Jump to content

Cura "initial layer height" bug?


BitNide

Recommended Posts

Posted · Cura "initial layer height" bug?

Hello UM community.

 

Recently I have been stumbling upon some failed prints which were poorle adhered to the build plate.

On closer expection it appears as if there was under extrusion on the first layer only. Assuming this was not a hardware issue I dove a bit into cura and found the following interesting result:

I tried slicing a tube which requires a good surface finish on all its sides. at a 30 degree angle I figured I'd get decent sides while maintaining stability over the entire height due to supporting structue. The position:

image.thumb.png.de017c2f8305efa0c2781ed32df7d329.png

Slicing the model solo, which virtually does not touch the ground. The initial layer height appears to be ignored by cura and set to the layer height 0.15:

image.thumb.png.008906984a74c4aba7277c35986d81c7.png

 

When I add a flat model to the mix, suddenly the initial layer height is turned up to the intended value 0.3:

image.thumb.png.63cfa3ee76f16b1e9e82f4ada12e0b29.png

 

Now this in itself would not be much of a problem. However the Ultimaker itself will raise up to 0.3mm on the first layer regardless of the sliced layer thickness. The result is about 50% underextrusion in the first scenario .

 

I am quite sure that this is what is happening. I tested this by powering off the UM3 on the first layer and attempting to then manually place 0.1 0.15 0.2 0.25 and 0.3 mm layers under the nozzle. The 0.25 was almost free moving while the 0.3 got significant resistance. Increasing the material flow for the first layer by a factor 2 also solved the problem in the first scenario, further confirming my measurement and suspision.

 

Is anyone else able to reproduce this result? If so is this a bug in Cura or am I incorrectly understanding the slicer? Any thoughts on the matter and how to tackle it would be helpfull as well.Manually checking the first layer thickness and adjusting the Initial layer flow is not realy managable with the amount of people that use the UM3 through the que.

 

 

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
         
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    ×
    ×
    • Create New...