Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Posted · Cura imports stl wrong

Hi, I am trying to import an STL file, I created in FreeCAD. It has a hole in the hull of the object and behind that hole there are two pins inside the object (see attached FreeCAD screenshot).

When I import the STL in Cura, there are no walls around the whole object where there is the hole in the hull (see attached Cura screenshots). However the wall and the hole are visible in light grey, Cura just doesn't print it.

 

Does anyone have any idea, what I might be doing wrong?

 

CURA:

cura1.thumb.PNG.0fc548e1f3d1bc9c3c825d9f20165809.PNG

cura2.thumb.PNG.21005db9cd036b5cb5e9c82fbd0375ab.PNG

 

FreeCAD:

freeCad.thumb.PNG.c50b5fee28e3f25ce3ce050a78711db2.PNG

  • Link to post
    Share on other sites
    Posted · Cura imports stl wrong

    The problem is, I specifically want it to be "not watertight". I need access to the pins, that are inside the object.

  • Link to post
    Share on other sites
    Posted · Cura imports stl wrong

    "Watertightness" doesn't require the model to be completely solid, you are allowed to have holes. What it does require is that all the surfaces join up with no gaps. It should be possible to fill the internal volume of the model with liquid without it leaking out between the model's polygons.

  • Link to post
    Share on other sites
    Posted · Cura imports stl wrong

     I understand the problem. It's not a watertight solid. I found a way to import it somewhat fine using meshmixer to create a hollow with an offset which makes the outer Hull actually have a thickness to it. Now the problem is, that's not really what I want. The result in cura now can't be printed with infill since the actual inside of the model is only within the walls. Also cura sees both sides of the wall as outer Perimeter. I understand the problem but actually am looking for a way to just prevent printing part of the regular model's wall.. In other words: I would basically like to set the whall line count to zero in that particular area. I just tried to use the support blocker and "Modify settings for overlap" but that doesn't do anything.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...