Jump to content

Ultimaker 2 blocks after 10 seconds of operations


Recommended Posts

Posted · Ultimaker 2 blocks after 10 seconds of operations

Hi all, we received our Ultimaker2 last friday. After fixing some minor issues (mostly related to how UM2 has been assembled) we started printing. We only used the SD print, we never tried to print with Cura.

We successfully printed 2 UltimakerRobots :) (just to tune the printer) and finally yesterday we started to make some more "serious" things :) Not too complex (basic cylinders to assess the resolution of the printer).

After 2 prints the UM2 has stopped to work. Front panel was blocked.

We supposed the problem was related to the Cura conversion of our STL so we tried to re-generate the gcode.

Same problem. We tried to print again the UltimakerRobot using the original SD. Same issue. After ~20 seconds the printer is blocked.

We have read some forum hints so we decided to restore factory defaults (same problem) and then re-flash the firmware (using Cura 13.11). Same as before.

After the restore of the factory setting we had to "initialize" the printer. Even the positioning of the build plate during the calibration phase blocks the printer.

As last test, we tried to print using Cura. Of course the print fails but what we noticed is that while the front panel is blocked, the software jog controls (one of the tab of the Cura print panel) are working, I mean, we were able to command the printer via USB but not using the front panel.

Has anyone else seen similar problems?

Thank you in advance for your support.


  • Link to post
    Share on other sites

    Posted · Ultimaker 2 blocks after 10 seconds of operations

    Contact support. We've recently identified a problem with the cables going to the front panel, which could be causing your issue.

    In the mean time, you can check the bottom of the machine. Not sure how willing you are to pull thing apart, but the cable going from the display to the main electronics should not have any loops or twists in it, this causes serious communication issues with the SD card and the display. (If you're not comfortable at checking this yourself, contact support by email, I'm sure they have more solutions they can offer then I can)

    We're also making some modifications to this cable to improve it, and providing better instructions for our assembly line.


  • Link to post
    Share on other sites

    Posted · Ultimaker 2 blocks after 10 seconds of operations

    Hi Daid,

    Thank you for the information. Yesterday I sent an email to the support. I hope to receive some help soon. I tried to open the bottom box covering the electronic but I need also to "release" at least the left side panel.

    By the way I noticed that 2 wires of the Z stepper motor are crushed between the metal box and the bottom panel.

    Ultimaker2 Crushed Cables

    I dont know if this may cause any issue.


  • Link to post
    Share on other sites

    Posted · Ultimaker 2 blocks after 10 seconds of operations

    Start by taking this cover off. I did it a few days ago. Was very easy to do:



    In the top right corner you can see the 2 gray ribbon cables Daid was talking about.

  • Link to post
    Share on other sites

    Posted · Ultimaker 2 blocks after 10 seconds of operations

    Hi GR5,

    I just removed the cover. I would say, the cabling of your printer is a little bit better than mine :shock: .....

    UM2 Board Cabling

    As you can see, 2 of the Z Stepper wires are almost cutted

    UM2 Z Stepper Crushed Wires

    Without the cover the problem seems disappeared. Maybe there is some shorts between the wires of the stepper motor.


  • Link to post
    Share on other sites

    Posted · Ultimaker 2 blocks after 10 seconds of operations

    They are *almost* cut but not quite. I don't think that's the problem. No - look at that big black cable bundle at the top right corner - inside there are 2 gray ribbon cables plus other stuff. Those 2 gray ribbon cables are the problem. I think.


  • Link to post
    Share on other sites

    Posted · Ultimaker 2 blocks after 10 seconds of operations

    Hi GR5, thank you again for your support. I have not touched the gray cables because as soon as I removed the metallic cover the printer started to work.

    What for me is not acceptable is that I've not bought a 50 bucks chinese toy where the "almost" cutted wires could be something usual to see.

    Ultimaker2 costs 2500 dollars and I guess the price is not linked to the cost of the single parts, but this is the price to pay to have what Ultimaker defines in their home page:


    • Easy to use and reliable
    • Designed for non-expert and expert

    Now I briefly summarize all the problems I found in the printer I received:

    1) the X slider block was shifted on the right. As draw back the home microswitch (on the top-left of the printer) was not touched by the slider so that the stepper motors did not stop at home position

    UM2 Home Microswitch

    2) the other side of the slider was touching the internal right panel

    UM2 Right Panel

    (Thank you to Sander we fixed the problem)

    3) the wires of the home microswitch were touching one of the motor belt

    4) the bottom cable connecting the build plate was under the plate so that when then plate was lowered it was bandy

    5) the Z stepper wires are "almost" cutted

    6) the printer doesn't work with the metal cover installed

    7) the wiring seems made by my 5 year old son

    If this is the definition of easy to use, reliable and designed for non-expert then it's ok.

    In addition to that, I sent several mails to support and sales but, up to now, I've not received any reply.


  • Link to post
    Share on other sites

    Posted · Ultimaker 2 blocks after 10 seconds of operations

    Is there any reason why nobody from sales and support is replying to my emails? Is there any holidays in Netherlands?


  • Link to post
    Share on other sites

    Posted · Ultimaker 2 blocks after 10 seconds of operations

    Hi Luca,

    Thank you for your patience.

    I will ask my colleague from technical support to get back with you on a short notice.

    Thank you for your patience.

    If I understand correctly issue 1 and 2 have been solved?

    Are you still experiencing difficulties with the other points?

    Some seem to be inconvenient, but not necessarily causing problems.

    If will sent you a new Z stepper motor, so you can replace the one you have now.

    I am not sure about the cover of the electronics, my initial thought would be not a short circuit, but by placing the cover you bend the wire in a way it gets interference. I will get back with you on this one.

    Thank you for your time and patience, have a great day.

    And I am looking forward to hear from you on the status of your other points.


  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.3 stable released
        In this stable release, Cura 5.3 achieves yet another huge leap forward in 3D printing thanks to material interlocking! As well as introducing an expanded recommended print settings menu and lots of print quality improvements. Not to mention, a whole bunch of new printer profiles for non-UltiMaker printers!
          • Thanks
          • Like
        • 56 replies
      • Here it is. The new UltiMaker S7
        The UltiMaker S7 is built on the success of the UltiMaker S5 and its design decisions were heavily based on feedback from customers.
        So what’s new?
        The obvious change is the S7’s height. It now includes an integrated Air Manager. This filters the exhaust air of every print and also improves build temperature stability. To further enclose the build chamber the S7 only has one magnetically latched door.
        The build stack has also been completely redesigned. A PEI-coated flexible steel build plate makes a big difference to productivity. Not only do you not need tools to pop a printed part off. But we also don’t recommend using or adhesion structures for UltiMaker materials (except PC, because...it’s PC). Along with that, 4 pins and 25 magnets make it easy to replace the flex plate perfectly – even with one hand.
        The re-engineered print head has an inductive sensor which reduces noise when probing the build plate. This effectively makes it much harder to not achieve a perfect first layer, improving overall print success. We also reversed the front fan direction (fewer plastic hairs, less maintenance), made the print core door magnets stronger, and add a sensor that helps avoid flooding.

        The UltiMaker S7 also includes quality of life improvements:
        Reliable bed tilt compensation (no more thumbscrews) 2.4 and 5 GHz Wi-Fi A 1080p camera (mounted higher for a better view) Compatibility with 280+ Marketplace materials Compatibility with S5 project files (no reslicing needed) And a whole lot more  
        Curious to see the S7 in action?
        We’re hosting a free tech demo on February 7.
        It will be live and you can ask any questions to our CTO, Miguel Calvo.
        Register here for the Webinar
          • Like
        • 18 replies
      • UltiMaker Cura Alpha 🎄 Tree Support Spotlight 🎄
        Are you a fan of tree support, but dislike the removal process and the amount of filament it uses? Then we would like to invite you to try this special release of UltiMaker Cura. Brought to you by our special community contributor @thomasrahm
        We generated a special version of Cura 5.2 called 5.3.0 Alpha + Xmas. The only changes we introduced compared to UltiMaker Cura 5.2.1 are those which are needed for the new supports. So keep in mind, this is not a sneak peek for Cura 5.3 (there are some really cool new features coming up) but a spotlight release highlighting this new version of tree supports.  
          • Like
        • 29 replies
    • Create New...