Jump to content

Objects sliced with cura cause print head to ignore z endstops


Recommended Posts

Posted · Objects sliced with cura cause print head to ignore z endstops

For some reason whenever I slice a model using cura and then try and print it, the first thing it does is raise the bed to the point where the springs are being compressed by the force of the print head pushing into it. When I just use pronterface, g0 z0 the z homes so that the print head is just in contact with the bed, no force applied. This is fine. However for some reason the line G0 F3600 X83.285 Y93.126 Z0.3 in the GCODE makes it ignore the z endstop totally and push into the bed. Any idea why this is happening? It also seems to ignore me if I use pronterface to manually adjust where z0 is using g0 z0.5, then g92 z0, and still pushes into the print bed. Is there any way I can fix this? I've attached my GCODE in case it's a command somewhere else, but I've looked through it and I can't see where it could be... Could it be a firmware issue?

CFFFP_3DBenchy.gcode

  • Link to post
    Share on other sites

    Posted · Objects sliced with cura cause print head to ignore z endstops
    54 minutes ago, nadmin95 said:

    command somewhere els

    The Z endstop is hard against the Z switch.  I don't think a negative Z is actually possible IF the Home Offset Z is zero.

    In Pronterface send an M503.  Looking through the response find the line that is M206 and check the Z value.

    If it isn't zero then you need to reset it.  Send M206 X{whatever your X is} Y{whatever your Y is} Z0

    Then level the bed using the good old fashioned piece-of-paper method and then start a print and see how it goes.  You can abort the print after seeing how it starts.

    You didn't mention if you are using a BLTouch or some other automatic leveler.  If you are, then doing the above has taken it out of the equation.  If you level the bed again using the Auto system and then print the same file, how does it look?  If it starts out low again, then the problem is in the auto-leveler system.

  • Link to post
    Share on other sites

    Posted · Objects sliced with cura cause print head to ignore z endstops

    Hi, it is an auto levelling system but it was custom designed for the machine IIRC. I have fixed it by removing the line in my start gcode which claimed to lower the bed by 15mm. For some reason this jerked the print bed and caused the clutches on the automatic levelling system to slip, meaning the z value was no longer valid. Removing this line has fixed the issue. Thanks for your help!

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...