Jump to content

Some help needed - Entry point not found


TimeLord11

Recommended Posts

Posted · Some help needed - Entry point not found

Hello, I was directed to here after contacting Ultimaker in Facebook.
If this is not the right forum then please refer me to the right one šŸ™‚
I have a problem which I can't solve:
I have an HP Pavilion laptop running Windows 8.1, 64 bits.
Up until few days ago it worked perfectly fine, I had on it the latest version of Cura, V4.6.
Then due to a problem that seems to come from an update to Windows I had to do a refresh to repair my computer, with that all programs including Cura were lost.
I tried to re-install Cura 4.6 only to get an error message about missing DLL files, I downloaded a total of 24 DLL files (as instructions said I need both 32 and 64 bit versions of them) and placed them in the right windows folder in hope that this would solve the problem, but sadly it does not.
I now get the following error:

688825847_curaerror2.png.0d295cd101369dfc47c5bedc69d4b564.png

Ā 

I have tried to install older versions of Cura and I still get this error, the only version that actually does work is 15.04.6

Is there anything I can do? I don't have enough money right now for a new computer, nor do I have the original installation disk of Windows 8.1

Thanks ahead.

  • Link to post
    Share on other sites

    • SandervG changed the title to Some help needed - Entry point not found
    Posted · Some help needed - Entry point not found

    I have not used Windows 8 in a long while, but as far as I know Cura should just work on it. Unfortunately, if you download dll files and put them somewhere on your system, that gets your system in a state where we don't know what versions of what files are where, making it harder to help you. Do you still have a list of dll files you installed?

    Ā 

    It sounds like the "Visual C runtime redistributables" are corrupted and/or have mismatching versions. The Cura installer comes with these redistributables and offers to install them for you. It could be that the installer thinks a newer version is already installed on your system (especially if you make a habbit of manually downloading DLLs and putting them on your system). You could try uninstalling any and all "Microsoft Visual C++ Redistributable" from your system, and then install Cura again. NB: this may affect other applications on your system.

    • Like 1
    Link to post
    Share on other sites

    Posted · Some help needed - Entry point not found

    It was the first time that I downloaded DLL files in order to solve something like this.
    Before that I tried to re-install Cura but got error messages about the missing DLL.
    I tried to ask on Facebook in a 3D printing group, but the only person who replied refused to help me when he found I still use Windows 8.1
    On the site where I downloaded the files the instructions were that each 32bit version of the DLL to be copied to the folder
    C:\Windows\SysWOW64, and each 64bit version of the files to be copied to C:\Windows\System32.

    Ā 

    List of the missing files is:
    api-ms-win-crt-conio-l1-1-0.dll
    api-ms-win-crt-convert-l1-1-0.dll
    api-ms-win-crt-enviornment-l1-1-0.dll
    api-ms-win-crt-filesystem-l1-1-0.dll
    api-ms-win-crt-heap-l1-1-0.dll
    api-ms-win-crt-locale-l1-1-0.dll
    api-ms-win-crt-math-l1-1-0.dll
    api-ms-win-crt-process-l1-1-0.dll
    api-ms-win-crt-runtime-l1-1-0.dll
    api-ms-win-crt-stdio-l1-1-0.dll
    api-ms-win-crt-string-l1-1-0.dll
    api-ms-win-crt-time-l1-1-0.dll

  • Link to post
    Share on other sites

    • 11 months later...
    • 3 weeks later...
    Posted (edited) · Some help needed - Entry point not found

    Yep me to exact same issue ???? HELP and same issue on my windows 8 and Windows 10 machines... I'm thinking there's a fault with Cura now not just me....... Oh well they may loose me soon as I don't have time to waste on software that's not supported.

    Ā 

    Edited by GTRClive
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series Ā 
        New features
        Ā 
        Temperature status.Ā During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state.Ā It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, theĀ Dump logs to USBĀ option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory.Ā If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to selectĀ Confirm removalĀ on the printerā€™s display. VisitĀ this pageĀ for more information about this feature.
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        Ā 
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method andĀ Method XLĀ printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning itā€™s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    ×
    ×
    • Create New...