Jump to content
Ultimaker Community of 3D Printing Experts

Stuttering/Pausing in latest Cura Version


Recommended Posts

Posted · Stuttering/Pausing in latest Cura Version

Hello Guys, 

 

I have Three Printers: A Ender 5 Plus, a Anycubic Kossel Linear Plus (Upgraded to 32bit) and an Renkforce RF100, and on all I encountered stuttering when I want to print round objects or some with a curve. I need to go as low as 35mm/s to keep it under control. 

Kossel (since Delta) runs on 32Bit with increased lookahead-Buffer, Ender 5 only 8 as well as the RF100 (but all of them have TMC2208 in them). 

I used a circle as test: Prusaslicer and all printers print fine and without any stuttering, I've Pushed the Delta to 70mm/s and it printed fine (only the hotend struggled a bit, but the whole thing runs only on 12V...). Also The 5 plus printed fine. 

Is there a solution? It is clearly slicer related, cause on Prusa everthing is fine and dandy, only with Cura it isn't nice anymore. 

Tweaked setting are: Model resolution, max. deviation, max. Resolution, none of which caused it to get better. With Prusa with the same model and as close as possible setting, everything easy. 

I like Prusa, but there are missing some options (coasting, Z-Wipe etc.) which have resulted in very nice and good looking prints. 

 

Also in the Kossel's Firmware I disabled S-Curve acceleration, but also helped nothing. 

 

  • Link to post
    Share on other sites
    Posted · Stuttering/Pausing in latest Cura Version

    Look at the gcode for a known stuttering circle (a known layer where it does it - I predict it won't do it every layer).  How many gcodes for a circle and how big is the circle?  You wan't the buffer length of the printer (really?  Only 8?) to be long enough that the printer can go from full speed (e.g. 70mm/sec) to stopped in that distance.  It depends on the acceleration.  Say it's really slow - 1000mm/sec/sec.  You can get 0 to 70mm (or back) in 2.45mm.  So you don't want more than 8 gcodes in a distance of 2.45mm.

     

    This is almost surely the problem.  If the acceleration is 2000mm/sec/sec you can get from 70 to 0 in just 1.22mm (wow - I didn't expect it to be linear).

     

    If you want to go 35mm to 0mm with acceleration at 1000mm/sec/sec you only need 0.61mm.  Wow - again it appears to be linear.  Not what I expected.  Anyway you get the idea - having half the buffer length and possibly lower acceleration can make a big difference and cause stuttering.

     

    So in your cad you could just output fewer triangles to the STL.  I've seen some crappy STLs where hundreds of triangles converge on one point (on a cylinder part).  Most cad won't do that.  But you can have 100 short gcodes just above and below that point all within 1mm.  Makes the printer almost completely stop.

  • Link to post
    Share on other sites
    Posted · Stuttering/Pausing in latest Cura Version
    25 minutes ago, DrDOHC said:

    weaked setting are: Model resolution, max. deviation, max. Resolution, none of which caused it to get better.

    Seems like the right track to me.  Seems like we are thinking it's the same or similar thing.  It could be the prusa slicer does this better (reduces gcodes).

  • Link to post
    Share on other sites
    Posted · Stuttering/Pausing in latest Cura Version

    Hey gr5, thanks for replying. 

    The accelerations of the delta are 1500-2000 I think, Jerk is 15. Buffer is set to 64, I looked it up really quick. 
    I will look into the gcode on both files with the same object. 🙂

    Well, my printer does stutter on every layer, the results aren't very nice and smooth. 

    I used on Fusion 360 first the high, then the medium and then the low setting, only at the low setting the stuttering was reduced, but didn't go away. The circle is 2mm wall thickness and 100mm in Diameter. 

    Also when I want to print a vase in Cura, the printer stutters at round objects, even at 35mm/s. 

     

  • Link to post
    Share on other sites
    Posted · Stuttering/Pausing in latest Cura Version

    Yeah I'm used to Ultimakers with 5000 to 9000 acceleration.  Bowden printers have much higher accel as the print head is light weight.  

     

    Can you upgrade the firmware on the printer to do 16 gcode look ahead?   Or even better, put a duet controller on there - are you familiar with duet?  Very nice controller - easy to use - very easy to setup for a new printer.  It's just a delightful interface.  I'm told (I don't have one).

     

    Or possibly resign yourself to printing 35mm/sec max speed.

     

    Or use prusa slicer.

     

    Or.... there is "max deviation" and "max resolution".  Try doubling those.  It might reduce quality.  Really it's better to reduce resolution in fusion.  I'd look at the STL in some other software to see what they actually look like visually.  I wouldn't be surprised if the resolution is still 10X higher than needed in your current STL.

     

    @burtoogle - I don't play with "max deviation" and "max resolution" but wasn't there some improvement you made recently?  Or Ultimaker did?  If there is an improvement - did it make it into the latest Cura?

     

  • Link to post
    Share on other sites
    Posted · Stuttering/Pausing in latest Cura Version

    second thought - could the heavy stuttering be doing tiny infills all around the cylinder and not from the skin walls?  If so there are improvements in that area also in the burtoogle version of Cura.  You could give that a shot.

  • Link to post
    Share on other sites
    Posted · Stuttering/Pausing in latest Cura Version

    @gr5 Well, my controller is a Bigtreetech SKR 1.4 (32 Bit, 120Mhz clockspeed), should be potent enough to drive the required speeds, It is not that I'm pushing my delta, for most delta printer enthusiasts I'm printing slow with it. 

    I have tweaked the firmware to 8, 16, 32 and 64 Gcode lookaheads, change was none visible, only in corners it got a bit better. 

    There are no small gaps that need to be filled. 

    It's happening in the outer shell: There the printer stutters, due to the bowden more filament gets squished out and then the model looks not nice anymore when the printheads slows rapidly down and then accelerates back up. ^^ 

     

    I'd happily try a beta/nightly build of Cura when there are some fixes applied. Honestly, it occurred only in the later versions of Cura, my most printing time I have spent pre 4.0 Release. Then even with the 8 Bit Ramps I could push 50mm/s without any hassle. ^^ 

     

    35mm/s is a waste of the fast delta. I mean I can live with some ringing and also light stringing, but not with heavy stuttering that ruins every model. Also, I like Prusa but I like Cura more, because it is more Intuitive and has way more settings to adjust than Prusa. Specially the Z-Seam adjustment in cura works well. 

     

     

  • Link to post
    Share on other sites
    Posted · Stuttering/Pausing in latest Cura Version

    Well I recommend 64 Gcode lookaheads.  My redeem printer has 256 lookaheads and it prints fine.

     

    Maybe the stuttering is something else - sharp corners - maybe increase the jerk a bit to see what happens.

     

    Did you look at the STL or the gcode to see if there was excessive points in the circle?  You shouldn't need more than one every mm or so but might find 10 or 20 all within a mm occasionally if the STL is decimated badly.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...