Jump to content
Ultimaker Community of 3D Printing Experts

Changing print speed within one object


Recommended Posts

Posted · Changing print speed within one object

Hi,

I have a model of two round objects connected with line. 393030189_Vstiek.thumb.PNG.ef6babb529c066479546cc1131b45089.PNG

But for some reason the line is printed with much higher speed than the two other object which with higher z-profile the printer doesnt like. Any suggestion how to equalize the printing speed in the model? I feel like I have already tried everything 🙂

 

Thanks!

Zuzana

  • Link to post
    Share on other sites
    Posted · Changing print speed within one object

    It might be your printer - it might be that there are too many line segments in the circles for your printer to process fast enough and it ends up printing too slow.

     

    1) Did you create this model?  Do you have the ability to access the original CAD model?  If so, when you export to STL - pay strong attention to the options.  Try to set the resolution low - if it's too high - for example if there are 1000 points in those circles that is too much.  20 to 60 points is more reasonable.

     

    2) In cura you have the color scheme set to "material type" so it's all yellow.  This is hiding lots of important information.  Normally you should set color scheme to "line type" but in this case set it to "feedrate".  See if indeed the line between the circles is a different color.  I doubt it.  If the circles and the line are the same color then the problem is with the printer.  Again - I suspect too many points in your circle - you may have set "resolution" or some other CAD feature to "extra high" or something like that and that may be causing the problem.

  • Link to post
    Share on other sites
    Posted · Changing print speed within one object

    Thank you for your answer! The original model was created in TinkerCad, meaning the resolution is really low, so this shouldn't be a problem.

     

    Setting color scheme to "line type" is really helpfull, thanks for the tip! It seems the problem is with the travelling:

    1745235396_Vstiek2.thumb.PNG.638675c23d43a82ca2fd172d24d26901.PNG

     

    It is vissible, that the printer shortens the way where it travels on few spots - and those are actually the spots where we have problem afterwards:

    IMG_20200929_125123.thumb.jpg.020b075a0ff8f118aa4e970a7707e176.jpg

     

    Any idea how to make the printer to take the same path every time?

     

    Thank you!

  • Link to post
    Share on other sites
    Posted · Changing print speed within one object

    Make sure combing is enabled.  It shouldn't be leaving the part (those blue lines) if combing is enabled.  If it still shows the blue lines then try enabling "print thin walls".  If it still has the blue lines then (just as an experiment) set the "line width" to 0.1mm.  just to see if the blue lines go away.  If they do you can set the line width down to about .33mm for a .4mm nozzle and not loose too much quality.  Or you can thicken that wall in CAD.

  • Link to post
    Share on other sites
    Posted · Changing print speed within one object

    But back to it "printing round parts slower".  I think you misunderstood.

     

    When tinkercad converts your cylinder into STL, because STL does not support any kind of curves - it only supports triangles, tinkercad turns those circles into polygons.  It could by a 5 sided polygon which wouldn't look much at all like a cylinder or a 20 sided polygon (about perfect for you) or a 1000 sided polygon.  But tinkercad makes a decision here.  I think/hope there is a way in tinkercad to set this value.  Usually some kind of "resolution" or "accuracy" setting somewhere in tinkercad hopefully?  If that circle has 100 or even 1000 polygons it will print those circles MUCH slower.

    • Like 1
    Link to post
    Share on other sites
    Posted · Changing print speed within one object

    Hello, I have the same issue,for example when I print a cylinder. When Tinkercad is converting to stl the final print is more of a polygonal rather than a cylinder. Should I export to obj would this solve the pfoblem?

    Thanks

  • Link to post
    Share on other sites
    Posted · Changing print speed within one object

    Sounds like the opposite problem.  It sounds like @zuzanah has too many sides to his cylindrical polygons and you have too few.

     

    This would be a setting in tinkercad.  Remember - too many polygons (thousands of edges in one circle of the cylinder) can make the printer slow down to a crawl.

     

    This article explains much more details:

    https://static.shoplightspeed.com/shops/608811/files/006831493/exporting-models-for-3d-printing.pdf

    [OOPS!  THAT ARTICLE INCLUDES TINKERCAD AND ALSO OTHER CAD SOFTWARE - It doesn't say how to change export resolution in tinkercad]

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...