Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker 2 worked until firmware update


Recommended Posts

Posted · Ultimaker 2 worked until firmware update

Printed one job great and then updated firmware. After firmware was updated no display on the LCD screen on the ultimaker itself and cura will not activate a print at all. Tried several times with the firmware update but still the LCD screen is blank on the machine. All that turns on is the fans and the LED lights. Machine is unusable.

  • Link to post
    Share on other sites

    Posted · Ultimaker 2 worked until firmware update

    A lot of people who have this issue don't actually have an Ultimaker printer.  There are some knock offs.  Can you take a photo of the print head and maybe a photo of the PCB underneath?  Most UM2 owners can tell by seeing only a small area of the printer if it's a knockoff or the real thing.


    Also is it a UM2+ or UM2 regular, Um2go, or extended?  Where did you get the firmware?

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    • Create New...