Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Posted · Cura ignoring small holes

Hi all,

I have a major problem with slicing the model in the attachement. It has a tiny hole in it (bottom right of the holes "section") and Cura ignores it. In the x-ray view the hole exists and returns no errors (no "red zones").

What I tried:

- turned off union overlaping volumes, remove all holes, extensive stiching,

- set maximum resolution to 0.05 (although I'm not sure what this does exactly). 

- I played with experimental "small hole max size" setting it both small (0.05) and big (3mm) 

- set initial layer height to 0.1 for 0.06 layer height

- fill gaps between walls: nowhere

- filter out tiny gaps off

- print thin walls on

 

My general settings:

-0.25 nozzle (Prusa MK3s), btw since Cura has only one nozzle size for Prusa I tried to change it manually in machine settings, but it doesn't work for some reason. I just changed it in line width section, maybe this is the cause? I've seen the topic with same issue and it recomended playing with .json file, to be frank I'm no programmer, so I don't want to touch it for now... 

-layer height 0.06

-all else deafult

 

I sliced the model in PrusaSlicer and the hole exists (prints as extremely small/just a contour) I just wanna use Cura because of a force of habit  I print in ABS and have all settings perfected, I need to use a raft and PrusaSlicer is giving me some really abismal results while Cura gave me a perfect print but without the hole :(

Przechwytywanie1.PNG

Przechwytywanie2.PNG

Przechwytywanie3.PNG

  • Link to post
    Share on other sites
    Posted · Cura ignoring small holes

    Did you design this part?  If so I can explain how to fix the model - I think the normals are backwards for that one hole.  I have instructions on fitting normals for 3 different cad packages.

     

    Otherwise, you can mess around with the checkboxes in the section called "mesh fixes".  Most notably maybe uncheck "union overlapping volumes" and maybe uncheck everything else as well.

     

    Also there's a feature somewhere that sets some resolution parameter when trying to loop rings of points together.

     

    Cura has an amazing plugin to test your model to see if something is wrong with it and can repair a very few of the many potential problems:
    In the upper right corner of Cura click "marketplace" and make sure you are on the "plugins" tab and install "Mesh Tools".  Then restart Cura.  Now right click on your model, choose "mesh tools" and first choose
    "check mesh", then "fix model normals" and "fix simple holes" to see if that helps.  Cura doesn't fix most issues so...

    netfabb free repair service is here (you have to create a free account first):
    https://service.netfabb.com/login.php

  • Link to post
    Share on other sites
    Posted · Cura ignoring small holes

    Thanks for a quick reply!

    Sadly it's not my model and I only have a .stl file, thanks for menioning netfabb, I have the pro version but I've never used it... Anyway, neither mesh tools nor online netfabb fixed the issue. Nettfab's desktop version also did nothing (but as I mentioned I opened it for a first time and just clicked on everything). I'll try to tinker with it some more, remesh it, maybe add a custom support and see. Below is netfabb's model analysis, it looks quite all right although it's hard to tell since I don't have the original project.  

     

     

    Przechwytywanie1.PNG

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...