Jump to content

Cura 4.7.1 Pause at Height Skipping Layer


cseighman

Recommended Posts

Posted · Cura 4.7.1 Pause at Height Skipping Layer

Hey everyone, trying to figure out an issue with my Ender 3 Pro using Cura's pause at height plugin. For some reason, it seems to skip the layer before the pause, and I'm not sure exactly why. For these settings, I watched the part be printed, and it printed fully at the 1.8 layer, paused, then resumed at 2.2, essentially skipping the layer at Z=2. I've attached my plugin settings as well as the section of the GCode where I believe the issue is, but I don't know enough about it to understand what the issue is. Using the latest TH3D firmware for the 4.2.7 silent board. Any help is appreciated!

PauseAtHeightSettings.PNG

GcodeSegment.PNG

  • Link to post
    Share on other sites

    Posted · Cura 4.7.1 Pause at Height Skipping Layer

    After digging into the GCode file, it looks like there may be a bug in the Pause at Height script.  I tried again but this time selecting the "Redo layer" and it went from 1.8 > 2.2 > 2.0 and then resumed layers regularly.  And digging into this GCode it appears to do 2.2 twice, so the initial script looks like it's seeing that split second of being at Z=2 and that's all there is for that layer.  I've attached my GCode files for the two scripts with and without selecting the "redo layer" option

    M0BuiltInLayerNoRedo.gcode M0BuiltInLayerRedo.gcode

  • Link to post
    Share on other sites

    • 2 weeks later...
    Posted · Cura 4.7.1 Pause at Height Skipping Layer

    There are several bug reports and a lot of discussion of this on Github.  The Cura team knows about the bug.  It appears it is not an easy fix.  I think "at height" works better if adaptive layers is off and there are no z-hops changing the height all the time.

  • Link to post
    Share on other sites

    Posted · Cura 4.7.1 Pause at Height Skipping Layer

    Sometimes with a newer version of Cura these kind of options don't work any more, they will be fixed in newer updates so sometimes you have to wait a little or use an older version!

     

    The times I used this option, it was always with "pause at layer"... therefore never noticed that "pause at height" didn't work.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.8 beta released
        Another Cura release has arrived and in this 5.8 beta release, the focus is on improving Z seams, as well as completing support for the full Method series of printers by introducing a profile for the UltiMaker Method.
          • Like
        • 1 reply
      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
    ×
    ×
    • Create New...