Jump to content
Ultimaker Community of 3D Printing Experts

speed travel wrong Unit in Cura [mm/s] - [mm/min]


DonBernos
 Share

Recommended Posts

Posted · speed travel wrong Unit in Cura [mm/s] - [mm/min]

Hello all,

 

I think I found a bug in Cura Software.

In start gcode you can implement the variable {speed_travel}. In Cura (German Version), it is related to the input field 'Bewegungsgeschwindigkeit' (travel speed)

The unit at input field in Cura is [mm/s]. If gcode is generated the value is transmitted 1:1 to gcode, that means e.g.

 

Input field Cura: 'Bewegungsgeschwindigkeit' (travel spped) = 120 mm/s

 

printer start code e.g. : G1 Z15.0 F{speed_travel} ;move the platform down 15mm

 

generated gcode        : G1 Z15.0 F120 ;move the platform down 15mm

 

but gcode uses as unit not mm/s, it uses mm/min !

 

I think when gcode is generated it must be 120 x 60 [mm/s] -> 7200 [mm/min]

 

Best regard

 

😉

 

 

  • Link to post
    Share on other sites

    • 2 months later...
    Posted · speed travel wrong Unit in Cura [mm/s] - [mm/min]

    The Cura max Z speed is in the Printer Settings (you may have to load the plugin from the Market Place).  That setting should place a limit within Cura.  If the person in the first post had it set to 2mm/sec (default is 10) then he can input 120mm/sec, but the Gcode would output 120mm/min.  

     

    Within the printer, M203 stores the max feedrates.  No matter what you enter into Cura as a setting, the max speed is governed by M203.

     

    echo:Maximum feedrates (units/s):
    echo:  M203 X500.00 Y500.00 Z25.00 E50.00

     

    The above is a response to M503 on my Ender.  You can see that the max Z feedrate is 25mm/sec.  If I enter 1000mm/sec in Cura, it's going to be limited to 25mm/sec when the printer sees the Gcode.

     

    At the beginning of a gcode file, if you have:

    M203 X900 Y900 X50 E50

    M500

    Then you will change the max feed rates of the printer to near their max possible.  M500 saves the change to memory (you only need to do it once).  Then check the Cura Printer Settings and make all the speed settings there match the M203 settings.

     

     

  • Link to post
    Share on other sites

    Posted · speed travel wrong Unit in Cura [mm/s] - [mm/min]

    This is not my case. I have an old version of Cura, customized by the printer manufacturer (ver 15.02.1, but is really old, maybe 7 years ago). This work well
    And I have a Cura version downloaded from the Ultimaker website (Ver 4.1). and this version does the conversion mm/s to mm/min wrong. This conversion is done with the factor 1 instead of factor 60. The code generated do not have the M500 or the M203 code. This is the beginning gcode (everything before the first line posted was commented by Cura). 
    PD: I added my printer to Cura, because it was not in the list:
    ;-------------------------------------------------------------------------------------------------------
    ;-------------CODE GENERATED BY CURA FROM ULTIMAKER WEBSITE-------------
    ;-------------------------------------------------------------------------------------------------------
    M140 S82
    M105
    M190 S82
    M104 S225
    M105
    M109 S225
    M82 ;absolute extrusion mode
    ;Sliced at: Thu 18-03-2021 01:11:13
    ;Basic settings: Layer height: 0.15 Walls: 1 Fill: {fill_density}
    ;Print time: 01:22:53
    ;Filament used: [2.29]m [16.0561306640625]g
    ;Filament cost: [0.0]
    ;M190 S82 ;Uncomment to add your own bed temperature line
    ;M109 S225 ;Uncomment to add your own temperature line
    G21        ;metric values
    G90        ;absolute positioning
    M82        ;set extruder to absolute mode
    M107       ;start with the fan off
    G28 X0 Y0  ;move X/Y to min endstops
    G28 Z0     ;move Z to min endstops
    G1 Z15.0 F120 ;move the platform down 15mm
    ;----------------------------------------------------------------------------------------------------------------------
    ;----------------------------------------------------------------------------------------------------------------------
    ;----------------------------------------------------------------------------------------------------------------------

    take a look to the last line:
    "G1 Z15.0 F120 ;move the platform down 15mm"

    this was done with the travel speed of 120 mm/seg
    and take a look of the same code generated by the old cura, with the same configuration:
    ;----------------------------------------------------------------------------------------------------------------------
    ;------CODE GENERATED BY CURA CUSTOMIZED BY THE MANUFACTURER---------
    ;----------------------------------------------------------------------------------------------------------------------

    M190 S82.000000
    M109 S225.000000
    ;Sliced at: Sun 14-03-2021 19:43:15
    ;Basic settings: Layer height: 0.15 Walls: 1.2 Fill: 0
    ;Print time: 4 hora 1 minutos
    ;Filament used: 3.741m 28.0g
    ;Filament cost: None
    ;M190 S82 ;Uncomment to add your own bed temperature line
    ;M109 S225 ;Uncomment to add your own temperature line
    G21        ;metric values
    G90        ;absolute positioning
    M82        ;set extruder to absolute mode
    M107       ;start with the fan off
    G28 X0 Y0  ;move X/Y to min endstops
    G28 Z0     ;move Z to min endstops
    G1 Z15.0 F900 ;move the platform down 15mm
    ;-----------------------------------------------------------------------------------------------------------------------------
    ;-----------------------------------------------------------------------------------------------------------------------------
    ;-----------------------------------------------------------------------------------------------------------------------------

    Is clear that this is happening. how to solve it?
     

  • Link to post
    Share on other sites

    Posted · speed travel wrong Unit in Cura [mm/s] - [mm/min]

    I have Cura 4.6 as my oldest install.  I checked on Github and didn't see any obvious references to the speed problem you are having.

    The newest version is 4.8.  Can you update to that and see if the problem still occurs?  You can keep your older installations of Cura when you update.  

     

     

  • Link to post
    Share on other sites

    Posted · speed travel wrong Unit in Cura [mm/s] - [mm/min]

    @GregValiant The program uses mm/s and G-code uses mm/minute, as the original post mentioned. It is an issue in which Cura doesn't support a standard. I've added it as a new issue: https://github.com/Ultimaker/Cura/issues/10636

  • Link to post
    Share on other sites

    Posted · speed travel wrong Unit in Cura [mm/s] - [mm/min]

    PrusaSlicer, Ideamaker, MatterControl, Chitubox64, Mingda Printer, QidiPrint, Repetier, PrintRun, and Lotmaxx are all the same as Cura.  Input is in mm/sec and gcode output is mm/min.  It would be kind of interesting to know how that got started as it seems to have become a defacto standard.  I did some work cutting toolpaths for CNC mills but it was a long time ago and I can't remember what units were involved.  (I just want to be clear on this - I am NOT so old that it would have been "cubits/week".)

     

    I had wanted to change my speed settings for my purge lines to give them some flexibility (for when I print TPU) but as you noticed there is no keyword for {speed_print_mm_per_min}.

     

    I think it could be done in PrusaSlicer because it appears that math is allowed in StartUp Gcode so {speed_print}*60 may be viable over there.

    • Like 1
    Link to post
    Share on other sites

    Posted · speed travel wrong Unit in Cura [mm/s] - [mm/min]

    I would also find it useful to have the ability to do math in the start up script to accomplish this exact example of {speed_print_mm_per_min}. Is there a known way to accomplish this?

  • Link to post
    Share on other sites

    Posted · speed travel wrong Unit in Cura [mm/s] - [mm/min]
    38 minutes ago, jacobdobbratz said:

    Is there a known way to accomplish this?

    No, there is no way to do this at this point.

    • Like 1
    Link to post
    Share on other sites

    Posted · speed travel wrong Unit in Cura [mm/s] - [mm/min]

    Sad to hear but understandable. Thanks for getting back so quickly and for all the work you do on here.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...