Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Posted · Cura stl from Sketchup Problems

Hi,

I’m new to 3D printing and just joined this group. I’m hoping someone can help me with a problem I’m having printing a model.

I’m using Sketchup Pro 2021 version to produce the model. Actually the model is an import from their 3D warehouse.

I’m using Cura 4.8.0  and have 2 printers, Anycubic Mega S and Creality CR-10S Pro v2

I am doing a project for my wife’s 65 th birthday and have been trying to add a Ribbon bow to the model. Not necessary but a nice touch. I imported a model from Shetchup 3D warehouse, scaled it to size required and exported it to an STL file. Tried slicing it in Cura, but it didn’t slice properly. Most of the bow wouldn’t print.

I figured the problem was because the surfaces in most of the model had no thickness, so I tried to add a 1mm thickness to all those surfaces. Problem: Sketchup will not thickness curved surfaces. I found a plugin, Fredo JointPushPull, which worked great and the model look good in Sketchup. I exported it to an STL and opened it in Cura. It looked good on the build platform, but when sliced most of the model wouldn’t print. I’ve tried many ways to correct this but nothing seems to work. I am thinking the problem is the translation from Sketchup to the STL.

Thanks for your help

Dave

Screen capture 1.JPG

Screen capture 2.JPG

Cura 1 mm thick.3mf STL from Shetchup 1mm thick.stl

  • Link to post
    Share on other sites
    Posted · Cura stl from Sketchup Problems

    I cannot give you a real solution for your problem, but Sketchup is known to produce non working STL files. It is not the app of choice to create models for 3D printing. So best you choose and use another CAD software for 3D printing you will always have troubles with Sketchup.

  • Link to post
    Share on other sites
    Posted · Cura stl from Sketchup Problems

    As Smithy says: SketchUp is going to be an endless nightmare. In the time you need to correct its defective models, you can learn another editor that does work. SketchUp was never designed for 3D-printing, it was ment for visual models only, like in architectural sketches, computer games and virtual reality.

     

    I use DesignSpark Mechanical, freeware from RS (electronics supplier), requiring only registration. But there are other good programs too.

     

    Look on Youtube for tutorials, and try one that appeals to you.

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker turns 10: A look back
        Ultimaker is turning 10 years old and that means it is story telling time! We'll explore 2010-2014, traveling through the evolution of the business from the Protobox and Ultimaker Original, to the major leaps forward with the Ultimaker 2 and Ultimaker 3.
        • 0 replies
      • Ultimaker Transformation Summit
        Visit our virtual showroom and learn more about the Ultimaker ecosystem!
        • 14 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
        • 4 replies
    ×
    ×
    • Create New...