Jump to content

Error: Z Switch is Broken.


sbblcift

Recommended Posts

Posted (edited) · Error: Z Switch is Broken.

Hello, with my UM2+ I recently had the issue "Z Switch is broken ER05" although I am pretty sure that my Z switch is okay.
In order to check the HW, I mounted a fully working control board and tested the functionalities. Everything seemed to work perfectly. I assume that my current control board has an issue. I installed Marlin 19 and 17 to test with another FW. The same error. Also did a factory reset unfortunately didn't do much difference. 
I also tried swapping the X-Axis Motor Connection with the Z-Axis Motor Connection. Then the error suddenly turned to "X or Y Switch is Broken" which has made me even more suspicious about a possible SW issue. I also pushed down my heated bed all the way down till it hit my Z-Switch. In this case i received "Z-Switch is stuck". 
Once I tried to move the X,Y and Z Axis manually with CURA via USB I noticed that none of the steppers are actually responding. This seems very weird. Has anyone encountered such problem recently? It didn't look like an HW issue since all the steppers stopped working suddenly. 

Edited by sbblcift
  • Link to post
    Share on other sites

    Posted · Error: Z Switch is Broken.

    Your Z switch is fine.  It's your Z stepper that isn't moving.

     

    When you first home the Z axis it moves the bed down until it hits the switch then up until it doesn't and then down until it does.  If it switch doesn't respond within a certain time then you get the ER05.  If it is always down then you get the "stuck" error.  In both cases, many things of course can cause the error.

     

    So to diagnose I need more info.  Do none of the motors ever move?  Did you not notice this back when you were getting the ER05?  When you swapped X and Z motor connection did the X motor start moving but not the Z?

     

    Some possibilities:

    1) Z stepper driver broken - this is common - these stepper drivers get very hot!  They work hard and can fail

    2) Cables to Z stepper broken

    3) Stepper broken (almost impossible - this is probably not it)

    4) 24V signal to steppers not connected (common - there is a relay, K1, that can block 24V to the heaters and steppers - heat won't work either if this is the issue)

     

    These are all very easy to diagnose since the symptoms are quite different.  For example with #4 you can't get the nozzle or bed to heat up.  With #1 you can swap cables to diagnose.

     

    If it's #1 and you have an old enough printer then there is an extra driver for the second extruder but newer PCBs don't have that chip installed.  It's pretty obvious since the stepper drivers are a large square chip positioned in a way that they are near and lined up to the 5 stepper connectors.  If you do have an older PCB you can then remap the extra extruder driver in the pins.h file and rebuild Marlin.  I can send you links to more details.  If you have a newer PCB then best course of action is to order a new PCB.

     

     

     

  • Link to post
    Share on other sites

    Posted · Error: Z Switch is Broken.

    By the way, it's good you did the factory reset as another possibility is that the steps/mm or the "distance to go before reporting ER05" values can get messed up and factory reset changes these back to defaults.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...