Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
magmotor

No Limit Switches

Recommended Posts

I installed a brand new board and everything works great....it connects first time, every time, x y moves like it should, z nice and smooth both ways, extruder works great, the right amount of filament and temp is right on.....except: I have no working limit switches at all....manually pushing each switch while the motors are moving results in nothing...I did a continuity check on all switches and they work fine....I tried all axes and switches and none would stop the motor....Iam leaning toward a software problem because I can't believe it's another board issue...I am using Daid's Build Marlin-Firmware 115200 with nothing else changed on it....I am using an HP laptop XP 32bit...any ideas of what else I can do? Thanks for any informaton...!

Share this post


Link to post
Share on other sites

What's the reason for that? Seems to me that's pretty dangerous thing to do. Say, for whatever reason, the printer looses steps and thinks it's further away from an edge than it really is, then when it tries to move in that direction it will slam into the side of the machine thinking it still has room to move.

Share this post


Link to post
Share on other sites
My Marlin builder has "use endstops only for homing" enabled by default. So your endstops are only used for homing.

I loaded a small test print into your software. It immediately headed for the left front of the machine and did what Robert said, it slammed into the front and wanted to keep going...I shut the machine off, moved the head back away from the sides and turned it back on, the software kept going and moved the head to the center, leveled the bed and starting printing....at any rate from the setup instructions it says to make sure the limit switches work my manually pushing while the head is moving and none of them do.....should I have unchecked the 'enable homing' on your build software?

Share this post


Link to post
Share on other sites
What's the reason for that? Seems to me that's pretty dangerous thing to do. Say, for whatever reason, the printer looses steps and thinks it's further away from an edge than it really is, then when it tries to move in that direction it will slam into the side of the machine thinking it still has room to move.
Interference from the motors on the end switches can really ruin a long print.

 

My Marlin builder has "use endstops only for homing" enabled by default. So your endstops are only used for homing.

I loaded a small test print into your software. It immediately headed for the left front of the machine and did what Robert said, it slammed into the front and wanted to keep going...I shut the machine off, moved the head back away from the sides and turned it back on, the software kept going and moved the head to the center, leveled the bed and starting printing....at any rate from the setup instructions it says to make sure the limit switches work my manually pushing while the head is moving and none of them do.....should I have unchecked the 'enable homing' on your build software?

You should have unchecked "Endstops only for homing". It's not that recommended to go to a custom build firmware before you know how to operate your machine properly, and everything works hardware wise. UNLESS...

The firmware that's shipped with SkeinPyPy-Beta4 (Cura) has the endstops always enabled, exactly to prevent damage to your machine. It's also checked, and verified to work. So that's always a safe firmware to switch to.

The Marlin_Builder was more intended for experienced users that want to customize their firmware a bit. Without going trough all the Arduino loopholes. When I update to new Marlin versions (as I try to keep it up with the development) it might break from time to time.

Share this post


Link to post
Share on other sites

Ok thanks for that info....I didn't realize i was using custom firmware....I loaded up your Cura and got halfway thru the one time only wizard and it said it couldn't set the temp...so I went ahead anyway...loaded up an stl file, sliced and diced it, loaded that up into printrun, heated everything up and hit print...it did beautiful..!! except for one thing...all my test models are printing out to about 1/5 scale.....under your model config it does say scale: 1 so i figured 1inch would come out 1inch...but it doesn't....iam using autocad R2007 for 3D and my stls....would that make a difference?...or any idea why the scale is so much different.....thanks again...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Announcements

  • Our picks

    • Architect Design Contest | Vehicles.
      We're open for entries! - Design and submit your 3D designs of architectural entourage - vehicles - for a chance to win a large filament pack. Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled model can really help to get your idea across.
        • Like
      • 14 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 18 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!