Jump to content
UltiMaker Community of 3D Printing Experts

Cura not using Relative Extrusion


Sporech
 Share

Recommended Posts

Posted · Cura not using Relative Extrusion

Hi,

 

With Cura, I am trying to use relative extrusion. I have found the setting and it was already ticked. I made sure to slice my model with the setting enabled, yet looking at the GCode, it's using absolute extrusion?

image.png.d848ff6a6606e264afaafa851e41e18d.png

 

image.thumb.png.9cc24ab7ae1ec1588348ce2329cc0281.png

(Extruder argument clearly counting up)

 

Does anyone know if this is a bug?

 

Thank you

  • Link to post
    Share on other sites

    • 1 month later...
    Posted · Cura not using Relative Extrusion

    Hi,

     

    Sorry for the delay, my printer's start code doesn't contain a M82 instruction. Cura seems to be ignoring the relative extrusion setting, are there any other settings that could be overriding it?

     

    Thank you

  • Link to post
    Share on other sites

    Posted · Cura not using Relative Extrusion
    On 12/30/2021 at 9:27 PM, GregValiant said:

    You have ticked the setting "Relative Extrusion" in the "Special Modes" section?  Cura should be adding an M83 right after your start gcode.

    Yes, relative extrusion is enabled under special modes, but it is being ignored.

  • Link to post
    Share on other sites

    Posted · Cura not using Relative Extrusion

    With your model loaded and Cura set up ready to slice, use the "File | Save Project" command and post the 3mf file here.  I would assume it's a setting somewhere and it should show up in a project file.

  • Link to post
    Share on other sites

    Posted · Cura not using Relative Extrusion

    Sure, do take a look 

    UM3_test_cube.3mf

  • Link to post
    Share on other sites

    Posted · Cura not using Relative Extrusion

    "This setting has been hidden by the active machine and will not be visible."

    So it's an Ultimaker printer thing rather than a Cura thing.  It's called out in the base "ultimaker.def.json" definition files as an override.

     

    "relative_extrusion":
            {
                "value": false,
                "enabled": false

     

    Untitled.thumb.png.7f963afb09c2ed62f8f787a880a1363b.png

    • Like 1
    Link to post
    Share on other sites

    Posted · Cura not using Relative Extrusion

    Excellent! Thank you so much for finding that. Where are the machine JSON files saved?

  • Link to post
    Share on other sites

    Posted · Cura not using Relative Extrusion

    In Windows they are in "...Program Files\Ultimaker Cura 4.x.x\resources\definitions".

    I'm not very familiar with the UM line of printers but I would assume they put that in because Relative extrusion isn't quite as accurate as Absolute extrusion.  I'm not sure why that is but it may have to do with the way the numbers are rounded during the calculations.

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...