Jump to content
Ultimaker Community of 3D Printing Experts

"Print with OctoPrint" doesn't work on first try, works after trying two or three times


Galgofrit
 Share

Recommended Posts

Posted · "Print with OctoPrint" doesn't work on first try, works after trying two or three times

Ever since I got my printer and set up OctoPrint with Cura, it has been this way - 

I click "Print with OctoPrint", it seems to do nothing (although it does upload the file correctly to OctoPrint, as visible on the web interface) - 

A subsequent second or third click successfully starts the print.

I'm asking here (in case anyone knows), but I'm not entirely sure if it's a Cura issue or an OctoPrint/OctoPi issue.

 

Any ideas?

  • Link to post
    Share on other sites

    Posted · "Print with OctoPrint" doesn't work on first try, works after trying two or three times
    2 minutes ago, Galgofrit said:

    I'm asking here (in case anyone knows), but I'm not entirely sure if it's a Cura issue or an OctoPrint/OctoPi issue.

    It is neither. It is an issue with the OctoPrint Connection plugin for Cura, which I am the creator of.

     

    This bug has been reported before, here: https://github.com/fieldOfView/Cura-OctoPrintPlugin/issues/233

    What plugins do you have installed in OctoPrint?

    • Like 2
    Link to post
    Share on other sites

    Posted (edited) · "Print with OctoPrint" doesn't work on first try, works after trying two or three times

    Oh, great, thanks for the response!

    These are the ones I'm running:

    • Bed Visualizer
    • Enclosure Plugin
    • Exclude Region
    • FileManager
    • Firmware Check
    • Navbar Temperature Plugin
    • Preheat Button
    • Printer Dialogs
    • Printer Notifications
    • Telegram
    • Themeify
    • TouchUI
    • Virtual Printer

     

    (edit: at least based on the plugin list on the web UI... if you want any log LMK)

    Edited by Galgofrit
  • Link to post
    Share on other sites

    Posted · "Print with OctoPrint" doesn't work on first try, works after trying two or three times

    Yes, it seems to solve it completely (gave it multiple tries as well in case it's something racy) - so I guess it's indeed caused by a plugin.

    I can do a binary search and start disabling things, but before I do, is there any specific ones that seem like likely suspects?

  • Link to post
    Share on other sites

    Posted · "Print with OctoPrint" doesn't work on first try, works after trying two or three times

    From your earlier list, I don't see an obvious problematic plugin. I have not tested with any of them (apart from Virtual Printer, which is a bundled plugin). I am very interested to know which plugin turns out to cause this issue.

  • Link to post
    Share on other sites

    Posted · "Print with OctoPrint" doesn't work on first try, works after trying two or three times

    Okay, I'll start disabling things and let you know if I have any conclusions. Thanks for the tips!

  • Link to post
    Share on other sites

    Posted · "Print with OctoPrint" doesn't work on first try, works after trying two or three times

    Oh man, the list above wasn't the full list - I guess it was only the ones with configuration, since I took them from the side bar...

    The actual one that broke it seems to be Auto Select, which, based on the issue on GitHub, is something I assume you're familiar with - so I guess I wasted your time, sorry about that! At least I'm glad to have it solved and have everything working.

    On a side note, appreciate your work (and your willingness to help!) 

  • Link to post
    Share on other sites

    Posted (edited) · "Print with OctoPrint" doesn't work on first try, works after trying two or three times
    25 minutes ago, Galgofrit said:

    The actual one that broke it seems to be Auto Select, which, based on the issue on GitHub, is something I assume you're familiar with

    Thanks for letting me know anyway. I never got confirmation in that issue that Auto Select was the culprit.

    Edited by ahoeben
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • Ultimaker showcase | April 2022 | 4pm CEST | 10am EDT
        I'm excited because I've personally produced this showcase event, so if you are curious what else I'm up to nowadays, come check it out and say hi in the chat! It would mean a lot! 
          • Thanks
          • Like
        • 4 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...