Jump to content
Ultimaker Community of 3D Printing Experts

error: Ultimaker 2 extended plus suddenly starts moving very slowly and sometimes print on air...


Recommended Posts

Posted · error: Ultimaker 2 extended plus suddenly starts moving very slowly and sometimes print on air...

 

I got error which repeats randomly :  'Ultimaker 2 extended plus' suddenly starts moving v e r y    s l o w l y and sometimes print on air.

It does this in different Z - levels, with different pieces.

CPU card has been changed, axels doesnt drift with gears(i use color pen to mark axle and gear - all off them)

CPU version Ultimainboard rev. 2.1.4.    2016 software

 

20211006_083504.jpg

  • Link to post
    Share on other sites

    Posted · error: Ultimaker 2 extended plus suddenly starts moving very slowly and sometimes print on air...

    When it moves very slowly - does the extruder move a long distance?  If so then I am familiar with it.  Change the other board.  The one that the SD card goes into.  Or at least try cleaning the connectors where the SD card connects inside.  Also maybe move the two ribbon cables to a slightly new position.

     

    I had a single tiny hair - maybe an eyelash in the connectors.  After cleaning that the problem still happened but much more rarely.

     

  • Link to post
    Share on other sites

    Posted (edited) · error: Ultimaker 2 extended plus suddenly starts moving very slowly and sometimes print on air...

    The extruder starts moving in small area and very small distances -  almost over same place. Normally it should move from   cornert to other end of the piece(printed box here). Its like paralyzes over that small area. 

    Sometimes it survived it and start printing again.... mostly not

    Usually move to wrong place and starts printing on air. 

    With many workpieces, it melts them from the same points.

    Sometimes - not always - it seems that the worktable has lowered too much..

    2 samaa.JPG

    other piece.JPG

    Edited by WisePrinter
  • Link to post
    Share on other sites

    Posted · error: Ultimaker 2 extended plus suddenly starts moving very slowly and sometimes print on air...

    Well it could be that the stepper is losing steps but that would sound loud even though it wasn't moving far.  I think I've seen this exact issue.  And if I'm right, the feeder is moving long distances and the feeder has a speed limit that is making it so that X and Y move INCREDIBLY slow.  So try to see it happen in action and then reach around and feel the filament.  It should be moving long distances - like 100mm while the X or Y move very short distances.

     

    I could be wrong - it could be a stepper driver is overheating.  But I doubt it.  I think you are experiencing something that I've seen many times.  It's read errors on the SD card.  Where it moves the E axis (the extruder) about 100mm and then on the very next moves it moves the E axis back to where it was.  This can take easily 10 seconds for each tiny X/Y move.

     

  • Link to post
    Share on other sites

    Posted (edited) · error: Ultimaker 2 extended plus suddenly starts moving very slowly and sometimes print on air...

    Thanks a lot of Your ideas. This U2 has been about 4 months unused. We got S3 - printer so my time has been around it. 

    Now I am going to get attention again to this U2 - machine and do testing more now. 

    Testing is time consuming  due the error comes so randomly. 

    Edited by WisePrinter
  • Link to post
    Share on other sites

    Posted · error: Ultimaker 2 extended plus suddenly starts moving very slowly and sometimes print on air...

    From your description I'm pretty sure it is getting bad bits occasionally.  A little more detail.  99% of gcodes look like this

    G1 X123.45 Y75.71 E2132.324

     

    This is setting the next X,Y,E position.   Assume that all 3 axis are moving only maybe 2mm (and the E axis maybe 0.1mm) from the previous position.  You can see we are about 2 meters of filament into the print.

     

    If that "1" in 2132 switches to a 0 then it tries to backup 100mm in E axis which is much of the length of the bowden tube.  The printer will slow down a LOT because the E axis has a max speed of around 20mm per second so that will take 5 seconds.  The next command will have the 1 back to 0 as it is supposed to be and now you have to wait ANOTHER 5 seconds for it to recover.

     

    Why don't other digits get messed up?  they do.  but if an X or Y gets messed up it just very very quickly moves to the wrong position and then comes back and continues.  Giving you little minor bumps and holes.

     

    To remove the front PCB this is the only tricky step - remove the knob as described and then the nut:

    https://ultimakernasupport.zendesk.com/hc/en-us/articles/115004187086-The-Button-Won-t-Click

     

    Then you can either try cleaning the SD card slot or replace the whole thing.

     

    ALSO TRY A NEW SD CARD

     

  • Link to post
    Share on other sites

    Posted · error: Ultimaker 2 extended plus suddenly starts moving very slowly and sometimes print on air...
    22 hours ago, gr5 said:

    From your description I'm pretty sure it is getting bad bits occasionally.  A little more detail.  99% of gcodes look like this

    G1 X123.45 Y75.71 E2132.324

     

    This is setting the next X,Y,E position.   Assume that all 3 axis are moving only maybe 2mm (and the E axis maybe 0.1mm) from the previous position.  You can see we are about 2 meters of filament into the print.

     

    If that "1" in 2132 switches to a 0 then it tries to backup 100mm in E axis which is much of the length of the bowden tube.  The printer will slow down a LOT because the E axis has a max speed of around 20mm per second so that will take 5 seconds.  The next command will have the 1 back to 0 as it is supposed to be and now you have to wait ANOTHER 5 seconds for it to recover.

     

    Why don't other digits get messed up?  they do.  but if an X or Y gets messed up it just very very quickly moves to the wrong position and then comes back and continues.  Giving you little minor bumps and holes.

     

    To remove the front PCB this is the only tricky step - remove the knob as described and then the nut:

    https://ultimakernasupport.zendesk.com/hc/en-us/articles/115004187086-The-Button-Won-t-Click

     

    Then you can either try cleaning the SD card slot or replace the whole thing.

     

    ALSO TRY A NEW SD CARD

     

    Ok - thanks - I am on my way to replace the card after Easter with new one. After that something other study if error persists ...

  • Link to post
    Share on other sites

    Posted · error: Ultimaker 2 extended plus suddenly starts moving very slowly and sometimes print on air...

    Definitely try a new SD card first (much cheaper!).

     

    I know some people who replaced that board and it fixed the issue and other's where it didn't fix the issue.  Definitely try to move the ribbon cables even a tiny bit.  Like if you put some foam between the two cables to make them another 1mm farther apart.  Or change the routing so they go past a different chip than they do now.  Just moving 1mm can be enough.

     

    Your whole issue is intermittent where maybe one in 10,000 bits get flipped.  That can be from a bad connection to the SD card, the SD card itself, or electrical interference in the ribbon cables.  This type of issue is difficult to diagnose as it is intermittent.

     

    I had this problem on one printer.  Cleaning the contacts helped A LOT.  But the problem was still there (but reduced by 10X).  So I swapped the board with another UM2 thinking the problem would either move to the other printer or stay with the "bad" printer.  Well the problem went away at that point so I never figured out exactly what the problem was.  Maybe I had moved the ribbon cables slightly?

  • Link to post
    Share on other sites

    Posted · error: Ultimaker 2 extended plus suddenly starts moving very slowly and sometimes print on air...
    On 4/14/2022 at 5:38 PM, gr5 said:

    Definitely try a new SD card first (much cheaper!).

     

    I know some people who replaced that board and it fixed the issue and other's where it didn't fix the issue.  Definitely try to move the ribbon cables even a tiny bit.  Like if you put some foam between the two cables to make them another 1mm farther apart.  Or change the routing so they go past a different chip than they do now.  Just moving 1mm can be enough.

     

    Your whole issue is intermittent where maybe one in 10,000 bits get flipped.  That can be from a bad connection to the SD card, the SD card itself, or electrical interference in the ribbon cables.  This type of issue is difficult to diagnose as it is intermittent.

     

    I had this problem on one printer.  Cleaning the contacts helped A LOT.  But the problem was still there (but reduced by 10X).  So I swapped the board with another UM2 thinking the problem would either move to the other printer or stay with the "bad" printer.  Well the problem went away at that point so I never figured out exactly what the problem was.  Maybe I had moved the ribbon cables slightly?

     

     

    Hi again. And thanks A LOT. 

     

    You are right  - after I change new electrical card for display and SD - card, and buy new SD card - U2 start printing rightly the erreneous piece. 

     

    I make test print 2 times - takes about 7 hours each - everything goes right !

     

    Now I have U2 printer for years to come working. 

     

     

    What about the firmware ?  I haven't yet find the latest version. 

    Our printer have the original firmware from year 2016 or something. 

     

    Thanks again! 

     

     

    vaihdetut.thumb.jpg.829a4acf21d6fff6eb6e0e16cc20c358.jpg

     

  • Link to post
    Share on other sites

    Posted · error: Ultimaker 2 extended plus suddenly starts moving very slowly and sometimes print on air...

    That version of the firmware is probably the latest (even though there are other versions with a newer date, I think they may be identical - not sure).

     

    However there is a better version of the firmware with a few minor bugs fixed and more importantly lots of features added (like continue a failed print after power failure or other failure).

     

    tinkermarlin:

    https://github.com/TinkerGnome/Ultimaker2Marlin/releases

     

    I use the above version on all 3 of my active um2 printers.  Make sure to download the "extended-plus" version.

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • Ultimaker showcase | April 2022 | 4pm CEST | 10am EDT
        I'm excited because I've personally produced this showcase event, so if you are curious what else I'm up to nowadays, come check it out and say hi in the chat! It would mean a lot! 
          • Thanks
          • Like
        • 4 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...