Jump to content
Ultimaker Community of 3D Printing Experts

3 Ext not loading files


Recommended Posts

Posted · 3 Ext not loading files

For a while now, our 3 Ext hasn't been able to load any of the files we have given it. We use Cura and place the gcode-file on a USB which we then put into the 3 Ext and usually it works just fine, the way it should, but it seems to not work anymore in the sense that when we try to read some of the files through the printer it keeps showing "Loading.." when hovering over a file, then when you try to start the print by clicking the file it says "preparing..." for a brief frigment of a second and then goes back to the main display.

No matter how long we wait, it doesn't load, not even when looking for a firmware update, even then it just says "Checking for updates..." for literally hours and still nothing

(Current version; 5.3.0)

We've tried a couple of things, but none have succeeded and we aren't sure what else to do. Anyone had or heard of this problem before, and can (try to) help?

  • Link to post
    Share on other sites

    Posted · 3 Ext not loading files

    Have you tried using a different USB flash drive?  Just because it works fine with your PC doesn't mean it's not a faulty USB flash drive.

     

    The UM3 has a linux computer in it.  If you are good with linux you can ssh into the computer and look at log files.  I could help you with that but only if you are good with linux.  However I suspect it is going to just report errors with the USB flash drive.  I'd check the contacts (blow on them?  Check cabling maybe?  I don't remember if the usb connector is part of the PCB (soldered right on the PCB) or if there is a cable to the USB jack).

     

    Two possible paths to go down (of many):

    1) Get a new linux board for your UM3.  They aren't cheap - contact your reseller for a price.

    2) Put the printer on the network and going forward always use digital factory to print.

     

    There are more involved debugging paths that aren't worth it if this is a business.

  • Link to post
    Share on other sites

    Posted · 3 Ext not loading files

    It definitely is not the USB itself, since we have several USB's and none of them are readable on this 3 Ext, I don't know if it could be the port though? The thing is, it "sees" the files on the USB, just can't load them onto the printer

     

    And I sadly don't know much about Linux

  • Link to post
    Share on other sites

    Posted · 3 Ext not loading files

    I reread your original post.  You are right - it is strange that it can read the USB flash drive somewhat but not completely.


    So you can go into the maintenance mode and you can tell it to write all the log files from the UM3 onto the USB flash drive.  And then post all those log files.  Particularly the ones that end ".log" or ".log0" (or is it .0.log?  something with a zero near the end of the filename) which are the newest.

     

    I'm wondering if the USB drive is fine and Linux is messed up.  I would try reinstalling the firmware using the "unbricking" method.  I'm wondering if your "hard drive" on your UM3 (it's actually eMMC memory) has some bad blocks.  Fortunately it will reroute the blocks automatically as long as you reinstall the operating system (aka firmware).

     

    Instructions for unbricking:  https://community.ultimaker.com/topic/20024-recovering-a-bricked-um3s3s5/

     

     

    There are newer images but here is an older one.   UM3 V5.2.11 image:
    https://software.ultimaker.com/releases/firmware/stable/5.2.11.20190503/recovery-5.2.11.20190503.img

     

    Image for um3 extended is the same as for um3.

     

    I think the log file might distinguish if the problem is with the firmware or with the USB wiring.  It could be loose and intermittent.

     

     

     

  • Link to post
    Share on other sites

    Posted · 3 Ext not loading files

    Well now the printer isn't working anymore XD

    I tried doing the unbricking method on it, but upon finishing it stopped working with certainty. It started not doing anything on the main display so I turned it off after some time and waited a minute before turning it back on, then I waited for it to start back up but thought it took a bit long, so just in case, I turned it off and turned it on again and left it to start up on its own. It has now been on for over 2 hours and is still stuck in trying to start up but getting nowhere. The display shows nothing, the print head isn't moving, moving or pressing the button isn't doing anything and I can't get to do a single thing.

    Is it possible something in the PCB got overloaded and burned or that a connection somewhere is disrupted?

    It seems to be completely done though~

  • Link to post
    Share on other sites

    Posted · 3 Ext not loading files

    Usually (always) the built in flash drive gets some bad blocks in a position preventing it from booting (these same bad blocks in a different location probably caused the strange errors you saw earlier).

     

    You should try repeating the unbricking procedure several times.  Never letting it sit doing nothing for more than 5 minutes.  Try as many as 10 power cycles.  It's amazing how many people say it works now after 3 power cycles.  But if it isn't getting to the progress bar and only showing you linux text and the robot then repeated power cycles won't help and something else is wrong.  I describe a few issues (link below) in my guideline.

     

    If this is a company printer and you have more money than time then just order another main computer board.  The "olimex" board.  Aka the "linux computer" board.

     

    If you have the time and want to save some money you can read my guideline.  Or at least buy a serial-cable-f to see what is going on.  Or you can try my alternate unbricking suggestions.  Or try the latest firmware.

     

    Which version of the firmware did you try to install?  The newer, the better as the newer versions re partition the internal flash drive but the older firmware versions don't usually do that.  Try to get version 7.0 or newer.

     

    So here is a LOT more detail on getting your UM3 running without spending more than 20 euros:

    http://gr5.org/unbricking/

     

     

     

     

  • Link to post
    Share on other sites

    Posted (edited) · 3 Ext not loading files

    I will try again

    Thank you for the help, if we cannot get it to work this way, it might be safer to either send it in for a repair or get a brand new one if we see no way out

     

    I thank you for your helpfulness and hope this will work, have a great day!

    Edited by Chandra1st
  • Link to post
    Share on other sites

    Posted · 3 Ext not loading files

    I hate mailing these printers around as the postal services can easily warp your printer enough that it looks fine but now prints everything crooked.

     

    So much easier to just replace the Olimex board.  I think it's 4 screws to uncover it on the bottom?  And then maybe 4 more screws to disconnect the board.  There are a few cables - just take a photo before disconnecting anything - maybe 4 cables?

     

    It's probably easier to do this than to package it up properly for shipping back to the reseller.

     

  • Link to post
    Share on other sites

    Posted · 3 Ext not loading files

    I didn't get this to work, but I managed to hook it up to the cloud and we can now print from a common PC that is connected to this printer.

    So instead of using a USB directly to the printer, we just put a file for Cura (not gcode, as that is a finished product) onto the USB and move it to that PC's Cura after which we can print it directly via the cloud

    This seems to be the easiest option, and I might try to fiddle around with the PCB later if I find the time and ressources for it, but for now we have found a solution

     

    I thank you so much for the help you have given, and I hope the methods you described will help others with a similar problem

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • Ultimaker showcase | April 2022 | 4pm CEST | 10am EDT
        I'm excited because I've personally produced this showcase event, so if you are curious what else I'm up to nowadays, come check it out and say hi in the chat! It would mean a lot! 
        • 4 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
        • 11 replies
    ×
    ×
    • Create New...