Jump to content
Ultimaker Community of 3D Printing Experts

Using first extruder full print area in two-color print


plaa
 Share

Recommended Posts

Posted · Using first extruder full print area in two-color print

I'm printing a two-color design with an Ultimaker 3.  When I import the two STL files and set them both to extruder 1, both models fit in the print area.  But when I set the second (much smaller) model to use extruder 2, the gray unprintable area expands and the first model can no longer be printed, even though it uses extruder 1.  The smaller model using extruder 2 is within the extruder 2 print area, so physically the printer is able to print it, but Cura is preventing it.

 

How can I make Cura understand that the first model can be printed, since it is within that extruder's print area?

 

I read about nozzle_offsetting_for_disallowed_areas flag, which apparently allows Cura to print within the gray areas, but I couldn't find the Ultimaker 3 definition file.  Could someone point me to an Ultimaker 3 definition file with this flag enabled (or second extruder area limits removed)?

 

Below is a visualization of the problem:

image.png.e8f7fe374524f97c94ee34ecee3d7714.png

  • Link to post
    Share on other sites

    Posted (edited) · Using first extruder full print area in two-color print

    Answering my own question:

     

    The definition file (on Mac Cura 5.0.0) is at /Applications/Ultimaker-Cura.app//Contents/Resources/share/cura/resources/definitions/ultimaker3.def.json.  This file needs to be opened with a text editor and the line "nozzle_offsetting_for_disallowed_areas": false, added to the "metadata" section.  This will allow the second extruder to print to the same area as the first extruder.

     

    Additionally you need to make sure Print settings --> Build Plate Adhesion --> Build Plate Adhesion Type is "None" (even if you have disabled adhesion in the recommended settings).  By default the disabled value is "Skirt" which still prints a skirt of both colors around the entire print object, which would go outside physically possible range.  Check from the preview that no rim is printed.

     

    Unfortunately just disabling the build plate adhesion type was not sufficient, the definition file had to be modified also.  😞 

    Edited by plaa
    Markdown not supported by the forum :(
    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 12 replies
    ×
    ×
    • Create New...