Jump to content

Active levelling bad result & how to downgrade firmware


th10gt

Recommended Posts

Posted · Active levelling bad result & how to downgrade firmware

Hi all, I'm writing in English even being a German...

Some days ago I've upgraded my UM3 to the latest version of the firmware (5.3.0). In addition I had to level the print bed. I did it manually first and after that I've started active levelling. The process of active leveling went well without any problems. When starting a new print no filament was extruded because the nozzle was much too close to the print bed. Fastening the screws moved the print bed away from the nozzle and filament was extruded. But the result was awfull because the print bed wasn't levelled precisely anymore. I've tried to fix that by carefully turning the screws but the result was quite poor.

 

I replaced the print head by a new one and also checked the sensor (--> Diagnostics --> Sensor). The sensor test was good and the problem wasn't solved.

I've posted my problem inside a FaceBook group and received the hint to check the sliding blocks and the surface of the glass. I did and both was fine.

So my first question is: What to do to bring back active levelling to good results?

In that Facebook group I received a comment saying that that guy exactly had the same problem after upgrading the firmware. He said, he solved the problem by downgrading the firmware to an old version. Even being quite unconfident with this approach (because thousands of others would have the same issue) I would like to give it a try.

Second question: Where I can find (and pick) old versions of the firmware?
Third question: What is precisely the process to install an old version of the firmware?


Thanks in advance for any support...

Greetings from Germany!

  • Link to post
    Share on other sites

    Posted · Active levelling bad result & how to downgrade firmware

    Hi,

     

    I also have the problem with all my Ultimaker printers, that without any fix, the auto bed leveling that is done before each print is too close to the build plate. This results in a shitty first layer (not quite as bad as in your case, where the nozzle seems to be touching the build plate).

     

    What has helped me is the "z offset plugin" by ahoeben. For the Ultimaker S-line printers, you have to have "extensive G-Code processing" enabled, iirc because the z coordinate is not relative in the gcode or something like this.

    It's just a workaround, but it works well. I have 0,1 mm of offset for my UMS5 and UMS3 which results in a better first layer. You might need even more.

     

    FWIW I think the bed leveling sensor is not a very good design, albeit cheap to manufacture since it's just a pcb. In my opinion, a mechanical switch probe would be the best solution. Of course this is difficult to implement since it has to stick out below the nozzle, but hey, Ultimaker has some talented engineers so I think it should be possible to find a solution.

     

    Viel Erfolg!

    LG, Niklas

  • Link to post
    Share on other sites

    Posted · Active levelling bad result & how to downgrade firmware

    Thanks, neute, but unfortunately it's not an UMS3 but a UM3...

    Meanwhile: I've read here a hint to switch back to "factory settings" and to set active levelling period to something else than "Never". A lot of work to do after switching back to factory settings. But at the end: No progress, problem is still the same!

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...