Jump to content
UltiMaker Community of 3D Printing Experts

Print N layers by blocking the Z height


ClaudioCT
 Share

Go to solution Solved by gr5,

Recommended Posts

Posted · Print N layers by blocking the Z height

Dear community,

is it possible to print a certain number of layers inside a pre-existing cavity (model fixed on the printing plate) at a certain height (z locked)?

After that, continue to print regularly (the build plate will drop a certain amount with each layer).

 

Thanks in advance for your reply!

CT

  • Link to post
    Share on other sites

    • Solution
    Posted · Print N layers by blocking the Z height

    You want to repeat a layer or two so it prints the exact same thing 2 or 3 things without the Z moving?  

     

    Oh wait!

     

    You want it to print exactly normal except the Z axis doesn't move for 2 layers.  Well that's pretty easy to just do it by hand in the gcode.  Search the gcode file for the letter Z.  Once you get past the first few there is only one Z in the file per layer and it's the height.  Just take a look.

     

    Unless you have zhop enabled.  If you do then that's unfortunate as there could be tens of thousands of Z's in there.

     

    But most of the time there is only one per layer so if you have 50 layers you only have to edit at most 50 numbers/heights.

     

    Take a look at the gcode!  It's not that complicated.

    • Like 1
    Link to post
    Share on other sites

    Posted · Print N layers by blocking the Z height

    Another trick is to use G92 gcode.  Here is a typical layer change - note the "Z 1.2" which means move the Z axis to 1.2mm such that the nozzle is 1.2mm from the bed.

     

    ;LAYER:6
    G0 X119.348 Y137.166 Z1.2

     

    What you can do is fool the printer telling it "hey you are already there" with the G92 command so:

     

    ;LAYER:6
    G92 Z1.2
    G0 X119.348 Y137.166 Z1.2

     

    The G92 says: Hey I know you thought the Z was at 1.0mm but pretend it's actually at 1.2mm.  Already there.  So then when the printer sees the command to go to 1.2mm it will just ignore it.

     

    Just add the G92 for the layers where you want Z not to move.  The bonus of this trick is it will work even if you have z hop enabled (but in that case don't search for Z as it will take forever, instead search for "LAYER").

     

    Once you stop adding G92 gcodes the printer will continue moving up but only in small increments (it won't suddenly jump up for every layer you "locked").

    • Like 3
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...