Jump to content

Save to removable saves on HDD anyway... Cura 5.1 and 5.2

Go to solution Solved by nepcior,

Recommended Posts

Posted · Save to removable saves on HDD anyway... Cura 5.1 and 5.2


Since some time i have a strange issue. When I insert the SD card into the computer's reader, Cura changes the "Save to Disk" button to "Save to removable" as usual. It also shows the letter of the SD drive. Unfortunately, when the button is pressed, Cura saves the gcode anyway to the hard drive. What could have happened? Reinstalling Cura from 5.1 to 5.2.1 did not help.

  • Link to post
    Share on other sites

    Posted · Save to removable saves on HDD anyway... Cura 5.1 and 5.2

    Hello @nepcior.

    @MariMakes should be able to help with this when she gets a moment.  She will need to know more about your computer and operating system.

    Cura makes calls to the operating system to handle file writes so maybe something is going on between them.

    Is the "lock tab" on the memory card in the "write" position?

    • Like 1
    Link to post
    Share on other sites

    Posted · Save to removable saves on HDD anyway... Cura 5.1 and 5.2

    Hey @nepcior,


    Welcome to the Ultimaker Community 🎉

    That's odd. 🤔 It reminds me of this github issue but it seems different. 

    I have a bunch of questions!

    Which operating system are you running?
    Is your operating system in a non English language?
    Did this SD card work before? 

    Do you have more devices plugged in? 

    • Like 1
    Link to post
    Share on other sites

    • Solution
    Posted (edited) · Save to removable saves on HDD anyway... Cura 5.1 and 5.2

    Hello again!

    I use Windows 11 x64. Yes, my operating system is not English language. Yes, SD card worked before. This happened during one session with the program. I don't remember exactly how it happened, but something like: I saved gcode to the SD card - OK. A moment of work, I saved the gcode, this time to disk - OK. Another moment of work and saving again on the SD card, but... This time, gcode was written to the computer, same drive I was saving to before. And it's always been like that ever since. No, I have no more devices in the card reader, if that's what you mean.


    I think it might be caused by one of the plugins. I have to check it out. I use "custom printjob naming".



    I'm back home and checked. Thank you MariMakes!
    Your questions led me to the idea of checking plugins. And that was indeed the reason. No idea how, but one setting of plugin "printjob naming" was set to save to path D:/. This plugin catches saving process and replacing the name. And the path in this case. Now all works as before.


    Edited by nepcior
    New information
    • Like 2
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 6 replies
    • Create New...