Jump to content

Cura ignoring small gap

Go to solution Solved by GregValiant,

Recommended Posts

Posted · Cura ignoring small gap

I'm trying to print a model that has two faces pretty close together, but not touching (about 0.3mm clearance). When I slice it in Cura, it "bridges" this gap, which messes up the part.


The part is available on Thingiverse here: https://www.thingiverse.com/thing:5228740 (0.5mm gap version). I've also attached a Cura project file in case there's any trouble reproducing.


I checked the STL file in Blender and FreeCAD; neither turned up any mesh errors. If I scale up the part to ~150% or more, the part slices correctly, which also makes me think the model is OK. It seems to be something about the small size of the gap.


Cura also seems to be using top/bottom layers to create this "bridge"—that doesn't seem right either.


I've tried toggling every setting I can think to try—mesh fixes, resolution/accuracy, stock presets, etc.—but nothing seems to have any effect. How do I get Cura to respect this gap, instead of ignoring it?


Un-sliced model; the "cup" and "ball" don't touch at any point:



Slicer output; two sides are "welded" together:



Iso view of a middle layer to show cross-section:



One more view; "welding" doesn't occur on outside 15-16 layers:



Environment: Cura 5.3.1 Flatpak on Fedora 38




  • Link to post
    Share on other sites

    Posted · Cura ignoring small gap

    Hi @spumpsalive,


    Welcome in here.


    Can confirm your issue with Cura 5.3.1, -but work Ok with Cura 5.3.0 Beta - Xmas version..


    So appear it's a "thing/bug" in between those two versions?





    • Like 1
    Link to post
    Share on other sites

    • Solution
    Posted (edited) · Cura ignoring small gap

    I can also confirm.

    It's troubling in that this would appear to be the type of bug that indicates that 5.3.1 cannot be trusted.

    This is the report on the model from formware.co online stl repair:

    --> 0 Naked edges (?)
    --> 0 Planar holes (?)
    --> 0 Non-planar holes (?)
    --> 0 Non-manifold edges (?)
    --> 0 Inverted faces (?)
    --> 0 Degenerate faces (?)
    --> 0 Duplicate faces (?)
    --> 0 Disjoint shells (?)
    -> Repairing: 100.00%
    ----- Repair completed in 7378ms ------
    -> Vertex count changed from 29547 to 29547 (+0)
    -> Triangle count changed from 59098 to 59098 (+0)


    This is the first model I've submitted that got straight "A"'s.


    EDIT:  Looking into this, toggling "Print Thin Walls" on and off will cause that cross-over to disappear and re-appear.  In particular the "Minimum Feature Size" seems to play a role.  When it is a small number the slice is fine.  Once it gets above 0.31 the slice is wrong.


    Edited by GregValiant
    • Like 2
    Link to post
    Share on other sites

    Posted (edited) · Cura ignoring small gap

    It was only a question of time.  This morning This Bug Report showed up on GitHub.


    This is a demonstration model.  The slit on the right is .15mm and the left slit is .50mm ( .05mm increments).







    In my estimation, they aren't even close.  My earlier comment that 5.3.1 can't be trusted would appear to be right on.

    Edited by GregValiant
    • Like 2
    Link to post
    Share on other sites

    Posted · Cura ignoring small gap

    Hi Greg,


    right you are, -even ver 5.3.0 has this issue too.

    To me it seems like when it come to small details it become worse.

    So, if I'll like to try those new versions, I'll always use the monitor to inspect the sliced object before printing.

    However, version 4.13.1 is the version I'm using and find very good.

    I'm using one small test object, the "ctrl V 3D test" -and if a slicer can do this one well I'll know the UM2 print it fine.

    This test object demand using a 0.25 nozzle to be perfect, but can be "some" acceptable using a 0.40 nozzle.


    I'll just put up this picture for anyone (Greg knows this very well) to see how accurate Cura could be.

    Here's how it's look in the monitor using Cura 4.13.1:


    I'm using Cura standard profile, except for the "brim", as I'm using "skirt"

    The minimum distance between walls: 0.5/0.4/0.3/0.2/0.1mm.

    This test object can be found here: https://www.thingiverse.com/thing:704409






  • Link to post
    Share on other sites

    Posted · Cura ignoring small gap

    Thanks all for the great response. The "Print Thin Walls" option is a helpful workaround for my case—if I run into further issues as a result, I'll roll back to 5.2.x. Let me know if there's any way I can assist further.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
        • 26 replies
    • Create New...