Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
wallan

Problem loading highres model

Recommended Posts

Are there any size limits on models in Cura?

I'm currently using 14.03 but I have had the same problem in previous versions as well.

So far I have solved it with splitting up the model but all splits generates more post work on the final model so I would like to split it up less if possible.

The model that currently gives me problem is about 4,2 million polygons.

When loading it takes quite a while but when finished there is no model to be found or any kind of message either. Sometimes loaded models gets very small so maybe there is a tiny model somewhere but i can't find it.

 

Share this post


Link to post
Share on other sites

I recommend you reduce the qty of polygons using this method (meshlab is free software):

Meshlab:

http://www.shapeways.com/blog/archives/226-polygon-count-reduction-with-meshlab.html

 

I had a 10 million polygon part and then I reduced it to 1 million and it still looked excellent. So I tried 100k and it still looked stunning. I think I went to 10k and it still looked good but I forget how low I went.

I was surprised how many extra polygons there were that aren't needed.

 

Share this post


Link to post
Share on other sites

Well, if it was for 3D rendering I could do that but...

I have printed this model before at lower reoslution but one can easy spot the polygon edges on the faces in the surfaces that should be perfectly smooth.

That does not mean that it could not be possible to go down to maybe 3 or maybe even a little bit less.

I think the model that showed polygons in print was a 1 millon model but I don't remeber.

It could have have been 256k in case I totally forgotten to subdivide it.

I have to check.

If it was 256k then I can give 1millon polygons a chance.

Will get back on that.

However, this is a clean model and if it was a more complicated one polygon count whould go up even more.

So, what is Cura supposed to be able to handle?

zBrush handles the 4 million polygon model easy and it's the same with meshmixer.

So why does cura have to struggle, why is there no message in case something went wrong and if it acctually did load after all, why cant I see it.

OK.

Some updates.

The model that showed visible polygons had 300k polygons.

So I suppose that I at least should try a 1.2 million polygon to avaluate if that is god enough.

 

Share this post


Link to post
Share on other sites

Just because the polygons are visible in CAD doesn't mean they will be visible when printed in plastic. The diameter of the nozzle is .4mm which means the radius is .2mm. So for example polygons .1mm across might not be visible when printed. Even polygons 3mm across might not be visible if the neighboring polygons are almost in the same plane.

Meshlab does a better job at removing "extra" polygons than most software. It has quite a few options to try to make it still look "just as good" so you can play with those options.

 

Share this post


Link to post
Share on other sites

When I talk about polygons being visible, I'm talking about visible in the print and not about polygons visible in CAD.

zBrush has excellent tools for reducing polygons in an intelligent way, but as long as i can see polygons in the printed model I can't se how the result would be better with even less polygons.

Would like to show an image if I could but all the parts with visible polygon edges has gone trough an Acetone treatment in order to remove them.

And just so there is no missunderstanding.

The model that had the visible edges was a 300k polygon model and not the one with 4million.

 

Share this post


Link to post
Share on other sites

I guess I can't help you then. Well - you could try another slicer. Kisslicer is pretty good - it has a nice gui similar to Cura.

I'd love to see what your model looks like (in zbrush or actual printed even if you did already smooth it). I'm trying to understand the complexity.

 

Share this post


Link to post
Share on other sites

Yes, there is an issue with this.

It has to do somewhere with the displaying code actually. The model is loaded into memory, but then somehow fails to get displayed in 3D. I haven't looked into the details yet, but it is a known problem.

It also seems to depend on the exact brand and make of videocard where/when this happens, at which number of polygons.

 

Share this post


Link to post
Share on other sites

Do you have the ability to limit "minimum feature" size when outputting to STL?

I use Moi3D (www.moi3d.com) and when I output to STL, I set the minimum feature to .001" which greatly reduces the poly count without any apparent difference in the final model. Not to sound like "that guy", but I defy anyone to see a difference in the model from the original to one where I add this minimum feature limit.

Try it, you'll be surprised!

Cheers,

Chris

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!