Jump to content
Ultimaker Community of 3D Printing Experts
fran

Can't connect to Cura via USB - please help! - solved

Recommended Posts

Hi everyone,

I'm running out of ideas what to do differently in order to get my newly assembled Ultimaker Original finally up and running.

Assembly went all well, however when I tried to connect the printer via USB to Cura 14.03, Windows 7 (64bit) would not recognize the printer (error code #43).

I installed the latest Arduino drivers as well as the FTDI drivers, but no luck.

A new arduino board (connected via USB) was also not recognized.

Then I tried using Ubuntu 14.04, running on a virtual box. I installed Cura there and connected the printer via USB. This time I got the message that the serial port could not be found.

Thought maybe this was because of running everything on a virtual box, so I decided to install Ubuntu on a separate partition with dual boot instead.

It still won't work though, again got the message about not finding the serial port.

Have you guys got any tips how to solve this one? It starts to get a bit frustrating...

That I might encounter problems on Windows 7 / 64bit I can relate to, but that even on a fresh Linux install things won't work - I'm out of ideas what else to do.

Please help!

Many thanks in advance,

Fran

PS: I did all this on a HP EliteBook 8530W with an Intel Core2 Duo T9600 @ 2.80GHz

 

Share this post


Link to post
Share on other sites

Thanks for the link, looks like more people are having trouble with the arduino board...

During the installation of Cura, all went well and the arduino driver was supposedly installed - no error message then.

 

I do get a sound when connecting the board via USB, and it does light up (green LED and orange LED at pin13):

arduino board defect

However, only an unknown device pops up in the device manager. In the port section of the device manager nothing changes at all, so I can't get a COM number for the board:

 

device manager

 

Then I downloaded the latest driver from arduino.cc. When I try to manually update the driver for the 'unknown USB device', I get this message:

 

screenshot2

screenshot3

 

I found a thread online about how to temporarily disable driver verification in Windows 7:

http://en.kioskea.net/faq/3914-windows-7-disable-signature-verification-of-drivers

 

Did that as advised, tried to update the driver again, and still no luck.

 

Installing the arduino software and its drivers also could not get it to work. When trying to upload a test program to the arduino mega 2560, the communication fails or cannot be established:

 

screenshot4

Changing the COM port number in the arduino program made no difference.

 

Is this an issue with the arduino mega 2560 running under Windows 7 64bit?

 

What I don't understand is that it also won't recognize the board on my fresh dual-boot install of Ubuntu 14.04. To be fair, I have to add that I haven't yet tried to install the arduino drivers manually onto that system (Cura is of course properly installed).

 

It's a tricky one...

 

Hope you guys can help!

 

Cheers,

 

Fran

 

 

 

Share this post


Link to post
Share on other sites

In the mean time I got another replacement board from Ultimaker. The first replacement board I bought myself as it unfortunately took quite some time until I got a reaction from UM support.

The UM board board is still in its original package - kind of hesitant to unpack and try it as well - if it is indeed a software issue (as I suspect), I'd end up with two extra arduinos...

 

Share this post


Link to post
Share on other sites

OK, now I'm really out of options...

Just tried connecting the Ultimaker to Cura on Windows XP - on an old Macbook Pro with bootcamp installed.

Installed Cura first, tried to connect - no luck, serial port could not be found.

Then I installed Arduino IDE, tried to get the board detected there, again it didn't work.

The device manager only shows an unknown device connected to USB.

So far I have tried the following OS's (the first three all on the same HP Elitebook 8530w laptop):

Windows7 64bit - error code #43, device not recognized

Ubuntu 12.04 on virtual box - no serial port found

Ubuntu 14.04 on dual-boot / separate partition - no serial port found

Windows XP SP3 (Macbook Pro from 2007) - device not recognized, no serial port found

I did all the tests with both the original arduino board which came with the UM1 kit, and a new (original) arduino which I bought at a local electronic store.

Only thing left would be to test with the third (!) arduino board I've got now, a replacement which was sent by Ultimaker this week. However I doubt that I got two malfunctioning boards here, would be very odd indeed.

Any suggestions how to proceed with this one? Never thought it would be this difficult to get the printer going...

Many thanks in advance for your advice!

Cheers,

Fran

 

Share this post


Link to post
Share on other sites

Jeesh.... Finally found the cause - it was the USB cable which caused the defect.

Even though the board reacted when connected with it (lights went up), the transmission was somehow not working properly.

Got a shorter high-quality USB 2.0 cable and now everything works perfectly!

Am so relieved that I can finally work with my new Ulitimaker :)

Thanks Gr5 and Daid for your support!

Cheers,

Fran

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!