Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
peetersm

UM1 - MINTEMP fail at random times - solved.

Recommended Posts

I am having trouble with my UM1.

I have triple checked my gcode and there's only one M109 (at the top), also this is happening at randome times during the print.

I watched the LCD panel and am seeing this:

-at a random place during the print (not the same everytime) the target temp will flash to zero. (sometimes the temp read also flashes zero then back to the read temp)

- the head will start cooling untill I get a "Err: MINTEMP" and then the fan turns on (if it's not already on)

I tried doing a "preheat PLA" and then moving the head all around and pushing on the wires & bowed tube but could not duplicate this problem that way.

CURA 14.01

Firmware 13.12 Dec 16th 2013

Any suggestions on what to try next?

thanks, Mark

 

Share this post


Link to post
Share on other sites

Check the connections into the the terminal block on the small board on top of the print head. If those are definitely good, then look at the connection coming from that board to the main electronics board.

There should be a spare set of wires currently unused from the head to the main board. You could try swapping to use that pair to connect the temp sensor board to the electronics. Just swap the connection at both ends.

 

Share this post


Link to post
Share on other sites

What temp are we talking about as there is some kind of issue somewhere around 170C but usually mintemp occurs when you have a bad wire.

As Illuminarti says, check the wiring. It's great that you have the ulticontroller (lcd panel) as it makes this so much easier to debug and fix! With the nozzle at any temperature (room temp 20C is fine) push the head around to the 4 corners of the bed - the goal is to get it to give you the mintemp error or at least to see the temp jump suddenly by more than 3 degrees. If that's not enough - try pushing and prodding the wire at the top of the print head. There is a small circuit board on top of the print head - the problem is usually the triple twisted wire leading upwards from there. It is *supposed* to go through a black "F" shaped plastic strain relief to avoid these mintemp issues. But it may be too late and your wire may be mostly broken inside the insulation. Or not sticking into the connector crimp properly. Hopefully prodding up there will induce the problem and you can either replace the wiring or use the spare cable. If you use the spare cable make sure you change it at the other end also (underneath the printer).

Alternatively there is another cable that goes from the thermocouple in the head to the tiny board on top of the head. That wire is very sensitive to electromagnetic radiation coming from the fan wiring. Keep those wires at least 10mm apart from each other (fan wiring apart from thermocouple wiring). About 5% of the time the issue is with that cable or the thermocouple itself.

Another way to isolate the issue is to get it to fail and while it is failing measure the voltage coming out of the tiny circuit board on top but I don't think you will need to go to this step. But coming out of that board 0V means 0C, 5V means 500C and all other voltages in between are linear (e.g. 20C is 200mv).

 

Share this post


Link to post
Share on other sites

thanks So much for the info.

Right now I am printing at 210C

I will check those head connections again and also the connection on the board under the printer since I did try poking and moving the head around while at temp for perheat PLA. I do have the F support installed, and I did see the spare wire just in case. I'll be back by the machine tomorrow.

I am curriuos. if the heater power wire or thermistor are losing connection would the target temp on the LCD go to zero? Shouldn't the target temp be controlled by the firmware regardless if it "sees" the thermistor or heater, or is going to zero a safty feature, like a deadman's switch?

 

Share this post


Link to post
Share on other sites

okay, gr5 you're right I did not need to ask for heat I just needed to poke more.

I did see the MAXTEMP error when I disconnected the cable from the board. and then with some more gentle poking on the head end I did see the MINTEMP error. I have switched over to the spare wires. I'll kep you posted, so far I'm 15 minutes into an 8 hour print. fingers crossed! :-)

 

Share this post


Link to post
Share on other sites

Hi,

For the ones getting a MINTEMP error - it can be due to a loose connector to the TC board.

After a while the strains on the cable this connector can break.

I fixed this by removing the connector and soldering the wires directly to the board.

What you can also do is order a new connector and use crimp sockets to attach it to the wires. The connector you need is a Micro JST XH 2.54mm 3-pin T-1 plug which you can usually find on ebay. I had mine shipped from Hong Kong for a few cents each.

Thanks

Ralph

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Announcements

  • Our picks

    • Architect Design Contest | Vehicles.
      We're open for entries! - Design and submit your 3D designs of architectural entourage - vehicles - for a chance to win a large filament pack. Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled model can really help to get your idea across.
        • Like
      • 24 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 23 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!