Jump to content
Ultimaker Community of 3D Printing Experts

Missing Geometry in Final Print


sensebellum
 Share

Recommended Posts

Posted · Missing Geometry in Final Print

I am having some trouble getting CURA to recognize certain holes in my model.

The hole is present in Sketchup, also in CURA's "Normal" and "X-Ray" view. But when I look at the actually layers it omits this hole completely - and in actuality as I found out at the end of a print. I tried a few different customizations and also the stock options and the paths were rendered just the same. It also ignores them regardless if the file is a .dae or .stl

How can I rectify this?

Also, is there a guide for formatting the models correctly for CURA? I would be interested in learning some of the tricks.

Hole-Presence.jpg

 

  • Link to post
    Share on other sites

    Posted · Missing Geometry in Final Print

    The most important things when working with Sketchup & Cura, are imho:

    1. disable all "Fix horrible" settings, as Dim3nsioneer mentioned.

    2. Fix all horrible stuff yourself :)

    Meaning, make sure there is nothing "red" in the "X-Ray" view, such as internal planes, or holes in your mesh (like missing faces).

     

  • Link to post
    Share on other sites

    Posted · Missing Geometry in Final Print

    Just my two cents here: maybe use DesignSpark Mechanical as CAD software instead of Sketchup (i find it much better for parts like this and you'll have better STLs to print with it)

     

  • Link to post
    Share on other sites

    Posted · Missing Geometry in Final Print

    Check the expert settings: Is any 'fix horrible' option set? If yes, disable it...

     

    If "type A" is checked, and the hole shows up then. Then the normals of your model are actually wrong which is why the hole goes missing.

     

  • Link to post
    Share on other sites

    Posted · Missing Geometry in Final Print

    I believe the following hints:

    Go to Sketchup on "window" to the "Model Properties", and then:

     

    - Reduce the Decimal precision up to max. 3 Dezimal places, more is not required for 3D printing with most of all machines.

     

    - Take advantage of the length snapping function, you need less then zoom in on structures.

     

    - Use in the SketchUp options "automatic correction".

     

    - Use the wire-grid-view and remove unnecessary structures within a model.

     

    - At circle shapes (Circle segments and even Hexagons) directly adjacent lines can cause Problems in Cura, I believe. This can lead to sudden closed holes in the finished object, which are displayed then closed in Cura only in the layer view. So I think I have experienced it several times.

    - For adjacent lines use simlpy a safety distance of perhaps 0.1 mm. There is no problem, and later on the finished object, not recognizable.

    Generally holding a watchful eye on possible areas of overlap.

     

    - Dark areas are appearing interior surfaces and exterior surfaces are lighter, this must be corrected manually sometimes.

     

    - The areas displayed incorrectly must be turned around only really before conversion to DAE. A right mouse click on the displayed incorrectly area and then select "Reverse Faces".

    - There are many useful plug-ins, they can simplify working with SketchUp much.

    At the moment I do not need any plugin's.

    I was for example recently recommended a plugin that can highlight potential problems in the object. So flawless body volume for 3D printing are possible at the end. Unfortunately I forgot the name of the plug-in.

    At the end are possible with a little practice good to very good designs with SketchUp. For some SketchUp is perhaps too simple or too complicated. Anyway, everyone decides for himself.

    And clean DAE's Cura treated exactly as STL's, I mean. The objects can in fact be easily scale, rotate, and even multiply :smile:.

    They can even be printed out.

    Markus

     

  • Link to post
    Share on other sites

    Posted · Missing Geometry in Final Print

    Great advice everyone.

    I found that unenabling all of the "Fix Horrible" options allowed the holes to be rendered but subsequently caused other problems in the model. I then exported the Sketchup model as an .stl file and it was loaded cleanly.

    Jonnybischof, oddly enough there was no red in the x-ray view that I saw.

    I'll be sure to set the resolution for future projects more finely detailed, thanks for the tip mnis.

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...