Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
Blizz

Manual refresh of render time

Recommended Posts

Having the render time updating automatically on a change is very handy for small, simple models, but for more complex ones it's pretty cumbersome. If I'm editing some plugins the program becomes unresponsive until it has finished updating the projections. Is there a way (or if not, please consider this a feature request), to stop it recalculating on its own and do it manually?

 

Share this post


Link to post
Share on other sites

This question was asked many times when the auto-update feature was added. Many people loved the feature and many people hated it. It turned out that all the people who hated it did so because of various bugs that locked up their computer while it was computing.

I suspect you found a new bug. The program should never become unresponsive. Especially while slicing. Maybe you can provide more details and see if other's can duplicate it? It may be a mac thing or something very specific to your computer such as antivirus program, or SD card issue.

 

Share this post


Link to post
Share on other sites

I don't think its a bug, it's just that it requires so much processing power that there's nothing left for the program's GUI...

It's the same for example when I have to resize those models. During redrawing you can hardly input values. All of a sudden you have an object that is 5000% instead of 50 or so :)

Like I said, it's a nice feature but having some control over when it actually recalculates would be very nice. It's a waste of CPU power if it is constantly redoing everything every time I add a 0 in an edit field you know :)

 

Share this post


Link to post
Share on other sites

I don't think its a bug, it's just that it requires so much processing power that there's nothing left for the program's GUI...

It's the same for example when I have to resize those models. During redrawing you can hardly input values. All of a sudden you have an object that is 5000% instead of 50 or so :)

 

Assumption right there.

It's not the toolpath processing that's causing slowdowns. It's actually some horrible GUI code that's causing the issues. It's actually calculating boundary boxes on the GUI thread, which is the main source of slowdowns. It would still do this even if you do not calculate toolpaths.

It's something I'm addressing in codename Pink Unicorn.

 

Share this post


Link to post
Share on other sites

What i do to avoid this is doing all the setting with an empty buildplate. Then you add your object and tweak it.

Particularly helpfull if you need to add several plugins

 

Oh, and I'm not 100% sure where plugins are ran, they might actually be blocking the GUI.

 

Share this post


Link to post
Share on other sites

well each time you add a plugin the slicing is rebooted and the same for every value you enter in the fields of the plugin.

 

Yes, but that's not what I mean. I mean, the plugin code, that's processing the GCode, that could be blocking the GUI.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Terms of Use Privacy Policy