Jump to content
UltiMaker Community of 3D Printing Experts

2 months, still no first print


Recommended Posts

Posted · 2 months, still no first print

If I had not seen video evidence I would not be convinced these really work. I am going to give myself this weekend to get this working or bin it.

At first I had a problem with the controller board. This was replaced after a very slow support process.

Fitted the new board. I have reinstalled all software, version 35.

Followed the software setup instructions exactly, although there is uncertainty. In the Gcode section there is an edit which must be made for "the first batch of Ultimakers". There is no info on how to tell if you have one of the first batch. Maybe this is the problem.

Anyway, nothing worked at all until I uploaded new firmware. I asked Ultimaker which version I should use at first but didnt receive any intelligble reply, si I selected Marlin RC2. No "release" firmware shows in the list, only RCx and "old" firmware. Why?

Anyway, all control panel functions work. I can extrude from control panel.

Downloaded the thin-wall test box.

Gcode generates but gives two errors. Dont know if this is a problem. How can software generate errors which it then detects itself? The whole thing seems flaky.

Start build. For some reason the Gcode is generated again. Find that the Z platform does not home before the build. Why not?

Manually home the Z platform.

Start build. The first thing that happens is the Z platform goes down and then extusion happens into thin air creating a blob of material on the platform.

Then the platform homes again and the head plunges into the blob.

Then it moves in the box shape, moving the blob which has now stuck to and blocked the print head.

So, I try again this time removing the blob before the main print starts. This time no extrusion is taking place at all. The head is moving and the extrusion gear is moving at a very tiny rate, much more slowly than I would expect to output any material.

Thats as far as I have got. tried all this many times, reinstalled software, tried RC1 firmware (which actually does totally different things, the extrusion seems to go crazy and dump masses of random piles of material before the head moves in the box pattern).

Any help would be welcome but I am starting to give up....

Oh and the noise from that crappy fan is driving me round the bend...

  • Link to post
    Share on other sites

    Posted · 2 months, still no first print

    The good news is that this all sounds very fixable. I'm thinking this is purely a software issue and it's not surprising that you're having problems considering how fragmented it all is at the moment.

    My recommendation would be to try out a software package that Daid here on the forum has put together, it's called Cura and is aimed at fresh users just like you. Basically what it is is a front end to a tweaked and improved version of Skeinforge where the hard work has been done for you. It also incorporates a firmware updater and a few other things (I don't run it myself so I don't know all the specifics). From what I've read from other users you're very likely to get up and running with this.

    Don't give up, you'll be a very happy camper once you get it up and running :) (and if you still feel like tossing it out I'll gladly pay the shipping and have you ship it to me instead ;) )

    edit: And yes, that tiny fan is a cheap POS, either put up with the noise or replace it not much else to say about that...

  • Link to post
    Share on other sites

    Posted · 2 months, still no first print

    Thanks for your advice. This software sounds like its very useful. I was reluctant to try owing to likelihood of introducing more possible problems into the mix. I did try though, and it did.

    Cant get it to generate Gcode at all.

    The log displays:

    Traceback (most recent call last):

    File "app_main.py", line 51, in run_toplevel

    File "C:\Program Files (x86)\Cura_RC3\Cura\cura.py", line 70, in


    File "C:\Program Files (x86)\Cura_RC3\Cura\cura.py", line 53, in main


    File "C:\Program Files (x86)\Cura_RC3\Cura\util\profile.py", line 192, in loadGlobalProfileFromString

    (key, value) = option.split('=', 1)

    ValueError: expected length 2, got 1

    CMD window:

    File "C:\Program Files (x86)\Cura_RC3\Cura\gui\preview3d.py", line 382, in OnM


    self.yaw += e.GetX() - self.oldX

    AttributeError: 'PreviewGLCanvas' object has no attribute 'oldX'

    C:\Users\warnea\Downloads\0.5mm-thin-wall.stl 0

    Traceback (most recent call last):

    File "C:\Program Files (x86)\Cura_RC3\Cura\gui\simpleMode.py", line 273, in On



    File "C:\Program Files (x86)\Cura_RC3\Cura\util\profile.py", line 192, in load


    (key, value) = option.split('=', 1)

    ValueError: need more than 1 value to unpack

    Unknown M code:103

    Unknown M code:101

    Unknown M code:103

    Unknown M code:101

    Unknown M code:103

    Unknown M code:101

  • Link to post
    Share on other sites

    Posted · 2 months, still no first print

    I did find that link and this cured the problem. In fact Cura is excellent and IMHO Ultimaker should include it with every machine and pay a license fee, to include in the product price. The software installation via the Ultimaker software setup guide is a mess and does not work.

    In fact the problem I had with the "official" software is pretty much the same as an issue covered in another thread in this section, to which there is no definitive solution.

  • Link to post
    Share on other sites

    Posted · 2 months, still no first print

    Agreed, I gave up the "official" software after two days and went straight on the Netfabb train and didn't regret it for a second... however I am afraid of trying Cura because then I might regret going to Netfabb ;-) ...I have heard lots of good talks about Cura. (I guess I will try it eventually)

  • Link to post
    Share on other sites

    Posted · 2 months, still no first print

    They each have pros and cons, no reason you can't use both man :)

    And I'm glad you're back on track Andyww.

  • Link to post
    Share on other sites

    Posted · 2 months, still no first print
    I did find that link and this cured the problem. In fact Cura is excellent and IMHO Ultimaker should include it with every machine and pay a license fee, to include in the product price.
    A license fee for free software?

    Note, I'll be releasing RC4 this weekend to address this issue and another issue which has been plaguing people with some types of ATI video cards. (Like my laptop)

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • Here it is. The new UltiMaker S7
        The UltiMaker S7 is built on the success of the UltiMaker S5 and its design decisions were heavily based on feedback from customers.
        So what’s new?
        The obvious change is the S7’s height. It now includes an integrated Air Manager. This filters the exhaust air of every print and also improves build temperature stability. To further enclose the build chamber the S7 only has one magnetically latched door.
        The build stack has also been completely redesigned. A PEI-coated flexible steel build plate makes a big difference to productivity. Not only do you not need tools to pop a printed part off. But we also don’t recommend using or adhesion structures for UltiMaker materials (except PC, because...it’s PC). Along with that, 4 pins and 25 magnets make it easy to replace the flex plate perfectly – even with one hand.
        The re-engineered print head has an inductive sensor which reduces noise when probing the build plate. This effectively makes it much harder to not achieve a perfect first layer, improving overall print success. We also reversed the front fan direction (fewer plastic hairs, less maintenance), made the print core door magnets stronger, and add a sensor that helps avoid flooding.

        The UltiMaker S7 also includes quality of life improvements:
        Reliable bed tilt compensation (no more thumbscrews) 2.4 and 5 GHz Wi-Fi A 1080p camera (mounted higher for a better view) Compatibility with 280+ Marketplace materials Compatibility with S5 project files (no reslicing needed) And a whole lot more  
        Curious to see the S7 in action?
        We’re hosting a free tech demo on February 7.
        It will be live and you can ask any questions to our CTO, Miguel Calvo.
        Register here for the Webinar
          • Like
        • 10 replies
      • UltiMaker Cura 5.3.0-Alpha 🎄 Tree Support Spotlight 🎄
        Are you a fan of tree support, but dislike the removal process and the amount of filament it uses? Then we would like to invite you to try this special release of UltiMaker Cura. Brought to you by our special community contributor @thomasrahm
        We generated a special version of Cura 5.2 called 5.3.0 Alpha + Xmas. The only changes we introduced compared to UltiMaker Cura 5.2.1 are those which are needed for the new supports. So keep in mind, this is not a sneak peek for Cura 5.3 (there are some really cool new features coming up) but a spotlight release highlighting this new version of tree supports.  
          • Like
        • 16 replies
      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    • Create New...