Jump to content

Two problems with UM2 - one fixed


Recommended Posts

Posted · Two problems with UM2 - one fixed

I have recently had two problems with my UM2 the second of which I still need help with.

Firstly the feeding of filament has gradually been getting more erratic until it no longer worked at all, and for some time it has been unable to withdraw filament and I have been having to pull it out manually.

Having tried everything else I eventually decided to dismantle the feeder and discovered that the filament was not running between the knurled wheel and the bearing because the hole in the plastic beneath them was so worn the filament was actually between the knurled wheel and the white plastic of the tension mechanism at the back.


I have cured this by gluing a 4mm x 4mm piece of square section brass rod to the back of the black plastic casing thereby forcing the filament into a more central position in the feeder mechanism again. This will work as long as the super glue holds out but there is not a lot of room in there to do much else.

Others with similar feeder problems may want to look out for this.

The other problem I have is that the print head now parks front left at the end of a print


which I assume is the reason that when starting the next print it now does that awful thing where the belts ride over the pulleys as it tries to move forward but can't. The knurled heads of the screws on the top of the print head hit the front edge of the top panel.


I can't see anything wrong and have tried factory reset to no avail.

Does anybody know what is going on and how to fix it?

Thanks in advance.


  • Link to post
    Share on other sites

    Posted · Two problems with UM2 - one fixed

    Can you actually print anything? Are you able to start a print at all?

    You might try installing Pronterface, and connect to the printer over USB. Start with the head in the middle of the print area, and try to move it left and right and back and forth using pronterface. See which directions it moves, and if, when it goes one way, you can get it to move back past the starting point, when going the other way. Also, try homing each axis separately, and see what happens (but be ready to hit the power switch if it crashes into the side).

    Since you've been working on the extruder housing, the first thing I'd check is whether you trapped and/or damaged the limit switch wiring that runs in that same corner of the printer (e.g., by getting the wires between the extruder motor and the frame, and or putting a screw through them).


  • Link to post
    Share on other sites

    Posted · Two problems with UM2 - one fixed

    Thanks for your replies.

    Yes I can still print - it prints fine.

    What I do (with power off) is manually push the print head back to rear left position at the start before I print. It still does a little bit of 'belt grinding' as it comes forward to a front left position but only momentarily.

    I will try Pronterface as you suggest - I have not come across it before so it may take me a while to get myself sorted.


  • Link to post
    Share on other sites

    Posted · Two problems with UM2 - one fixed

    Quick note, it is often overlooked but Cura has a Pronterface like UI build it. Go into File -> Preferences and change the printer window type to Pronterface.

    The new UI will appear when you print a model. You can enter the UI without a model loaded but selecting File -> Print even when the screen icon is dimmed.


  • Link to post
    Share on other sites

    Posted · Two problems with UM2 - one fixed

    I have now had a chance to check the machine properly again and Illuminati you were right on the money.

    One of the red wires to the stepper motor above was pinched behind the extruder motor.

    I released it and the machine works as normal. The wire is presumably damaged but I would rather not attempt a repair if I can get away without it.

    Thanks to Illuminati, EldRick and anon4321.

    I will take a look at Robert's feeder.

    Also a warning to others not to repeat my mistake while working on their feeder mechanism and to watch out for what is happening on the inside of the cabinet while they are struggling to hold everything together round the back.


  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    • Create New...