Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  

Extruded volume gradually reducing

Recommended Posts


after struggling for ages with this, I am out of ideas and would like some input from the experts on the printing defect I am experiencing.


- Ultimaker

- V2 hot end, recently upgraded after this problem appeared, hoping it would solve it. I believe to have assembled it correctly and according to the instructions on the Ultimaker wiki

- Bertho upgrade of extruder

- first used PLA from source on ebay but problem also persists with PLA from Ultimaker

- I have check that all belt drive pulleys are tight and also that the belt tension is good

Note: with the V1 hot end, this Ultimaker used to print nicely. Until this problem described below started appearing.


- Cura and PrintRun.


1) When starting a print, the first layers tend to be ok, as the print progresses, the extruded volume is gradually reduced. The result is a print with very low density that is virtually see-through. Img4783.thumb.jpg.1b176fedc3e0e65487e5af4e5022625c.jpg.

This started during a very long print with large flat area (see pic) and has been aggravating since.

2) There seems to be gap between the walls and in-fill (Img4791.thumb.jpg.69fc6fb00bb2324a620374e3bbd4ca44.jpg). I read that this is linked to belt not being right, but could there be something else. I am quite confident the belts and pulleys are good.

Often after a print finishes in this way, I have to go through great lengths to remove the PLA from the hot end and when I feed it back in for a new print the story repeats. Yes, the V1 and V2 hot ends tend to plug.

Normally I print at 200, but have tried up to 220 to no avail.

Any ideas?


Share this post

Link to post
Share on other sites

I've observed exactly the same. all versions of hotend and extruder are affected I agree.

the problem is due to a gradual build-up of material which, as you observed, then leads to it being very difficult to remove the PLA from the hot end afterwards. you can't manually push it through without excessive force either.

a temporary fix is to remove and clean out the hotend (if you just re-insert the PLA it will do the same thing).

I believe it's caused by excessive retractions - if I run with no retractions there are no problems. do you find the same thing?

Share this post

Link to post
Share on other sites

I had a similar problem recently - hotend v1, berthos extruder, v3 bolt. I used PLA from 2printbeta and had after a while terrible problems with the flow rate, the print was getting thinner and thinner and the PLA didn't flow in a stream but more in little blobs (or none at all). I got weird prints with that, instable, flaky, partially see-through.

I uses retraction on some objects before.

I then got rid of the v1 hotend and installed the v2 one. I noticed that the v1 hotend had some teflon tape (it seemed) in the nozzle and the nozzle-tip and seemed to be clogged with burned /blackened PLA.

I also noticed that my bowden tube was squished a bit and made it difficult to push the PLA through. I printed from 210 to up to 235 degrees and speeds from 40 to 120mm/sec. Before my problems really got worse, my extruder failed several times with grinding (and scrubbed off PLA on the bolt).

At this moment i got the new v2 hot end installed and the same PLA - did a testprint without retraction that went well.

I'd say it's plausible that the hot end gets clogged with retraction, as the retraction will pull back cooler material into the nozzle and maybe form tiny layers of PLA there, making the hole smaller and smaller over time.

Will keep an eye on it and this thread!

Share this post

Link to post
Share on other sites

That's interesting. The print of which I posted the images does indeed use retractions, 1.5mm but only about 4 or 5 per layer. Otherwise I printed at 50mm/s, Cura's default which worked well for me until this problem appeared.

The problem is through that now, after unblocking and re-assembling the extruder, I cannot even print a 10x10x10mm cube that uses no retractions. Even after such a small cube, the density of the deposited material is as low as shown in the pictures.

Also, I have unblock it after every print, which is not so straight forward...

What do people use to clean the hot end from the inside - I mean to make sure there's nothing obstructing the nozzle. I tries heating and injection compressed air but there are too many air-leaks in the bowden.

I'm starting to think that the plastic I put in might have contained some impurities, but have no way to check this. Sigh...

Share this post

Link to post
Share on other sites

I usually heat up the hotend and pull out the PLA and let the excess dribble out the nozzle. this gets rid of most of it.

4 or 5 isn't many retractions, i was thinking lots of retractions in a short period of time, but at low speed and with high temperature, the hot zone may extend further up the nozzle giving a similar effect.

have you checked the ID of the bowden tube? that's a good start. Or if, when the nozzle is clear, you can easily push filament through, but when blocked like this it is difficult, that would eliminate the bowden tube as being the problem.

I also note the problem sometimes fixes itself a few layers up, after rapid retractions stop and the material is pushed out the nozzle it seems to 'clear' itself.

Share this post

Link to post
Share on other sites

Thanks for the all the input so far.

I disassembled the hot end again to find out what happened. I managed to pull out the filament with the heated hot end, which already had a 6-8mm long section that looked like it as melted. Once I took the hot end appart I found another plug in the PTFE piece. This plug was about 12mm long and spanned from the interface of the PTFE adapter with the brass part well into the Bowden tube. It took some serious pulling to get it out.

I took the opportunity to measure the diameter of the PTFE tube, which is 3.3mm. Measuring the diameter of the PLA filement that had not yet plugged up show a diameter of 2.8 to 2.9mm. This rules out any constriction in the path of the PLA impeding the feeing mechanism.

Pictures of the plugged up PTFE part attached.

Has anyone seen something similar happening? The sad thing is that I am quite confident I can reproduce this reliably. As always, any input is much appreciated.

Share this post

Link to post
Share on other sites

that's interesting - I took mine apart last night to find almost exactly the same thing. a couple of experiments later and I was able to reproduce the plug at several different key points along the hotend - just by changing the ambient temperature and applying (or removing) a fan.

it can be exacerbated by increasing the extrusion amount too - if you are over extruding you can create the problem in 30 seconds from a clear nozzle.

your temperatures are fine so next question - what's your E-value? (you probably set this in your slicer whichever you're using)

Share this post

Link to post
Share on other sites

have the same problem.. good to have a thread to adress it.

Strange is, first getting perfect bottom layer and all other much less output. A stringy mess.

i even reinstalled all software and Firmware to make shure i didnt mess it up by changing values.

I also find it comes either from to many retractions in short intervals or is temperature/feedrate related..

If printing quite slow for a longer period the hotzone climbs gradually and in combination with the retraction create these blobs instantly.

What i try to fix it:

-I hope to find a solution by raising the printing speed. my esteps were 865.888 (filament has less time to get soft)

-I will try to create a coldzone directly above the Hotend. (Fan blowing between wood and Aluminium plate)

-Make some more Filament tests and measurements.. and only buy from trusted and tested shops

(my white PLA is very thin 2.56mm, my white ABS is insane 3.5mm) got by Alibaba.com

Share this post

Link to post
Share on other sites

My first thought would be that if you bumped up your steps per e in effort to get a different flow, you actually have overdone it and are essentially pulling semi-molten PLA/ABS up into the PEEK/PFTE area during retraction and it's creating a plug there. I would say bump your steps back down and change your filament diameter size so that it's creating a "larger" volume. It will then not want to push as much of it out the hotend. But changing that steps per e will affect your retraction speed and distance as well as your flow, so I think that's not a wise means of adjusting flow... Since you are only getting the problem during retraction, I would say that is your likely culprit. The test for it would be to turn your steps per e back down to where it should be and turn your filament diameter up until it matches the flow you want. Then try your retraction again and see if that produces the same failure. Just my two cents though!!!

Share this post

Link to post
Share on other sites

correct. if E is too high it also affects retraction and makes things worse. you need E to be about right (or retraction to be off).

an active cold end is the correct solution as SG, myself and others have also found - any long prints or idle periods will otherwise allow heat to creep up the barrel and form a plug.

Share this post

Link to post
Share on other sites

Gosh i want one of those ultimakers that run 54h straight...

Im getting thick hard-skin on my fingers, disassembling these hotends over and over.

Using my V2 Nozzle, V3 Bolt and the Springfeeder Part.

My problems are actually getting worse...

Nothing helped so far. I noticed my Aluminum plate is getting very hot..

I start thinking my Nozzle is blocked by some hard debris that doesnt fit through.

So i took it apart.

While hot i placed a 3mm drillbit all the way in from the bowdenside.

I let it cool down and pulled out the drillbit with all plasticsremains and stuff.

Then i took some steelwire to push through from nozzle side.

This went well. I tested pushing some filament by hand directly into the PEEK. there was quite some pressure but i had a good stream of glossy PLA coming out the Nozzle.

I didnt notice the forming of a plug in the bowden or the white insulator but still cant print.

So i gave it another try to get printing again.


First a good Perimeter and Loop was printed but as soon as the Bottom Infill started it got back to dribble just little PLA drops.. I rushed to forcepush the filament a bit but it would slip again as soon i let it go.

Share this post

Link to post
Share on other sites

I just changed back to a clean V1 nozzle and i can print again... but still got the problem.

all other settings stayed same.. no retraction.

Must be my V2 Nozzle is internally damaged or blocked somehow... lucky i didnt buy it extra.


I noticed that the tread sealing tape that came with the Ultimakerkit didnt survive in the nozzle... it Backed out to a hard and brittle substance. maybe its this stuff that clogged my V2 nozzle.

Share this post

Link to post
Share on other sites


Finally my Machine works again.

I dont think moving the machine from ground to table brought this effect.. (temperature)

I now mounted an older V1 Nozzle, removed the white Insulator and voila... no further hardware changes.

I took the fast print preset in cura.. (have to export that again to see what the difference to my profile was)

i slowed the print down to 60% though. took 30mins to print.

I also noticed when i want to print a gcode thats been generated to print a t 50mm/s i will have shifted Prints...

If set to 70mm/s they pop out perfect. :shock:

Share this post

Link to post
Share on other sites


i had a similar problem. The solution was, after cleaning the hot End, that i had mounted the brass pipe in the wrong direction. The other point of my problem was, the my filament is to thick (2.98 - 3.14mm). When i am using the ultimaker filament everthing works fine.

Share this post

Link to post
Share on other sites

i had a similar problem. The solution was, after cleaning the hot End, that i had mounted the brass pipe in the wrong direction.

That could also be a reason for your issues with the V2 hotend. I don't see any pictures of your V2 setup, but there should be a gap somewhere, and it is supposed to be between the heater block and the brass sleeve around the bottom of the PEEK part. The other thing you may choose to do if you are feeling mechanically inclined, go for the V1/V2 hybrid. Alaris, Ian and I are all very pleased with how it's working, though none of us seem to be 100% sure why it's working as well as it is.

Here's the thread.


Share this post

Link to post
Share on other sites

thanks for the input from so many people. It is interesting to see that others are suffering from similar issues. Unfortunately, I have not had much success in fixing my extrusion problem.

What I did:

- checked that the hot end temperature matches that read by the thermocouple, it is ok.

- cleaned and unblocked the hot end.

- checked that the pressure applied by the spring on the extruder ball baring and feed screw is sufficient to grip but does not deform the filament.

- use filament that used to work well and seemed reliable at the time.

- a adjusted the height of the print bed not to start printing on layer that is too squashed that could cause back-flow.

- re-measure the diameter of the filament and re-tuned the filament feed parameters in Cura.

The results I get are still the same. Currently I cannot even print a 10x10x10mm cube without running into the gradual reduction of extruded volume density. See images attached, left is current cube, right is one I printed some time ago, when things were still working.


Here is an image of the V2 extruder, just to confirm I have put the bits in the right way around.


Alaris2, you asked for the E value. here is the profile I used to print the left cube shown above:


filament_diameter = 2.9

nozzle_size = 0.4

machine_center_x = 100

machine_center_y = 100

wall_thickness = 0.8

flip_x = False

flip_y = False

flip_z = False

swap_xz = False

swap_yz = False

model_scale = 1.0

model_rotate_base = 0

layer_height = 0.2

solid_layer_thickness = 1

fill_density = 20

skirt_line_count = 3

skirt_gap = 5

print_speed = 50

print_temperature = 200

support = None

enable_raft = False

filament_density = 1.00

retraction_min_travel = 5.0

retraction_speed = 30

retraction_amount = 0.5

retraction_extra = 0.0

travel_speed = 150

max_z_speed = 3.0

bottom_layer_speed = 20

cool_min_layer_time = 10

fan_enabled = True

bottom_thickness = 0.3

enable_skin = True

extra_base_wall_thickness = 0.0

cool_min_feedrate = 10

fan_layer = 1

fan_speed = 100

fan_speed_max = 100

raft_margin = 5

raft_base_material_amount = 100

raft_interface_material_amount = 100

support_rate = 50

support_distance = 0.5

infill_type = Line

solid_top = True

fill_overlap = 15

bridge_speed = 100

sequence = Loops > Perimeter > Infill

force_first_layer_sequence = True

joris = False

retract_on_jumps_only = True

enable_dwindle = False

dwindle_pent_up_volume = 0.4

dwindle_slowdown_volume = 5.0


start.gcode = ;Sliced {filename} at: {day} {date} {time}

;Basic settings: Layer height: {layer_height} Walls: {wall_thickness} Fill: {fill_density}

;Print time: {print_time}

;Filament used: {filament_amount}m {filament_weight}g

;Filament cost: {filament_cost}

G21 ;metric values

G90 ;absolute positioning

M107 ;start with the fan off

G28 X0 Y0 ;move X/Y to min endstops

G28 Z0 ;move Z to min endstops

G92 X0 Y0 Z0 E0 ;reset software position to front/left/z=0.0

G1 Z15.0 F{max_z_speed} ;move the platform down 15mm

G92 E0 ;zero the extruded length

G1 F200 E3 ;extrude 3mm of feed stock

G92 E0 ;zero the extruded length again

;go to the middle of the platform (disabled, as there is no need to go to the center)

;G1 X{machine_center_x} Y{machine_center_y} F{travel_speed}

G1 F{travel_speed}

end.gcode = ;End GCode

M104 S0 ;extruder heater off

M140 S0 ;heated bed heater off (if you have it)

G91 ;relative positioning

G1 E-1 F300 ;retract the filament a bit before lifting the nozzle, to release some of the pressure

G1 Z+0.5 E-5 X-20 Y-20 F{travel_speed} ;move Z up a bit and retract filament even more

G28 X0 Y0 ;move X/Y to min endstops, so the head is out of the way

M84 ;steppers off

G90 ;absolute positioning

support_start.gcode =

support_end.gcode =

nextobject.gcode = ;Move to next object on the platform. clear_z is the minimal z height we need to make sure we do not hit any objects.

G92 E0

G91 ;relative positioning

G1 E-1 F300 ;retract the filament a bit before lifting the nozzle, to release some of the pressure

G1 Z+0.5 E-5 F{travel_speed} ;move Z up a bit and retract filament even more

G90 ;absolute positioning

G1 Z{clear_z} F{max_z_speed}

G92 E0

G1 X{machine_center_x} Y{machine_center_y} F{travel_speed}

G1 F200 E5

G92 E0

replace.csv =

As always, any input would be much appreciated.


Share this post

Link to post
Share on other sites

hi guys

i got a similar problem. seems to have many reasons for same effect. Filament, temp, pressure, and so on.

i could get rid of it by adding severals things to my machine..

i hope they may help you too.

its crucial that you have set e-steps that perfectly fit the filament you use.

heres what i did.

- check all belts tension and alignment. do this regularly and check if the pulleys are tightened.

- adding a fan to hotend that blows between Alu and wood creating a coldzone.

- double check if endstopcables get near to steppercables. (Interference) divide them better and have them properly twisted. make shure you dont wind them up to coils when binding with cableties.

later i also:

- changed back to standard feeder pressure lever. I know its strange, but i just have better prints with it right now.

- changed back to V1 Nozzle. My V2 got clogged with bits of burned-out teflon tread sealing tape. dont use that tape!

Share this post

Link to post
Share on other sites

have to admit active cold zone and V1 nozzle seem to be key recurring themes here.

unfortunately there's no E value in what you pasted sven - it looks like you're using Cura in which case the number you want is 800 something and will be hiding in the first run wizard page.

(actually, the number isn't something we can check - only you can do that by ensuring you follow the steps in the first run wizard. the number varies a bit by filament and machine. mine is 893 or so, some people have as low as 835)

Share this post

Link to post
Share on other sites

All right. I misunderstood E-value as extrusion parameters in general, but I know what you mean.

I have done the first run wizard a few times now. At the beginning I was tweaking the values, but now I keep them to the measurements. The only parameter I am unsure about it the diameter. Using callipers I measured the diameter but my filament is oval shaped varying between 2.8 and 3.0 mm. I try to put in some kind of average but I realize that that might be sub-optimal.

How do other people address this issue for setting up the correct E-value?

Share this post

Link to post
Share on other sites

There is no point going crazy with measuring, because it will change through a single roll....

If you get it about correct thats fine. So probably in your case just put in 2.9mm as the diameter.

Sometimes it can be 2.7 or 3.05 in which case you need to alter that value. But there is no point in stopping

every hour to change from 2.9 to 2.92 and so on.

In the end you will need to alter the steps per e because its different for each machine. Depending on

real hotend temp, how you assembled it, if you put tin foil in between the heater+thermocouple holes and hotend

and so on. Also the nozzle diameters will all be a tiny bit different. All of which effects how much filament will

be extruded for a certain number of rotations of the extruder. You would think that if it turns 10x then

it MUST extrude a certain amount. But if the pressure to extrude is higher because of different hotend temp, then

there will be a small "slippage" in the extruder, so less will come out. Also depending on spring pressure etc.

I think when I did the wizard at first I got something like 850, and I ended up tweaking to 880 or something.

It will be different for every machine, so you do need to just try yourself. The machines are not manufactured or

set up with sufficient prescision to be able to just set them all to what the wizard says and hope its perfect.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 114 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!