Jump to content
Ultimaker Community of 3D Printing Experts

Power Cord loose fit


DudeUser
 Share

Recommended Posts

Posted · Power Cord loose fit

This is a common problem. You aren't plugging it in all the way because the circuit board isn't centered in the hole. Loosen the 4 screws holding the circuit board - just loosen them a little - then you can plug the connector all the way on (it latches permanently and won't come off unless you slide the latch on the power cord). Then re-tighten the 4 screws that hold the circuit board in place.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Our picks

    • Ultimaker showcase | April 2022 | 4pm CEST | 10am EDT
      I'm excited because I've personally produced this showcase event, so if you are curious what else I'm up to nowadays, come check it out and say hi in the chat! It would mean a lot! 
        • Thanks
        • Like
      • 4 replies
    • New here? Get ahead with a free onboarding course
      Hi,
       
      Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
      Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
      They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
      Ready? Register your product here in just 60 seconds.
        • Like
      • 12 replies
×
×
  • Create New...