Jump to content
Ultimaker Community of 3D Printing Experts
limeyboy

UM2+ Z-Axis Low At Start [**SOLVED**]

Recommended Posts

Hello

This forum has been a big help to me, thanks to all that take the time to respond. I did search but could not find a similar fault/fix.

Had an UM2 for 3 years - no real issues. Two weeks ago I upgraded to the + (including firmware) and since then I've had intermittent issues with the start of the print. The nozzle will be anywhere from 1mm to 5mm away from the bed for the first layer, so it prints in fresh air.

Bed leveling / calibration = makes no difference (tried 10+ times - bed is level and just a bit of friction between the paper and nozzle)

Factory reset = made no difference

Sometimes I power off the printer, power immediately back on, start the print and all is good - even if 30 secs ago it was printing in fresh air. Sometimes I need to do this 4-5 times before it works.

As an additional note: At the same time this ^ fault appeared, I started to get the error 'Error stopped - Z switch stuck' - but powering off and on clears it every time.

Both are intermittent issues - if there is no Z error and the first layer is down correct - the print turns out great.

Thanks for any suggestions (that won't cost me more money :))

JW

Edited by Guest

Share this post


Link to post
Share on other sites

Thanks neotko

I checked the Z screw is tight and centered and the Z switch is triggering (multimeter on the switch).  Not sure what the "Z Endstop" is? Bed stops when the 3 bed levelling screw heads contact the base.

Can anyone tell me (or point me to) the sequence that triggers the "Z stuck" error because what I don't understand is how: The bed can be down, I press to start a print and without the Z axis moving or trying to move at all = Z stuck error comes up.

I could understand:

- Bed moving down, switch does not on = error

- Bed moving up, switch does not go off = error

But how does zero movement trigger an error?

Thanks again.

JW

Share this post


Link to post
Share on other sites

So does anyone have any further ideas before I contact Ultimaker support?

I am still having two intermittent issues:

- Print starts with bed too far away (down) from nozzle

- Z switch stuck error (I'd still like to know the logic conditions that trigger this message...)

Here is what I have done since first post above:

- Factory reset again

- Re-levelled the bed - many times

- Checked the z-switch is working - both at the switch and on the board

- Checked the board - to make sure everything is where it is supposed to be and there are no lose connections after the UM2+ upgrade.

- Deleted the UM2+ machine profile in Cura - downloaded default firmware for UM2

  - (I cannot actually run as an UM2 now I have the UM2+ upgrade because the feeder runs in the opposite direction running UM2 firmware).

- Re-installed UM2+ machine profile in Cura - downloaded default firmware for UM2+.

Since Saturday I have had two good prints and approx 20 aborted soon after start - due to one of the above errors.

Because I had so many uneventful prints over 3 years before fitting the UM2+ upgrade I am currently convinced it is the upgrade, probably firmware, that has caused both these issues to come up. Or this is a bad coincidence.

Cheers for any pointers.

JW

Share this post


Link to post
Share on other sites

So does anyone have any further ideas before I contact Ultimaker support?

mmmhh, are you sure, that you have placed the plug of the small 5V fan at the correct connector ("Fan 5V" J34)? If you accidently plugged it to the 8/16 STEP (JP3)...this would explain your symptoms...

Yes I went back to the circuit board and verified this connection - I've searched posts and tried most of the ideas for any "Z" axis issues - and I saw that one come up a couple of times.

This is also an intermittent issue - every now and then (not often) - a print starts and ends well.

Thanks for the idea though - any more nuggets?

JW

Share this post


Link to post
Share on other sites

SOLVED

I was put in touch with local support = FBRC8 located in Memphis, TN. I have to say they were great through the diagnosis, good frequent contact with solid ideas to try.

After checking a few wires and settings (all ok), I downloaded Pronterface. All the checks in Pronterface came back ok as well.

Eventually Spencer @ FBRC8 said to send it in to them - they provided the packaging and shipping note and within a couple of days after receiving the printer they said the Z-Motor was bad. One clue here was they said it should be possible to raise the bed by hand lifting on the bed - I had to manually raise the bed by also turning the Z-screw shaft at the same time as lifting on the bed.

So the Z-motor was sticking at certain points which explained why it must have lost its position and was trying to start prints with a 5mm gap between the nozzle and the bed. The Z-switch stuck error had to have been related to the Z-Motor.

FBRC8 replaced the Z-motor, calibrated etc and determined all was well again.

I will say that the second e-mail I got from FBRC8 back at start of Feb mentioned the possibility that the Z-motor may be bad - so they nailed it early - but tests I performed did not immediately back that up.

I am happily back printing excellent quality parts as I am used to with my UM2.

Big thanks to FBRC8 and especially Spencer - good support all around and based off this experience I recommend them highly.

Thanks also to those that posted here with ideas for me to try.

Cheers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • Our picks

    • Architect Design Contest | Vehicles.
      We're open for entries! - Design and submit your 3D designs of architectural entourage - vehicles - for a chance to win a large filament pack. Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled model can really help to get your idea across.
        • Like
      • 24 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 22 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!