Jump to content
Ultimaker Community of 3D Printing Experts

UM2+ feeder on UM2, firmware and software question


Recommended Posts

Posted · UM2+ feeder on UM2, firmware and software question

Hey folks,

I just upgraded my UM2 with the UM2+ feeder. After updating the firmware to UM2+ firmware via cura I read that I need to double the e -value for the stepper motor of the feeder. I believe this isnt't possible through cura, and I have to manually download the firmware and change the e-value?

Another problem I have with cura is that for the UM2+ I cant change the machine settings to add temperature control. Is there any way around this or am I forced to use simplify 3d?

(also when using simplify I could just double the extrusion multiplyer instead of changing the firmware)

Problem with this is that the printer is used by students who do know cura, but not simplify.

Thanks in advance, Sen

  • Link to post
    Share on other sites
    Posted · UM2+ feeder on UM2, firmware and software question

    You really want to fix the steps/mm or it won't do "insert filament" properly either. So I recommend just using cura to install the UM2 "plus" firmware. You might have to do a "reset to factory defaults" after that as I think the firmware tries to honor your older steps/mm settings. Alternatively you can install tinker Marlin which lets you adjust these values right from the menu. I recommend version 16.01. Or you can also adjust steps/mm with a gcode and then do a M500 gcode to save the new steps/mm.

  • Link to post
    Share on other sites
    Posted · UM2+ feeder on UM2, firmware and software question

    I'm not sure what you mean by temperature settings but I have a guess. If you use the default cura settings for a UM2 it produces "ultigcode" which allow you to specify certain things on the printer instead of the slicer including: filament diameter, print temp, bed temp, retraction distance, fan speed multiplier.

    If you want to specify temp in the slicer you can choose "reprap mode" gcode instead of "ultigcode". This is in the machine settings in cura. If you do this then any of these settings on the printer are ignored.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...