Jump to content
Ultimaker Community of 3D Printing Experts
Amanwhocan

Ultimaker Original and 3D printer heated bed - temp reads '0' - any ideas?

Recommended Posts

Hi there

I have an Ultimaker Original and have added a third party version 3 heated bed (the common black one).

All was going well, I have added the bed, a glass plate - MOS-FET module. Upgraded Cura to the latest version, firmware upgrade done. The temp sensor to the bed is wired to 'temp 3'. I have tried with and without the 4.7K resistor. the display has a temp reading for the bed, but it shows '0' - can anyone advise?

I have also tried a spare temp sensor connected to 'temp 3' - same result

Best regards, Kev

Edited by Guest

Share this post


Link to post
Share on other sites

Is this the newer UMO with the white circuit board? If so it is expecting a PT100 temp sensor.

And kind of temp sensor is this? There are so many types. For example a lot of people use thermistors for heated beds because they tend not to get much hotter than 150C and many thermistors can't handle temps over 150C. Or some people use PT100 or some use thermocouples. It matters.

And although every PT100 out there has the exact same table that translates resistance to temperature, that is not true of most thermistors. Company A might sell 3 different types of 100K thermistor and company B will almost certainly sell a thermistor with a 4th type. They are almost all different. You need to know exact brand and model number of the thermistor and then make sure the UMO firmware has the right temp table.

Share this post


Link to post
Share on other sites

Thanks for the prompt reply, the motherboard is a green one, V1.5.7.

The heated bed came from Anet and has the connector on it, unfortunatly there does not seem to be any info on the sensor. I think I need to know two things - do I need the 4.7K resistor to be fitted at R4 position, and where to set the sensor type? I have read some people referring to editing the 'configuration.h' file. Although I was an electronics engineer, and now work with PC's I do not have much experience with 3D printing software. Do I need to make changes in Cura or in the Ardunio software, and if so where / how? Any help will be much appreciated. The Ultimaker works, the MOSFET module heat's the bed up if I manually add a 12V signal to the input - I just need the temperature to be sensed!

best regards, Kev

Edited by Guest

Share this post


Link to post
Share on other sites

There is firmware on the V1.5.7 board called "marlin". Named after the fast swimming fish that turns corners quickly. There are lots of great marlin builders that make it trivial to build your own Marlin for your own configuration:

http://marlinbuilder.robotfuzz.com/

and

https://bultimaker.bulles.eu/

Both of the above dont' work for UM2 but work great for UMO. Probably the second link is better. Each have their pluses and minuses of features.

Before you build your own marlin though you need to learn more about your sensor. Disconnect it from any circuit and measure the resistance at room temperature and measure the temperature of the room at the same time and make notes. Then repeat at a second temperature (which won't be as accurate but what can you do). The second temperature should be at least 30 degrees hotter. Doing it at 100C (boiling temp) might work well - you could put water on the heater and stop when it starts boiling? maybe? Really you want to wrap it all up in a towel with a thermometer in there.

After doing that you can look at all the thermistor tables in Marlin and see if you can find a match. Hopefully it's not a PT100 because the V1.5.7 board can't handle that. Hopefully (and likely) it's a 10K or 100K thermistor which is at 10K ohms or 100K ohms at some common temp (I think either 25C or 0C) but beware there are *many* different temperature curves for your "generic" 10K thermistor. In other words each manufacturer has a different temp table. But there are only 20 or so commonly sold 10K and 100K thermistors so yours is likely in the Marlin tables somewhere.

You can look at these tables here in github.

Well first I think this is still the current Marlin for UMO for V1.5.7 board - it certainly works just fine:

https://github.com/ErikZalm/Marlin

Here is the file with the thermistor tables:

https://github.com/ErikZalm/Marlin/blob/Stable/Marlin/thermistortables.h

Glancing at that table you have to know a few more things. The thermistor is in series with a 4.7K resistor typically (or noted in the comments if it's a different resistor). The arduino puts out 5V and the value measured back is with a 12 bit ADC so values go from 0 to 4096 representing 0 to 5V (actually it goes to 4096 which represents something slightly under 5V but the math works out to 5V and 4096 if I understand correctly - either way - close enough). The 5V is kind of irrelevant because it cancels out of any calculations.

Note that if you look at those marlin builders, they have a drop down to choose the thermistor for your heated bed and you might want to just look through that list and try to buy one (they cost very little - pennies in bulk, maybe $1 if you buy just one) that matches exactly one in the list and just add it to your heated bed and forget about the one that came with the bed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • Our picks

    • Architect Design Contest | Vehicles.
      We're open for entries! - Design and submit your 3D designs of architectural entourage - vehicles - for a chance to win a large filament pack. Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled model can really help to get your idea across.
        • Like
      • 24 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 23 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!