Jump to content
Ultimaker Community of 3D Printing Experts
jimmythegent

first layer blob problems with PLA

Recommended Posts

blob 1blobs 2final first layer after adjustments

Hey all, my first post on here so please be kind, and I'll try not to waste your time!

I'm using the rev 3 ultimaker.

I started with ABS, and have moved on to PLA and I'm having some issues with printing the first layer of this 4-sided pyramid.

There seems to be quite a lot of lumps and blobs and so on and whatever I try doesn't seem to get rid of it. It seems like there's too much material squirting through the nozzle.

I've tried tweaking the temperature (190, 205, 210, 220). 190 doesn't print so well and the material stops extruding about halfway through the first layer. The others seem to be blobbing - 220 a little more so.

I'm printing at 60mm/sec.

I've change the E-steps around a bit to no effect really (all between 835-890 or so). Calibration is saying 97mm is getting extruded on a 100mm gcode hence the 890 setting.

Cable thickness is all set up properly and playing around a half mm either side doesn't seem to make a difference either.

Any hints/tips Ultimanauts? Might it be dodgy material? Or is there some settings I've not taken into consideration?

 

Share this post


Link to post
Share on other sites

A picture would be helpful after the skirt is laid down. But what you are describing sounds like "bed levelling" issue. I don't mean levelling exactly but height. Try lowering (or possibly raising) the bed by a tiny amount. Make sure you level with a hot nozzle (as it expands when hot) and use a piece of paper to check in all 4 corners.

Also is packing density set to "1.00"? It should be.

 

Share this post


Link to post
Share on other sites

Ah that was the idea of the gallery thing but I hadn't finished the upload.

 

Here's some pics. I'm levelling with a piece of paper basically until the paper is just a teensy bit dragged by the head so I'll try a little lower I guess... Next Ultimaker upgrade - get some sort of touch sensitive heatbed that levels itself...

 

blobs 2

blob 1

 

Share this post


Link to post
Share on other sites

Hi Jimmy, welcome to the forum.

Looks like your first layer height is close to the bed - maybe a touch too close, it's hard to tell. In general, I wouldn't worry about that, as you're getting a nicely squashed first layer, that should stick well. But then there's all the blobbing, which I think is excess extrusion escaping when it can. So the question is - why is there so much extrusion?

What layer height are you printing, and are you requesting extra thickness for the first layer? Also as George mentioned, do you have the packing density set to 1.00?

You may want to check your steps-per-e again, and also the filament diameter. It might be helpful to attach the gcode file here, so we can take a look and see if anything seems odd with your settings.

 

Share this post


Link to post
Share on other sites

It's hard to tell from the picture, but the picture is very helpful anyway. I agree that the bed is a little too high and the plastic can't get out of the nozzle and every once in a while a blob suddenly escapes. Try lowering the bed. the paper method is good but maybe you did it cold? Maybe the "teensy" bit of drag is still a little bit too much drag.

Or maybe the levelling is fine and you have some setting wrong but I think it's the levelling.

 

Share this post


Link to post
Share on other sites

BTW, if you're trying to print very thin layers (less than 0.1mm) then maybe try setting a thicker first layer - perhaps 0.2 or 0.3mm). That will make any z-level inaccuracy less critical, and give you a better shot at getting the first layer down well for everything else to build on.

 

Share this post


Link to post
Share on other sites

Thanks for all the replies folks.

Packing density is set to 1, layer height 0.2. Pretty much the default settings in Cura.

I've measured up the filament (2.9mm) and done a test extrusion to get the e-step settings (a little under at around 97mm for 100mm gcode making the estep setting around 890).

As far as I've read - on these forums - the estep is just a pressure setting so isn't sooo likely to have drastic effects on the print - I'd be very happy to hear opinions on that one.

Will give the bed lowering further a try and report back, cheers for all your help!

 

Share this post


Link to post
Share on other sites

Jimmy - I strongly recommend that to I attach a gcode file here so we can check it out. (If you click 'More reply options' then you get a different user interface that lets you attach files).

No, the steps-per-e is absolutely fundamental to the print process. The slicer looks at the length of line segment that you want to print, and based on the nozzle width and layer height, it calculates the volume of plastic needed at the hot end during that part of the print.

Based on the declared width of the filament, it figures out how many mm of raw filament it needs to feed into the cold end of the system to get that volume. And the gcode specifies that number of mm for the e move on that line of code.

The steps-per-e is what the firmware uses to figure out how far to turn the stepper motor to get that many mm of plastic fed into the Bowden tube, and hence that volume of plastic squirted out of the nozzle. If your steps value is wrong, then you get either too much or two little plastic for the segment being printed.

A few percent error isn't going to make too much difference to a print - except perhaps if you already have a bit of z-error on a narrow first layer, so even the right amount of plastic is struggling to get out. With the latest stock equipment, the general consensus is that the 'right value' is about 830.

Share this post


Link to post
Share on other sites

OK Chaps just uploaded it to Mediafire - here's the basic file I've been using with temp, estep and filament diameter width settings changed in the filename.

If there's nothing wrong - perhaps tell me which of those (estep/temp esp) might be the best to work with to get the levelling right....

 

Share this post


Link to post
Share on other sites

The gcode looks fine... I see that you're slicing with a first layer height of 0.3mm, but in your photos it looks a lot less than that, so I suspect that your z=0 position is wrong. Also, at the start of the skirt, it does an unnecessary 4.5mm de-retract (which is a bug in Cura), and yet I don't see any sign of major blobbing at the start of the skirt either. So I think that the plastic couldn't escape due to the closeness of the nozzle to the bed. And then this excess pressure build up is compounded by the fact that the printer thinks it's printing a 0.3mm first layer... pressure builds up, and then starts to squirt out in blobs.

Therefore I recommend you heat the nozzle, autohome the bed, and then carefully re-level the bed at each corner, and then try again.

Also, I noticed that you included multiple gcodes with different file names that included an 'Exxx' value in the name. Does this reflect you changing the E steps value in Cura before each slice? Because if so, it isn't doing anything. The e-value you specify needs to be included in an M92 Exxx command at the start of the gcode file - but it isn't there. I'm not sure exactly how/when Cura includes it - maybe you have to add placeholder code in the start gcode for it.

To be honest, the gcode of every print isn't the best place for it. It should be set in the firmware ok the printer and saved to EEPROM. If you have an Ulticontroller, it's easy to do (Control -> Motion). If not, then you can use Cura or pronterface etc to connect to the printer and issue the M92 command, followed by M500 to do the save. (Best do this on a freshly power cycled machine, so you don't also save any other temporary settings that got changed in the last gcode you printed).

 

Share this post


Link to post
Share on other sites

I feel like I already answered your question and you ignored it. I've seen this exact thing "blobs" and thin first layer and fixed it by lowering the bed about .1mm. Did you at least try it? I could be wrong but, again, I have some experience with this exact problem and that fixed it for me.

So: Level one more time. Use the paper method. Make sure nozzle is hot (or you will be too tight). Do the exact leveling procedure you did before but now after you get it perfect, lower the bed an additional tiny bit - maybe 1/8 turn on each screw (tighter of course).

Or alternatively, just tighten each screw 1/8 turn and try first layer again.

Or alternatively, level like you normally do but there should be just the slightest resistance to the paper. barely barely more than if there is a huge gap.

 

Share this post


Link to post
Share on other sites

 

final first layer after adjustments

 

First layers coming out much better now folks. Sorry gr5, wasn't ignoring you - just didn't reply - sorry about that.

 

Bed levelling was the answer - as gr5 stated. I had quite a few problems with bases coming unstuck so went proper low on the levelling front. I've gone further down but it seems like the part isn't sticking - guess it's going to be a matter of an 1/8th turn here and there to get it right...

Turns out the estep setting is at 836 in Ulticontroller already so I assume that would override the part gcode.

 

Share this post


Link to post
Share on other sites

yay! Now that you know how important bed leveling is, you will get very good at it. Keep in mind that it changes over the course of a day or so (the wood bends over time and even 5 hours can be enough time to mess it up on a new UM).

On older UM's the wood eventually slows down it's droop but I'm so good at levelling now it's no big deal to do it before every print.

 

Share this post


Link to post
Share on other sites

This is an old post but I thought I would give my two cents.

It looks like the filament simply is not getting fed through at a consistent rate or maybe the nozzle is clogged.

I use an ANET A8. This is exactly how my prints looked when I had replaced the hollow screw that guides the filament to the nozzle. I realized I simply had that screw in upside down. After I flipped it, it worked great. The size that has the plastic part showing in the screw needs to face downwards and the beveled metal end of the screw needs to face upwards.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy