Jump to content
Ultimaker Community of 3D Printing Experts
Kefon

Problem with spiralize in CURA 3.6

Recommended Posts

Hi everyone! I'm having a weird behavior with CURA 3.6 and spiralize (vase mode).
Some layers are missing, replaced by a straight line... (see the pictures)
I'm using a very classic profile, execpt for the spiralize outer contour mode.
 
CURA 3.6
--> Layer display shows some missing or partially missing layers
--> If I print like this, yes, the problem is visible in the part
--> If I move down the part in CURA to print only the top of my piece, to make a quick test on where the problem is, well, no more problem displayed in CURA and the print is ok, the problem disappear! (but it reappears as soon as I try to print the whole part)
 
CURA 3.4.1
--> No problem at all!! (with the exact same profile)
After looking everything, I wanted to try other older versions to see where the problem is, and check if the problem comes from CURA 3.6 or my STL. CURA 3.5 and 3.5.1 have the same problem, but with CURA 3.4.1, no problem at all, all my layers are here!
 
Does anyone have any idea about this problem? Is it a known bug?
Thanks in advance for your answers!

cura-pb-1.jpg

cura-pb-2.jpg

cura-pb-3.jpg

Share this post


Link to post
Share on other sites

Waaaaayyyy, back in the day, during the 3D rendering dark ages, if an object was in one location, it would generate a black spot. If the model was moved just ever so slightly, or even the camera, it would go away.

 

Just for funzies, I wonder if it would remain if moved. Basically, a null return based on a positional issue.

Share this post


Link to post
Share on other sites
18 minutes ago, kmanstudios said:

I have seen this happen periodically in regular slices too. It seems to be a sporadic issue that is not persistent. If I slice again, it goes away. I have not tried to print one, but seems to be more of a graphics issue and not a real slice problem.

 

Well, this is not a graphic issue as I tried to print it (as mentionned by @DidierKlein) and the problems are "real" and appeared on the printed part. I tried to sliced it again, and the problem is still there, at the exact same position.

 

BUT! I discovered one more clue to this problem. I was scaling the part (not uniform).

I tried different scale to see where the problem occurs :

100% scale (uniform) -> no problem

70% scale (uniform) -> no problem

80% (XY) / 63% (Z) (not uniform) -> no problem

73% (XY) / 63% (Z) (not uniform) -> no problem

74% (XY) / 63% (Z) (not uniform) -> !!! problem !!!

 

So I tried different not uniform scalling, and some show the problem, and some not.

I have no clue on why or why not. but at least I can remove the problem by just changing a bit the scaling.

So for now I solved my problem, but this weird behavoir still exists 😉

 

@smartavionics the piece is part of a work in progress for an art piece, so I can't publish it on the forum...

I just send you a PM.

 

Thanks everybody!

 

 

 

 

Share this post


Link to post
Share on other sites

Hi @Kefon, I briefly looked at your project. Yes, it does have that weird missing layer with the straight line. I set the experimental setting called Slicing Tolerance to Inclusive and it appears to slice OK (layer view looks OK, haven't actually looked at the gcode yet). So I wonder if there is something in the model that doesn't get converted into Cura's internal representation correctly? Will play with it some more later or tomorrow. Hope this helps.

Share this post


Link to post
Share on other sites
1 minute ago, Kefon said:

@smartavionics I just tried the Inclusive on Slicing Tolerance, you are right, it's better, but still some problems on some layers. But good to know! I never tried this option. Thank you for trying 🙂

 

I am using my own version of Cura which has some fixes to the spiralisation which haven't made it into Ultimaker's Cura yet so you may be seeing a problem that I have already fixed. If you want you can try one of my releases which I have mentioned many times on this forum.

Share this post


Link to post
Share on other sites

BTW, @Kefon, Cura mesh tools plugin says that your nice model is not watertight so I think that maybe explains why you get that weird missing line. Also, if you look at the model in a viewer, you can see there is something weird in the area that has the missing line. You can see it here about 1/2 way up this image there are some darker segments...

 

Screenshot_2018-12-15_08-23-09.thumb.png.80360ab187f6892f07cf779317881b45.png

 

Screenshot_2018-12-15_08-21-40.thumb.png.aa19cf5701f1bb54fe8c8fb62130703d.png

 

Screenshot_2018-12-15_08-20-32.thumb.png.e7e50455384cb2a372b28985e7b141ed.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 95 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!