Jump to content
Ultimaker Community of 3D Printing Experts

Overriding Start G-Code (CURA 4.0.0)


NoviceExpert
 Share

Recommended Posts

Posted · Overriding Start G-Code (CURA 4.0.0)

I have been using the old 15.04.6 version of Cura for a long time. I have been advised to upgrade to the beta to check out the new features and so far am impressed with the 4.0.0 beta. However, I like my bed and extruder to heat up at the same time and these added lines of G-Code prevent that when I slice.

M140 S{print_bed_temperature}
M105
M190 S{print_bed_temperature}
M104 S{print_temperature}
M105
M109 S{print_temperature}
M82 ;absolute extrusion mode

Where do these lines get added, because I used to be able to heat both at the same time with 15.04.6 with the following code.

M107; FANS OFF
M140 S{print_bed_temperature}
M104 S{print_temperature}
G91; RELATIVE POSITIONING
G28; HOME ALL AXIS
M84; KILL MOTORS
M109 S{print_temperature}
G90; ABOSOLUTE POSITIONING
G1 X5 Y5 F10000; MOVE CLOSE TO HOME
G28; HOME ALL AXIS
G29; PROBE BED
M190 S{print_bed_temperature}
G1 Z100; RAISE Z-AXIS TO 100MM
G1 X0 F1000; MOVE SLOW TO HOME
G92 E0; ZERO EXTRUDER
G1 E10; PRIME NOZZLE
M25; WAIT FOR USER
G92 E0; ZERO EXTRUDER
G1 F{travel_speed}; START
M140 S60
G92 E0

I don't want to have to remove the lines everytime I slice a print, can these lines be edited or taken out of start G-Code somewhere?

  • Link to post
    Share on other sites

    Posted · Overriding Start G-Code (CURA 4.0.0)

    Basically it should be possible to use the same start script as before, but the names of the settings / replacement patterns have changed.

     

    You will probably need:

     

    {material_bed_temperature_layer_0}

    {material_print_temperature_layer_0}

    {speed_travel_layer_0}

     

    If you're interested:

    @ahoeben compiled a list of all possible variables a while ago: Settings and replacement patterns

     

  • Link to post
    Share on other sites

    • 1 year later...
    Posted · Overriding Start G-Code (CURA 4.0.0)
    On 1/5/2019 at 4:23 PM, tinkergnome said:

    Basically it should be possible to use the same start script as before, but the names of the settings / replacement patterns have changed.

     

    You will probably need:

     

    {material_bed_temperature_layer_0}

    {material_print_temperature_layer_0}

    {speed_travel_layer_0}

     

    If you're interested:

    @ahoeben compiled a list of all possible variables a while ago: Settings and replacement patterns

     

     

    Is it possible to do math in the {} ?   I notice there is width and depth of the print area, but that would be much more useful if I could somehow reference the center of the bed {machine_width/2} or {machine_depth/2}....  or if they would just add a reference for the {machine_width_center} {machine_depth_center}

    • Like 1
    Link to post
    Share on other sites

    • 2 months later...
    Posted · Overriding Start G-Code (CURA 4.0.0)

    Hi, I'm trying to get rid of the M190 and M109 to avoid waiting for the bed and hotend to heatup. 

     

    I tried modifying the JSON (fdmprinter.def.json) like:

     

    #: fdmprinter.def.json
    msgctxt "material_bed_temp_wait label": { "default": false },
    msgid "Wait for Build Plate Heatup"
    msgstr ""

    #: fdmprinter.def.json
    msgctxt "material_bed_temp_wait description": { "default": false },
    msgid ""
    "Whether to insert a command to wait until the build plate temperature is "
    "reached at the start."
    msgstr ""

    #: fdmprinter.def.json
    msgctxt "material_print_temp_wait label": { "default": false },
    msgid "Wait for Nozzle Heatup"
    msgstr ""

    #: fdmprinter.def.json
    msgctxt "material_print_temp_wait description": { "default": false },
    msgid "Whether to wait until the nozzle temperature is reached at the start."
    msgstr ""

     

    And the JSON from my specific printer (robo_3d_r1.def.json) like:

    "overrides": {
            "machine_start_gcode": {
                "default_value": " G92 E0 ;\n M565 Z-1 ;\n G1 Z5 F5000 ;\n G29 ;\n"
            },
        "material_print_temp_wait": { "default": false },

     

    But I'm still getting the waiting codes after slicing. Any ideas on what else could I do?

     

  • Link to post
    Share on other sites

    Posted · Overriding Start G-Code (CURA 4.0.0)

    You could use the post-processing plugin "Search and Replace" and search for "M109" and replace with ";M109".  That should comment all M109's in the file.  Use a second search and replace for the M190 line.

    You may be aware that the M109 line is a safety to keep from running extrusion commands while the hot end is cold.

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...