Jump to content
Ultimaker Community of 3D Printing Experts

Z-axis of all prints reduced by half original thickness


sam

Recommended Posts

Posted · Z-axis of all prints reduced by half original thickness

Hi beautiful/gorgeous people,

I'm facing a new problem recently. My prints for X and Y axis are good, just a slight problem I can solve. However, for the height (Z-axis), all the thickness of my prints reduced by half, either the STL files I downloaded or the files I created using CATIA. As far as I concern, I didn't change any setting for the thickness, in fact I didn't found any setting for the thickness as well.

Any idea? Many thanks.. :???:

 

  • Link to post
    Share on other sites
    Posted · Z-axis of all prints reduced by half original thickness

    Looks like, either your steps-per-mm for z has somehow gotten changed, or the stepper-drivers micro stepping setting for the axis is wrong. Do you have an ulticontroller?

     

    1) Which part should I look for steps-per-mm for z axis?

    2) Also where should I look for the stepper-drivers micro step setting?

    No i don't have ulticontroller, all the setting I set all from Cura. It's the same result when I used Cura 12.08 and Cura 13.06..

     

  • Link to post
    Share on other sites
    Posted · Z-axis of all prints reduced by half original thickness

    Does it show half height in Cura? Or only *after* you print?

    If the problem is only *after* you print then download pronterface, and read about the gcodes to set the Z resolution:

    http://reprap.org/wiki/G-code

    https://github.com/ErikZalm/Marlin/

     

    If the problem is in Cura (half height shown visually in Cura) then click on the object then select scale icon in bottom left corner of view, then click the lock to unlock the 3 scales, then change "scale Z" to "2.0".

     

  • Link to post
    Share on other sites
    Posted · Z-axis of all prints reduced by half original thickness

    Does it show half height in Cura? Or only *after* you print?

    If the problem is only *after* you print then download pronterface, and read about the gcodes to set the Z resolution:

    http://reprap.org/wiki/G-code

    https://github.com/ErikZalm/Marlin/

     

     

    Only *after* print. In Cura it shows full length. Then I printed the part, the height only half from the Cura. Okay I will try to download it. Thank you for the link. wink.png

     

  • Link to post
    Share on other sites
    Posted · Z-axis of all prints reduced by half original thickness

    @gr5

    So, after I downloaded the Marlin firmware, I should upload it into my UM? icon_e_confused.gif

     

  • Link to post
    Share on other sites
    Posted · Z-axis of all prints reduced by half original thickness

    I am no electronics person but i have seen that you have posted previously about yourself getting a new RAMPS board.

    Have you checked the jumpers that are sitting near your stepper drivers? For XY-axis all three jumpers should be in place, but for the Z-Axis one should not.

    See here:

    http://wiki.ultimaker.com/Electronics_build_guide

    Fabian

    Edit:

    I think this is what illuminarti meant by "wrong microstepping setting".

     

  • Link to post
    Share on other sites
    Posted · Z-axis of all prints reduced by half original thickness

    Hopefully the jumper issue will fix your problem but if not...

    Changing the Marlin won't help you change the steps per mm. You can *ask* your printer how many steps per mm the Z is set to, then you can double that value, and save it back into your machine.

    Actually I would use pronterface (free) to send the gcodes:

    http://koti.kapsi.fi/~kliment/printrun/

    M503 <- tells you current settings of your machine including steps/mm for z axis (probably 533)

    M92 Z1066 <- sets steps per mm for z axis to 55 (but only temporary until rebooting of machine)

    M500 <-- stores that setting permanently into eprom

     

  • Link to post
    Share on other sites
    Posted · Z-axis of all prints reduced by half original thickness

    I am no electronics person but i have seen that you have posted previously about yourself getting a new RAMPS board.

    Have you checked the jumpers that are sitting near your stepper drivers? For XY-axis all three jumpers should be in place, but for the Z-Axis one should not.

    See here:

    http://wiki.ultimaker.com/Electronics_build_guide

    Fabian

    Edit:

    I think this is what illuminarti meant by "wrong microstepping setting".

     

    Yeah I did got a new RAMPS board, but that board is for my not-yet-finish-build 3D printer. The printer that I hv this problem right now is my UM printer.

     

    Hopefully the jumper issue will fix your problem but if not...

    Changing the Marlin won't help you change the steps per mm. You can *ask* your printer how many steps per mm the Z is set to, then you can double that value, and save it back into your machine.

    Actually I would use pronterface (free) to send the gcodes:

    http://koti.kapsi.fi/~kliment/printrun/

    M503 <- tells you current settings of your machine including steps/mm for z axis (probably 533)

    M92 Z1066 <- sets steps per mm for z axis to 55 (but only temporary until rebooting of machine)

    M500 <-- stores that setting permanently into eprom

     

    Probably the problem is with the codes. The problem is that I hv the firmware uploaded into my UM long long ago, and I'm not change it since then. This is because I dunno where did I saved the firmware program :mrgreen:. I was thinking of uploaded the new Marlin firmware into my UM but I'm really afraid if something I don't like will be happening. :shock:

     

  • Link to post
    Share on other sites
    Posted · Z-axis of all prints reduced by half original thickness

    . I was thinking of uploaded the new Marlin firmware into my UM b

     

    It's pretty safe. Just do it. You can always change it again later.

     

  • Link to post
    Share on other sites
    Posted · Z-axis of all prints reduced by half original thickness

    Ok, I did uploaded the new Marlin firmware into my UM, the thickness is still the same. Then now I try using pronterface. But tbh I really don't know how do I check the current setting for my z-axis or thickness for my object.. I send command M503 but it seems nothing happen, not show anything about my current setting.. :oops:

     

  • Link to post
    Share on other sites
    Posted · Z-axis of all prints reduced by half original thickness

    Oh ya, is it possible to change the orientation of the object in pronterface? I tried looking for the button to change the orientation, but I just couldn't find it :shock:

     

  • Link to post
    Share on other sites
    Posted · Z-axis of all prints reduced by half original thickness

    Orientation? Object? There are no objects that I know of. You can simply control the low level aspects of the machine. For example you can send gcodes. Or move one of the axes.

    Below is a screenshot of Pronterface. As you can see on the right side, I tried sending M503 but nothing happened because I hadn't connected to the printer. So I clicked "connect" and then tried again and it worked. Also notice that when I connected it displayed some information. In fact it looks like the moment I connected, pronterface sent a M503 also. So I got all the settings twice.

    Pronterface Screenshot

     

    edit: As usual to see an image in it's full size you have to first left click on it, then right click and choose "view image" and then usually left click it again except this time my image just barely fits in the screen so you can skip the final zoom click.

     

  • Link to post
    Share on other sites

    Archived

    This topic is now archived and is closed to further replies.

    ×
    ×
    • Create New...