Jump to content
Ultimaker Community of 3D Printing Experts
bill-havins

End Gcode For Rostock MAX in Cura 13.11.2

Recommended Posts

Hello to All,

I am considering using Cura 13.11.2 as the "preferred" slicer for my Rostock MAX. This most recent version of Cura has some very attractive features and seems to work very well. Bravo!

I am having difficulty developing end gcode that works reliably. The "postfix" I am presently using works pretty well, but, after the "G28" is issued (see below) the axes do home, but then begin to step backward very, very slowly. This includes the extruder. The only way I can stop this backward stepping is by turning the printer power off.

M104 S0

M140 S0 ; bed heater off

G92 E0 ; set extruder position to zero

G28 ; home X, Y, and Z axes

M84 ; disable stepper motors

I would appreciate suggestions for developing better end gcode.

Thanks!

Bill

 

Share this post


Link to post
Share on other sites

Here is an end gcode routine that works well in Slic3r and KISSlicer. I wonder if the problem is a firmware issue?

G92 E0; zero extruder

G91; incremental mode

G1 Z3 E-8 F5000; raise Z and reverse filament

G90; absolute mode

G28 ; home axes

M104 S0 ; turn off temperature

M140 S0

The above just doesn't seem to work with Cura. Disappointing.

Bill

 

Share this post


Link to post
Share on other sites

What 'doesn't work with Cura' about it? Cura doesn't care either way, really. The end gcode is jsut text that gets appended to the file, and sent to the printer.

There's nothing non-standard about either version of the end gcode - they both do much the same thing, and using very standard Marlin gcodes. The only difference is that the one that 'works' doesn't explicitly turn the steppers off.

 

Share this post


Link to post
Share on other sites

The CURA endcoade for Rostock machines needs to be improved. I have, on multiple occasions, ruined freshly printed parts by forgetting to change the endcode.

All you need is a G28 command - that will home the machine. I am running a RostockMAX and it works fine. Here is the endcode i use, i strip out anything that is not required to keep it simple.

M104 S0

M140 S0

G28

M84

This works fine, i do not get the motor creep' you speak of.

Hope this helps, would love to see CURA improved for the Rostock machines in the future.

DG

 

Share this post


Link to post
Share on other sites

Thanks, gadgetfreak. Deleting the configuration string (the last line of the gcode) solved the problem.

I am now using Cura 14.01 for all slicing tasks and it is performing well. I really appreciate the efficiency of motion it produces (few-to-no unnecessary hotend movements).

I have successfully converted my Rostock MAX to a dual extruder configuration and Cura slices models such that they print very well.

It would be nice to have the option to "turn off" inclusion of the configuration line in the gcode. But, hey, if that's the only problems I have with Cura it's no big deal.

Next week I'll begin printing files using HIPS for support material. I hope things continue to work well.

Thank you, Daid, et al. This is a great slicer.

Bill

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!