Jump to content
Ultimaker Community of 3D Printing Experts

Nozzle creating pit/hole in the top layer of my print


Mahrooz
 Share

Recommended Posts

Posted · Nozzle creating pit/hole in the top layer of my print

I've recently started noticing that my ender 3 has starting leaving a hole or pit in the last place my nozzle was in my prints as can

be seen in the picture1666742386_holeinprint.thumb.jpeg.4cdcc5720b3d0a89752b445deca30d76.jpeg. I have tried altering my end Gcode however I can't seem to find the problem. I am currently using cura 4.9.1 however I also tried cura 4.8 and I had the same issue there. This is my current end Gcode: 

 

G91 ;Relative positioning

G1 E-2 F2700 ;Retract a bit

G1 E-2 Z0.2 F2400 ;Retract and raise Z

G1 X5 Y5 F3000 ;Wipe out

G1 Z10 ;Raise Z more

G28 X0 Y0 ;move X/Y to min endstops, so the head is out of the way

 

G1 Y100 F5000 ;move bed forward (Y)10mm to remove part at (F)5000 feed rate

 

G1 X0 Y{0} ;Present print

M106 S0 ;Turn-off fan

M104 S0 ;Turn-off hotend

M140 S0 ;Turn-off bed

 

M84 ;Disable all steppers

 

If anyone knows a solutions I would love to hear it:)

  • Link to post
    Share on other sites

    Posted · Nozzle creating pit/hole in the top layer of my print

    The "divot" looks like the nozzle is remaining in contact with the print.  It doesn't look like anything is taking overly long though.  I made some slight changes (in bold) to your end gcode.

     

    G91 ;Relative positioning

    G1 E-4 F2700 ;More retraction and a single retraction

    G1 Z1.2 F2400 ;More rise

    G1 X5 Y5 F3000

    G1 Z10

    G90 ;absolute positioning

    G1 Y{machine_depth} F7200 ;Present Print

    M106 S0 ;Turn-off fan

    M104 S0 ;Turn-off hotend

    M140 S0 ;Turn-off bed

    M220 S100 ;set feed rate to 100% in case tuning changes were made mid-print

    M221 S100 ;set flow rate to 100% in case tuning changes were made mid-print

    M84 X Y E ;Disable all steppers but Z so the X beam doesn't slide down on it's own.

  • Link to post
    Share on other sites

    Posted · Nozzle creating pit/hole in the top layer of my print
    16 hours ago, GregValiant said:

    The "divot" looks like the nozzle is remaining in contact with the print.  It doesn't look like anything is taking overly long though.  I made some slight changes (in bold) to your end gcode.

     

    G91 ;Relative positioning

    G1 E-4 F2700 ;More retraction and a single retraction

    G1 Z1.2 F2400 ;More rise

    G1 X5 Y5 F3000

    G1 Z10

    G90 ;absolute positioning

    G1 Y{machine_depth} F7200 ;Present Print

    M106 S0 ;Turn-off fan

    M104 S0 ;Turn-off hotend

    M140 S0 ;Turn-off bed

    M220 S100 ;set feed rate to 100% in case tuning changes were made mid-print

    M221 S100 ;set flow rate to 100% in case tuning changes were made mid-print

    M84 X Y E ;Disable all steppers but Z so the X beam doesn't slide down on it's own.

    Thanks for the comment, I tried the end gcode however I still seem to get the same result. I tried filming the end of the print in slo-mo in order to see what is wrong: https://1drv.ms/v/s!Ap3DhELSYkH9gcQNjonFE7EdhOHClg?e=P1U3DL

  • Link to post
    Share on other sites

    Posted · Nozzle creating pit/hole in the top layer of my print

    Your machine looks like it's pausing for a couple of seconds.  The only thing I can figure is that the retraction is really slow.

     

    You can't check your "max speed" with Cura, but you can alter it.

    Bring a 25mm calibration cube into Cura.  Make the "Z" = -24 so it sinks into the build plate leaving only 1mm exposed.

    Set the retraction and prime speeds to 30mm/sec.

    Slice the model and create a gcode file. 

    Open that gcode file in a text editor.

    Add these 3 lines just below ";Generated with Cura_SteamEngine 4.9.1"

    M203 X900.00 Y900.00 Z50.00 E50.00 ;Set max speed on all 4 axes.  FYI the units are mm/sec

    M201 X3000 Y3000 Z100 E1000 ;Set max Jerk on all 4 axes

    M220 S100 ;Set the Feed Rate % to 100%

     

    For an example, if your M203 X is currently = 50 then that is the speed limit on the X and if you tell Cura to move at 150 then when a gcode line like G1 X0 Y0 F9000 gets to the printer, the firmware says "whoa, max is 50mm/sec" and so the printer changes the feed rate to F3000 (mm/min) because of the limit.

    There was a poster here who was wondering why his machine was so slow and he was retracting and priming 7mm at 1mm/sec.  Every time there was a retraction and prime it took 14 seconds to complete.  You are only retracting 2mm but if it's at 1mm/sec then the nozzle is going to sit there waiting for the retraction to finish before it raises the Z.

     

    Anyway, save the altered gcode file and print it.  See if it's quicker to finish the end-of-print moves.  If it works and gets off the print in good order then on the LCD select "save settings".  If it didn't make any difference then cycle the machine off and on and the printer will forget those setting changes.

     

    • Like 1
    Link to post
    Share on other sites

    Posted · Nozzle creating pit/hole in the top layer of my print
    22 hours ago, GregValiant said:

    Your machine looks like it's pausing for a couple of seconds.  The only thing I can figure is that the retraction is really slow.

     

    You can't check your "max speed" with Cura, but you can alter it.

    Bring a 25mm calibration cube into Cura.  Make the "Z" = -24 so it sinks into the build plate leaving only 1mm exposed.

    Set the retraction and prime speeds to 30mm/sec.

    Slice the model and create a gcode file. 

    Open that gcode file in a text editor.

    Add these 3 lines just below ";Generated with Cura_SteamEngine 4.9.1"

    M203 X900.00 Y900.00 Z50.00 E50.00 ;Set max speed on all 4 axes.  FYI the units are mm/sec

    M201 X3000 Y3000 Z100 E1000 ;Set max Jerk on all 4 axes

    M220 S100 ;Set the Feed Rate % to 100%

     

    For an example, if your M203 X is currently = 50 then that is the speed limit on the X and if you tell Cura to move at 150 then when a gcode line like G1 X0 Y0 F9000 gets to the printer, the firmware says "whoa, max is 50mm/sec" and so the printer changes the feed rate to F3000 (mm/min) because of the limit.

    There was a poster here who was wondering why his machine was so slow and he was retracting and priming 7mm at 1mm/sec.  Every time there was a retraction and prime it took 14 seconds to complete.  You are only retracting 2mm but if it's at 1mm/sec then the nozzle is going to sit there waiting for the retraction to finish before it raises the Z.

     

    Anyway, save the altered gcode file and print it.  See if it's quicker to finish the end-of-print moves.  If it works and gets off the print in good order then on the LCD select "save settings".  If it didn't make any difference then cycle the machine off and on and the printer will forget those setting changes.

     

    Thankyou again for the comment! I tried the settings and my printer does indeed move faster now, I seem to still get a dot where the print ended but its definitely better then before!

  • Link to post
    Share on other sites

    Posted · Nozzle creating pit/hole in the top layer of my print

    There will always be some time involved when the printer makes a retraction.  It's on it's own line of gcode and that move must complete before the next line gets acted on.

    Another thing you can do is add a new Ender 3 in Cura.  Just give it a different name.  The new printer will have all the defaults from the definition files and we know they work.  With the max speeds set and Cura aware of the settings you should be OK.

    There is an add-on plugin in the Marketplace for Printer Settings.  When it's active it will be the last group of settings in the settings dialog box on the right of the screen.  Go through those and match the settings to what you know to be true of your printer.

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...