Jump to content

Cura Settings not coming every time...


mursa

Recommended Posts

Posted · Cura Settings not coming every time...

Can my custom settings be kept the same every time Cura is started? Is there a way to handle this without making a backup?

  • Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    Thanks for your message. I have implemented your suggestion now. If these settings appear every time I open Cura, the problem is solved.

  • Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    No they don't appear every time you open Cura, but you can just select your saved profile. There is no way to auto load a specific profile on startup. But it is just a click to select the needed profile.

    • Like 1
    Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    A hack/workaround could be to use a saved project instead of profiles and use a saved project to open Cura. Then you have all the preconfigured settings at startup. Just remove the saved object and add a new one.

    • Like 1
    Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    If the option with the saved project works for you, then you are also a little bit more on the safe side during Cura updates. It can happen that a custom profile stops working after an update and then you have to look manually in the profile file why it is not working.

     

    Personally I use only saved projects and when I have to print something new, then I just choose a project of a previous saved print job and replace the model. 

     

    But there are also a lot of users with custom profiles, it is just a personal preference.

    • Like 1
    Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...
    On 7/9/2021 at 7:09 PM, mursa said:

    Can my custom settings be kept the same every time Cura is started?

    I don't understand the question. If you change a setting value and restart Cura, the setting value should still be what you changed it to. If it isn't then something is going wrong.

  • Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    For example, I used cura today and my settings are correct. However, when I open Cura on the second day, I see that the default values have arrived. In other words, the problem is that the default settings come only when you start using cura again. This requires me to reopen Cura, which has hundreds of settings, every time by returning from backup.

  • Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    As ahoeben wrote in his reply, when you change some settings, then quit Cura and reopen it, the settings should still be the same as before the start. 

     

    If not you should check if the configuration folder is writeable for you. Maybe that's the problem.

  • Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    I did what you said for now and it's ok. Thank you for your interest.🙏

  • Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    Thanks for the feedback and happy printing!

  • Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    Can you not just add a save settings button? obviously the settings we put in are the settings we want to use. there are quite a few changes I have been making and it's a pain to have to go back and change them again just because I shut my PC down. Then to start a new project on default settings and everything is wrong.

     

    Thanks

  • Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...
    3 hours ago, robD1701 said:

    Can you not just add a save settings button?

    The settings should save automatically. A "save settings" button would use the exact same code as automatic saving, excapt it would be triggered manually (in addition to it happening automatically). So, logically, if automatic saving does not work for you, then neither would manual saving.

     

    If automatic saving does not work for you, then that is a bug and we have to get to the bottom of it.

     

    Have you tried making a profile out of the settings you changed?

  • Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    I had the problem and it went away by itself, but I needed to change something (add a material) to trigger settings to save for some reason after upgrading to 5.4.0. I mentioned that on a similar topic: 

     

    Note that always save my own material and print profiles too, as noted by ahoeben:

    On 10/28/2022 at 3:31 AM, ahoeben said:

    Have you tried making a profile out of the settings you changed?

     

  • Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    не, друго ми трябва

  • Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    That comment does not even make sense...?

  • Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    Hi everyone

    I am new here. I have a ender3 pro ,cr touch, mb 4.2.7, with a creality 3d mini pad touch screen.

     

    Crealitity thunmnail. cura package.  says to move it to cura and then restart cura. i have done this but no thumbnail appears on lcd screen what did i miss doing in cura. thanks

  • Link to post
    Share on other sites

    Posted · Cura Settings not coming every time...

    I'm not familiar with that package in particular but generally for thumbnails you need to add them in a post-processing script. In Cura, go to Extensions > Post Processing > Modify G-Code. There's a generic "create thumbnail" script but I don't know if a third party package would use that or add its own, so look through the list, or it could just do it as a plugin, in which case look in the Extensions menu and see if it's added anything of its own.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 7 replies
      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
    ×
    ×
    • Create New...