Jump to content
Ultimaker Community of 3D Printing Experts

Autoscale problem with version 2.10


john8888
 Share

Recommended Posts

Posted · Autoscale problem with version 2.10

Before version 2.10 a Fusion project in inches would Make/Print and open in Cura with no problems.  It now auto scales and is too big to re-scale in Cura so I have to scale in Fusion before printing then rescale back after!  Any way to turn this feature of?

 

Don't all jump on me for using obsolete units.  I'm making reproductions of 19th century devices from original plans.

 

Thanks

  • Link to post
    Share on other sites

    Posted · Autoscale problem with version 2.10

    You can configure Cura in the application preferences if you want to scale very small models and/or very large models. If I remember correctly the checkbox to scale very small models is checked by default. So you can just disable that.

  • Link to post
    Share on other sites

    Posted · Autoscale problem with version 2.10

    If you designed the part in inches then select the model and set the scale to 2540%.  You could scale the model up in the cad software just so you could export it but I've always found that to be an unnecessary step.  It really doesn't matter so long as you know the conversion factor whether it's from decimal feet to millimeters or whatever.

  • Link to post
    Share on other sites

    Posted · Autoscale problem with version 2.10

    The original is 3 inches which CURA thinks is 3mm - OK as STL is dimensionless.  Settings to scale large or small have no effect when importing to CURA.  In CURA I have to scale 2540 before every print.

     

    This used to work so either there was a change in 2.10 or I did something really dumb (quite possible!)

     

    Rescaling in CAM works but now all the dimensions are "wrong"

     

    Thanks

  • Link to post
    Share on other sites

    Posted (edited) · Autoscale problem with version 2.10

    Every system I've come up with to get around the scaling problem has had their pluses and minuses.  I'd have a large assembly drawn in metric and then open a catalog and have to model a purchase component that was drawn in Inches.  So I'd usually draw it in inches so I wouldn't have to sit with a calculator in my lap and when it was done I'd scale it by 25.4 so it would fit into the assembly.

    Cura's "Scale Extremely Small Models" default is 10000%.  I think it would be handier if the default was 2540% or if there was a toggle so it could be made 2540%.  Maybe I'll put in a feature request over on GitHub.

    EDIT...I put in the request.

    Edited by GregValiant
  • Link to post
    Share on other sites

    Posted · Autoscale problem with version 2.10

    This is way confusing.  With scale small ON a 3" cube goes to 3mm and a 1" to 100mm!  With scale small OFF 3" goes to 3mm  and 1" goes to 1mm.

     

    If a change is made forget small and large settings.  Just have autoscale with a default value of 1.  We can use any units in the CAM and set whatever scale we need for the print.  Simple and consistent.

     

    Someone may be working with different CAM units on different designs so one might argue that the auto scale value should be associated with the printer so choosing printer sets the scale.  Personally I think that's really picky and just getting an autoscale setting would solve lots of immediate issues.

     

    Thanks

  • Link to post
    Share on other sites

    Posted · Autoscale problem with version 2.10
    1 hour ago, john8888 said:

    This used to work so either there was a change in 2.10 or I did something really dumb (quite possible!)

    Well, one thing you are doing wrong is reading the version number of Cura. There never was a Cura 2.10, so I am guessing you mean Cura 4.10.

  • Link to post
    Share on other sites

    Posted · Autoscale problem with version 2.10

    Oops!   4.10.0

    • Like 1
    Link to post
    Share on other sites

    Posted · Autoscale problem with version 2.10

    AHoeben responded to my feature request over on GitHub.  It turns out that I'm behind the times again.  The Mesh Tools plugin can be found in the MarketPlace.  When it loads - the tools become available on the right click menu.  There is also a sub-menu added to Extensions so it's Extensions | Mesh Tools | Mesh Tool Settings... and then choose your favorite units for your imported models.  Most units are there but he left out Cubits.  Noah would be in some trouble especially since there doesn't appear to be a utility to convert PencilCad from papyrus to STL.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
         
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...