Jump to content

Issues with new 5.3.0 firmware


Deb

Recommended Posts

Posted · Issues with new 5.3.0 firmware

Hi.. we have updated Ultimaker 3 with firmware 5.3.0 but after installation the printer kept showing that the firmware still needs updating- it kept doing this on a loop. Also after the update the printer lost connection over the network.  Sometimes it's connected for a few seconds and then it loses connection. CURA version is 4.11.0.  Anyone experiencing this please? And any tips? Thanks

  • Link to post
    Share on other sites

    Posted · Issues with new 5.3.0 firmware

    Regard the update loop, here is an explanation, but you can just ignore it:

     

    I think any other issues you see with 5.3.0 are not related to the firmware, because the only change in 5.3.0 is that UM has renewed the root ca certificates for the digital factory connection.

  • Link to post
    Share on other sites

    Posted · Issues with new 5.3.0 firmware
    20 hours ago, Smithy said:

    I think any other issues you see with 5.3.0 are not related to the firmware, because the only change in 5.3.0 is that UM has renewed the root ca certificates for the digital factory connection.

    Yes but well, not exactly...

    For the UM3 specifically we did have to change a lot, we're not sure why, but we had to enable TLSv1.3 to get it to work with the new certificate, previously TLSv1.2 was fine, to do that we had to update python, libssl and all it's dependencies including the indirect dependency that is nginx (the web-server on the printer) .

    So there are quite a few changes, though none "should" have influence on printing and the printer applications.

     

    21 hours ago, Deb said:

    Sometimes it's connected for a few seconds and then it loses connection.

    We did have to update some standard packages to get the WiFi working correctly, though I haven't seen or heard about any problems like this. If you are on WiFi, can you check if you experience the same problems when connecting trough Ethernet (wired cable).

    • Thanks 1
    Link to post
    Share on other sites

    Posted · Issues with new 5.3.0 firmware
    On 10/7/2021 at 9:42 AM, robinmdh said:

    For the UM3 specifically we did have to change a lot, we're not sure why, but we had to enable TLSv1.3 to get it to work with the new certificate, previously TLSv1.2 was fine, to do that we had to update python, libssl and all it's dependencies including the indirect dependency that is nginx (the web-server on the printer) .

    Thanks für the clarification, I am not a full time python developer, but I do a lot of python in our company, so I can imagine that it was a hard weekend for all of you guys.

     

    So thanks for your work to bring a fix for the SSL issue so fast!

    • Like 1
    Link to post
    Share on other sites

    • 1 month later...

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.8 beta released
        Another Cura release has arrived and in this 5.8 beta release, the focus is on improving Z seams, as well as completing support for the full Method series of printers by introducing a profile for the UltiMaker Method.
          • Like
        • 1 reply
      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
    ×
    ×
    • Create New...