Jump to content

Solidworks plugin Cura 4.12 does not work


Trickle

Recommended Posts

Posted (edited) · Solidworks plugin Cura 4.12 does not work

Hi I wanted to ask. Does anyone also have a problem with the Solidworks plugin after upgrading to 4.12.0? I tried reinstalling the plugin and still nothing. I'll open the sldprt file. He'll write to me after a while. That the file does not exist or that there are no bodies.

Here is the log:

2021-11-18 11:45:57,404 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [112]: Exception: Exception occurred while loading file D:/R1z0/Project/vyztuz_postele.SLDPRT
2021-11-18 11:45:57,412 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]: Traceback (most recent call last):
2021-11-18 11:45:57,419 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]:   File "C:\build\Cura\4.12-exe\build\inst\lib\python3.8\site-packages\UM\FileHandler\ReadFileJob.py", line 78, in run
2021-11-18 11:45:57,426 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]:   File "C:\build\Cura\4.12-exe\build\inst\lib\python3.8\site-packages\UM\Mesh\MeshFileHandler.py", line 36, in readerRead
2021-11-18 11:45:57,432 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]:   File "C:\Users\R1z0\AppData\Roaming\cura\4.12\plugins\CuraSolidWorksPlugin\CuraSolidWorksPlugin\CadIntegrationUtils\CommonComReader.py", line 127, in read
2021-11-18 11:45:57,438 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]:     result = self.readOnMultipleAppLayer(options)
2021-11-18 11:45:57,444 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]:   File "C:\Users\R1z0\AppData\Roaming\cura\4.12\plugins\CuraSolidWorksPlugin\CuraSolidWorksPlugin\CadIntegrationUtils\CommonReader.py", line 329, in readOnMultipleAppLayer
2021-11-18 11:45:57,449 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]:     self.closeForeignFile(options)
2021-11-18 11:45:57,454 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]:   File "C:\Users\R1z0\AppData\Roaming\cura\4.12\plugins\CuraSolidWorksPlugin\CuraSolidWorksPlugin\SolidWorksReader.py", line 755, in closeForeignFile
2021-11-18 11:45:57,461 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]:     self.activatePreviousFile(options)
2021-11-18 11:45:57,467 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]:   File "C:\Users\R1z0\AppData\Roaming\cura\4.12\plugins\CuraSolidWorksPlugin\CuraSolidWorksPlugin\SolidWorksReader.py", line 470, in activatePreviousFile
2021-11-18 11:45:57,472 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]:     if options["sw_previous_active_file"] and "GetTitle" in dir(options["sw_previous_active_file"]):
2021-11-18 11:45:57,477 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]:   File "win32com\client\__init__.py", line 127, in __dir__
2021-11-18 11:45:57,484 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]:   File "win32com\client\dynamic.py", line 208, in __dir__
2021-11-18 11:45:57,489 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]:   File "win32com\client\dynamic.py", line 217, in _dir_ole_
2021-11-18 11:45:57,494 - ERROR - [JobQueueWorker [3]] UM.Logger.logException [116]: pywintypes.com_error: (-2147352565, 'NeplatnĂ˝ index.', None, None)

 

Edited by Trickle
  • Link to post
    Share on other sites

    Posted · Solidworks plugin Cura 4.12 does not work

    YES!!! it has been bugging the crap out of me I wish I didn't upgrade. I even tried emailing the developer but got no response. This topic needs more discussion. I can usually get it to work after 4-5 reboots of either cura solidworks or my computer. 

  • Link to post
    Share on other sites

    Posted · Solidworks plugin Cura 4.12 does not work

    The only solution that I can offer here is having a look at the subscriptions that Ultimaker offers. One of the features that you get it is built in support for various CAD files (including solidworks parts).

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
         
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    ×
    ×
    • Create New...