Jump to content
Ultimaker Community of 3D Printing Experts

Cura putting too much space between lines.


Mlogue9
 Share

Recommended Posts

Posted (edited) · Cura putting too much space between lines.

Well, over the past few weeks cura 4.12 has started to underextrude - well made gcode files that did so. I finally took a single layer to a caliper and measured. My lines are set at 0.4mm, same as the nozzle, and yet only 2.5 lines are within 1.6mm with much empty space. There should be 4 lines. I don't see an option for space between lines, there's line width and thats it. If it means anything I have a bunch of custom line directions [45,135,15,105,75,165]. I don't think it's the printer because i tried an old gcode I sliced last year, it printed fine with lines approximated. 

 

So with the lines overspaced, none of my prints are finishing. I can compensate with flow to like 150%, but then I get artifacts from overextrusion! Please help.

Edited by Mlogue9
Ruled out printer
  • Link to post
    Share on other sites

    Posted (edited) · Cura putting too much space between lines.

    The Line Width IS the index distance between two adjacent extrusions.  That's how Cura calculates the size of the rectangle it has to fill.  When you factor in the length of the extrusion you get the volume of the extrusion.

    The E values in the Gcode are calculated to provide that volume of filament for any extrusion.  If you have gaps between the lines then it is under-extruded.  The question is why it is under-extruding when older gcodes do not.

     

    What filament diameter do you have entered in Cura?  Does it match what the printer uses?

    Are all the flow rates under "Material" at 100%?

    Checking the printer - is Volumetric Extrusion (E in mm³) turned on?

    If Volumetric is turned off on the printer (normal) then check the Gcode flavor in Cura.  It should not be set to Volumetric if the printer is not set to Volumetric.

     

    If you would load a model and set Cura up to slice and then use the "File | Save Project" command and post the 3mf file here someone will take a look.  Since the older Gcodes are fine, that lets the printer off the hook (mostly).  I don't like to guess, but when it's a question regarding something that is essentially very simple math then the problem is usually a setting in Cura that is conflicting with the printer.  Cura is calculating the E values by one method and the printer is interpreting it as another method.  As you've found out, the result of that is scrap.

     

    One more thing - what printer?

     

    Edited by GregValiant
  • Link to post
    Share on other sites

    Posted (edited) · Cura putting too much space between lines.

    I have a 0.4 nozzle and 0.4 is whats selected for nozzle in Cura (4.12) up top, line width is 0.4 under Quality. Filament under machine settings, extruder is 1.75mm. Volumetric is not enabled on printer - it's an ender 3 machine. Its a BTT Silent board running Marlin. The extruder is dual gear and aftermarket but neither correlate to issue. The change *seems* to be something I must of inadvertently changed in cura. I've been using 4.12 fine for month or more but it's been the last week, so i'll post an older gcode (bedlevel - it prints ok). I am pretty sure it's my fault and i really really appreciate your follow-up questioning! Oh Flow - i usualy keep it at 100% in cura and change it on the printer. In response to the issue I jacked it up to 120% in cura and 110% on the machine - so 133% or so... but with both at 100% I still had these weak prints.

     

    It's almost like it's printing a raft, that's what it looks like, just real fine, but they are not spaced 400um.

     

    I have depression so it affects my memory so if i forgot something sorry and thank you!

     

    ---

     

    Oh I have linear advance k at 0.45

    testCube.3mf testCube04x012_MINENOV3.gcode BedLevel+KIII04x02NOV6IPOH03x008_NOV6IPOH.gcode

    Edited by Mlogue9
    Linear Advance
  • Link to post
    Share on other sites

    Posted · Cura putting too much space between lines.

    I made a couple of changes to the testcube04x012....Gcode file to accommodate my Ender 3 Pro (no linear advance, etc.).  I printed a few layers and it was perfect until it got to the infill.  That printed way too fast at 120% flow so I went back and looked at your speeds in the 3mf file.  They are all over the place.  The flow rate through the hot end (mm³/sec) is jumping up and down.  That alone will make printing inconsistent.

    I took your profile, made a couple of adjustments to what I know works on my machine, made the speeds consistent, got rid of Z-hops and retract at layer change and some other things.  I kept the layer height at .3 and the various line directions settings.  Attached is a gcode file and a project file.  There is no bed leveling or baby-stepping in the gcode as I'm a paper guy but it should print on your machine.  You could slice the 3mf file and your startup gcode would be in place.

    The Gcode file prints excellent on my printer with the 1.1.5 board and Marlin 1.1.8.

     

    After changing the extruder and the mainboard you did re-calibrate the E-steps correct?

     

    There are two models here.  Both were sliced with 4.12.1.  The beer bottle is included because it's close to flawless as far as I can tell.  The flat print is your model using the gcode attached below and on the same printer.  It also looks very very good.

    DSCN2760.thumb.JPG.c3223e8a87a01d5b0c1b5ffa368cd8c0.JPG

    GVBooster.3mf GVUntitled.gcode

    • Like 1
    Link to post
    Share on other sites

    Posted · Cura putting too much space between lines.

    Well I think i needed to brush more often, hehe, my gears were clogged so > underex. 

     

    Something in your profile works, because while lines still don't meet when I stepped it up to printing a 0.3mm layer, there WERE 4 in a the span of 1.6mm - as opposed to 2.5. Thanks much. I like the GCODE lcd messages too.

     

    https://photos.app.goo.gl/W7zp6fCd16wTRnEd6

  • Link to post
    Share on other sites

    Posted (edited) · Cura putting too much space between lines.

    Congrats on finding it.

    Regarding the screen message -

    If you go to Extensions | Post Processing | Modify Gcode you will bring up a dialog for the post-processors.  Within the scripts are "Display Progress And Layer On LCD" and "Display Progress On LCD".

    The one I use is a bit different and is in the Zip folder attached below.  Extract the file and then copy it to the (for Windows) "...C:\Program Files\Ultimaker Cura 4.12.1\plugins\PostProcessingPlugin\scripts" folder and the next time you start Cura it will be available in the list of scripts.  You will notice in the gcode there is an M117 line that sends the message to the LCD and there is also an M118 line that bounces the same message to my host program.  It has a fudge factor for the time and I've found  that setting it to 1.1 makes the actual print time really close to what is being shown on the LCD.

    It isn't a part of Cura so when you upgrade the software you would need to manually copy and paste ShowProgress.py back in for the new version.

     

    ShowProgress.zip

    Edited by GregValiant
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...