Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
eoghanm

beads on calibration lines; bed levelling wizard; start/stop - solved

Recommended Posts

Hi,

I built an original UM and got it working fine at the weekend. Then I moved it to a different location. When I run the bed-levelling wizard I get beads along the calibration lines and it is clear that the printer is losing its way. It 'thinks' it is still moving when the beads are being printed.

I am using the USB controller from a PC. The problem (start/stop) is happening on all three axes and it seems to be quite regular (as you can see from the pattern).

beads on calibration lines.

 

Since it is happening on all three axes I don't think it is a problem with an individual motor or pulley. I have retightened all the pulleys though.

 

I am not sure the fan by the electronics board is definitely on; is it a problem with thermal cutouts?

 

Any help appreciated.

 

Share this post


Link to post
Share on other sites

Do you mean that it stutters along? Starting and stopping? I'd suspect the USB connection in that case. Disconnect everything you can that might cause interference, shut down every program you have running except cura. Consider giving cura/python elevated priority. If you have access to a different computer I'd try on that one as well to see how that goes. I'm assuming that you opted not to get the Ulticontroller here.

The fan that cools the electronics MUST run or you will indeed have problems with overheating stepper drivers. I'm not sure if that would cause this phenomena (not sure how long they shut down before starting back up again).

Actually before any of that, when this happens does the extruder gear keep turning? I'm assuming it stops together with all the other motors, correct?

 

Share this post


Link to post
Share on other sites

I'd suspect the USB connection

 

At first I thought - robert is clever - he thought of something I didn't consider. But thinking about it more I think the moves during calibration are single LONG moves. So I don't think it's USB related.

I would check the power supply voltage - the 19V - see if it is dropping down to 12V or something a few times per second.

I would get prontrface - it's free:

http://koti.kapsi.fi/~kliment/printrun/

Connect to the printer with that and do controlled movements of 100mm at a time at different speeds. Try to figure out what is going on. I've never heard of this. Maybe post a video?

 

 

Share this post


Link to post
Share on other sites

Thanks for the responses so far. I am uploading a video to show better what I mean.

Bead printing

As you can hopefully see the extruder continues to move smoothly while the head is stuttering along. I think this why I am seeing 'beads' the PLA is being laid down even though the head isn't moving.

I have tried disconnecting everything else, closing everything else down etc. Ran laptop on battery instead of power supply. Tried plugging printer into a different plug. No difference on anything there. I will get a different computer and update then. Hopefully it is just a USB issue. Although the same computer worked fine at the weekend.

 

Share this post


Link to post
Share on other sites

Ok, since the extruder keeps moving I don't think it's USB issues. I think everything stutters in that case, but I've never had the problem myself so I'm not entirely sure.

I'm hearing a weird clunking sound in the video though, in the video it's heard half a second or so before the head stops. Is that the way it is in reality as well or is there a sound syncing issue in the video? It almost sounds like a belt slipping (but it doesn't look like it does on the video). Can you identify where it's coming from?

 

Share this post


Link to post
Share on other sites

As best I can see there aren't any pulleys popping. There is a clunking noise at times. I think the noise is coming from the motors.

If I turn off the power and push the head around it doesn't feel completely smooth but I wouldn't say there is a lot of resistance either.

I have tried another computer and the same problem recurred.

When the firmware was installed it was done from a Mac, but it worked fine with the PC I am using after that.

I had the speed set quite low (20mm/s), could this be part of the problem?

 

Share this post


Link to post
Share on other sites

No. 1mm/sec is fine. 300mm/sec is fine.

Install prontrface. There's a link in my post above. Move 100mm at a time. Listen carefully where the thunk is coming from. Something must be rubbing or getting stuck or something very weird is happening. I doubt it's the electronics but I'm not certain. In fact move both axes at once and see if they both pause at the same moment. If so then it's probably your power supply is fluctuating from 19V down to 6V or something like that and the 6V isn't enough power to move the steppers. But this seems very unlikely.

In order to move both axis at the same time, home X and Y using prontrface, then use gcodes in the right window:

G1 X100 Y100

will move both axes in a diagonal line to the center of the print bed

G1 X0 Y0

will go back to home

Repeat those. You can set the feedrate also (in mm/minute):

G1 X100 Y100 F1200

(1200 would be 1200mm/min or 20mm/sec).

Once you set the feedrate once it stays with that feedrate until you tell it a new one so you don't have to keep sending the same feedrate.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!