Jump to content
Sign in to follow this  
stevegt

Z axis homing inconsistent on UM2: workaround and patch

Recommended Posts

Posted · Z axis homing inconsistent on UM2: workaround and patch

Did you check with a gcode produced by the latest Cura? As i said it happened to me with the previous firmware but doesn't seem to happen anymore with 14.06

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

Didier, I did not.

It's an interesting test, however I strongly feel that the new firmware needs to be backward compatible - at least with 14.x. Most people have hundreds of models already sliced in previous versions and I would say this behaviour is far from acceptable.

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

Also, a little tip to everybody who has experienced the grinding.

It can be time-consuming to clean the mess that grinding does.

It is hard to access the grub/socket screw that locks the feeder screw in place to the motor shaft. Basically you need to disassemble the feeder to access it at a straight angle.

What we have done is to just use a power drill to remove some material from the black ring of the plastic housing. Then after aligning the socket/grub screw you can easily access it with the smallest key in UM2 kit or a Torx T6 screwdriver.

See attached pictures:

Make a little entry point for accessing grub/socket screw by drilling out material

torx6 or the smallest key in UM2 package

Motor D Shaft

grub/socket screw flush with motor axle

 

The last image is from the assembly manual. I added it because it shows clearly that the feeder screw/sleeve should be flush with the top of the motor shaft/axle.

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

Concerning the filament grinding,

Would it be possible to lower the motor current at the fast forwarding part of the priming cycle?

Or even better, when the filament is fast forwarded in general?

That way you could make sure the filament has reached the head with no risk of grinding it down.

You could then run the final part of the priming at a low feed rate so that the filament has time to melt and thereby avoid grinding.

My Z-axis calibration is still a bit strange with 14.06.1 by the way.

The gap between the head and the platform still increases with about 0,1mm at some point after the calibration was done, possibly at first power cycling. But it then stays at that distance it seems like, so I can accept it as it is now.

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

And this is the topic i started a couple of weeks ago with the same behaviour.

http://umforum.ultimaker.com/index.php?/topic/5637-feeder-grinding-on-startup-while-plate-is-leveled-up/

It's odd i don't understand why it looks like it's solved for me with the latest firmware but shows up to others...

I have to confirm that it doesn't happen to me anymore for me

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

Oh sorry Didier, I didn't see your post.

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

I am having problems not with Z axis homing but with X axis homing and it makes an awful noise as it homes X and Y. This has all happened since the firmware upgrade. Am now thoroughly stuck and unable to print. It was working fine until then and cant get back to the versions I was using successfully before hand.

Any suggestions or threads to follow?

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

Which firmware upgrade are you using?

When does the 'horrible noise' happen? it sounds like maybe you aren't triggering the end stops properly? Have you checked whether the cross rods that go through the head are fully seated into the sliding blocks.

If you power off the printer and move the head by hand, does it move smoothly? Do you feel and hear the end stops clicking in the back right corner before the head/fans crash into the frame?

You can download a previous version of Cura, and install the firmware from that... but it may be best to try performing a 'factory reset' on the printer. Remove the filament first, and then go into the maintenance advanced menu and perform a factory reset. Then go back through the leveling and filament load process.

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

I am having problems not with Z axis homing but with X axis homing and it makes an awful noise as it homes X and Y. This has all happened since the firmware upgrade. Am now thoroughly stuck and unable to print. It was working fine until then and cant get back to the versions I was using successfully before hand.

Any suggestions or threads to follow?

 

Is it making the awful noise as it is moving, or is it making the noise as it presses the X axis against the end? (Do we know it's the X axis making the noise, and not Y or the feeder?) Is the noise coming from the motor, or from some other part? If you're not sure, try using a piece of flexible tubing as a stethoscope.

You might benefit from starting a new topic. While I can't rule it out, I can't think of anything in the 14.06.1 upgrade that could cause the symptoms you're seeing. You're coming from 14.03, I take it?

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

Thank you both for your help.

All rods ok, and I checked the x axis endstop which I can trigger by hand but the head was not triggering it. I think that the fan mounting had got bent somehow and was pushing up against the side and preventing the tigger by a mm. I have now resolved the homing issue.

I have gone back to 14.06.1 and reset to the default factory settings. What is odd is that any of the previous models on the card now print off the bed so maybe I need to save as new G code in this new version of CURA.

Its not printing on the same place on the bed as in the diagram so there seems to be some offset here. This may be another topic and I shall search for that. At least its printing again for the purposes of the talk I need to give.

 

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

Is your firmware version now 13.06.2? Thats the one that comes with the latest Cura (13.06.1).

Most likely you just need to rerun the bed leveling routine on the printer. There's definitely no need to re-save the gcode in the newer Cura. There's nothing in the slicing process that would change from version to version about z-height.

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

The offset on the bed that you are seeing is probably just caused by the fact that the print nozzle is offset from the center of the head. The single nozzle actually covers an area of the bed that is shifted slightly to the left of the entire physical plate. When a second nozzle is added alongside, it will cover an area slightly offset to the right. The print area that is defined and shown in Cura is actually the area that the left hand nozzle can reach, not the entire build plate (which extends a bit further to the right).

So everything prints slightly to the left of where it looks like it will print in Cura.

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

I have tested the 14.06.1 for some time now and have come to the following conclusion about the Z calibration on my machine:

If I run the buildplate leveling procedure using a 0.1 mm thick paper for the Z-calibration then the first layer will print 0.1 mm thick until I power cycle the printer.

It does not matter what I do to the printer, like pushing the platform down when in lower position, running lower buildplate and so on. The first layer will still be 0.1 mm after leveling until i power cycle it.

After power cycling the first layer is suddenly 0.3 mm and stays like that no matter how many times I power cycle it.

I have already reset the default settings on this firmware a few times so suppose it should be properly initiated.

The models I have tested so far are supposed to print 0.3 mm initial layer. I have not tested 0.2 mm initial layer yet, so I don't know what will happen then.

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

So, it sounds like you are saying that the correct bed level is only achieved *after* you have power-cycled the printer?

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

I have tested the 13.06.1 for some time now and have come to the following conclusion about the Z calibration on my machine:

If I run the buildplate leveling procedure using a 0.1 mm thick paper for the Z-calibration then the first layer will print 0.1 mm thick until I power cycle the printer.

It does not matter what I do to the printer, like pushing the platform down when in lower position, running lower buildplate and so on. The first layer will still be 0.1 mm after leveling until i power cycle it.

After power cycling the first layer is suddenly 0.3 mm and stays like that no matter how many times I power cycle it.

 

Hi Anders,

Something's strange here. Can you read me the build date/time and version number that shows in Maintenance|Advanced|Version on your printer?

Steve

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

Hi!

Sorry, I accidentally wrote 13.06.1 in the previous post, that is wrong, here is the info:

Jun 5 2014 09:13:03

Version 14.06.1

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

Thanks Anders. Okay, that's the exact same version I'm running. I'm not going to have time to do any testing today, but I'll see what I can do, either tomorrow or this weekend, to try to duplicate what you're seeing. If you can give me any more details and/or an exact duplication procedure that should help.

If anyone else gets to this first, here's what I'm thinking so far: I don't think Anders is seeing a Z homing bug; this sounds like something else. I'd like to eliminate that as a possibility though, and I'm curious to see if what he's seeing might explain some other issues I've noticed. I tend to print thin first layers, and my leveling rings utility defaults to .1 mm as well, so I would not have noticed anything as directly.

Notes to self: Check with feeler gauges. Try running leveling rings with a .3 mm thickness.

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

I recall something like power cycling being needed on the very first units...Anders, what is your serial number/when did you receive your unit?

I think Daid might know if I might be right or not...

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

Yes, this issue seems not to be directly related to the Z-homing issue.

I think my machine always has been like this, but before the 14.06.1 firmware it was not as consistent, so it was difficult to figure out exactly what was wrong back then.

It is not a major issue for me now that I know I have to power cycle after leveling the build plate.

However, I might not be the only one with this issue so I thought it might be good to tell people here.

To duplicate it, just level the build plate with a 0.1 mm paper and print something which has 0.3 mm initial layer thickness.

Power cycle and print the same thing again.

On my machine first print will have about 0.1 mm initial layer thickness and after power cycling it will be 0.3 mm (as it should be).

My machine was delivered in mid January and has serial UM2A05-MES1337xx

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

That's all most helpful and I managed to do a nice high quality print again which was very satisfying. Appreciate your prompt follow up and advice. Thank you.

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

To duplicate it, just level the build plate with a 0.1 mm paper and print something which has 0.3 mm initial layer thickness.

Power cycle and print the same thing again.

On my machine first print will have about 0.1 mm initial layer thickness and after power cycling it will be 0.3 mm (as it should be).

 

I haven't been able to duplicate this yet myself -- in my own case, I appear to be getting 0.3 mm both on the first print after leveling as well as after a power cycle. Disclaimer: I'm using leveling rings with a 0.3 mm thickness, rather than a standard print, so my test may not be valid. Still thinking.

Anders, exactly how are you measuring the 0.1 vs 0.3 thicknesses? Aborting during the first layer and then using a caliper?

 

Share this post


Link to post
Share on other sites
Posted · Z axis homing inconsistent on UM2: workaround and patch

I mostly measure the thickness of the prime frame that prints before the print starts with a digital caliper.

To get better priming of the head I have been printing a double frame lately.

It is obvious too when I look at the first layer that it prints way to close to the platform before power cycling.

It takes several layers of printing before the excess plastic from the first layer is hidden within the printed object. The outer dimensions of the first layers of the print will also increase due to the excess plastic.

Last few days I tried calibrating the nozzle slightly close to the platform to get the plastic to stick better. I usually get like 0.3-0.35 mm after power cycling and now it is like 0.25 mm.

The distance stays consistent at 0.25 mm after power cycling, so on my machine it seems everything works like it is supposed to after it is power cycled.

If no one is experiencing this problem, maybe it is just something with my machine. Don't waste too much of your time with this in that case. I can live with it as it is now :smile:

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!