Jump to content
Ultimaker Community of 3D Printing Experts
CT2015

Firmware update to UM2

Recommended Posts

Hi,

Cura does not recognize cable connection from pc to UM2 and keeps telling me to connect cable. I have checked USB ports and had cable checked. What should I do next?

This started because my UM2 will not recognize new files that I have generated in Cura to print. However it does recognize the files that came with the printer. These files are dated early to mid 2014 so I thought maybe it was just a matter of updating the software. The machine is new, just received it 1 week ago and have not had any problems printing from the files provided on the san disk.

Help!

Thanks,

CT

Share this post


Link to post
Share on other sites

Hi @CT2015,

How do you mean it won't recognize the files?

They don't show up on your SD card?

- Maybe your SD card is faulty. Do you do save removals?

- Are you using the custom SD card, different brands not always work.

Does it say the file will overrule some settings?

- Are you sure the files you have sliced are sliced for the Ultimaker 2?

In Cura you have the option to slice for every member of the Ultimaker family.

Perhaps it was set to a different machine.

If you can give a little bit more details on what is happening it will probably guide us in the right direction.

Thank you!

Share this post


Link to post
Share on other sites
Hi @CT2015,

How do you mean it won't recognize the files?

They don't show up on your SD card?

- Maybe your SD card is faulty. Do you do save removals?

- Are you using the custom SD card, different brands not always work.

Does it say the file will overrule some settings?

- Are you sure the files you have sliced are sliced for the Ultimaker 2?

In Cura you have the option to slice for every member of the Ultimaker family.

Perhaps it was set to a different machine.

If you can give a little bit more details on what is happening it will probably guide us in the right direction.

Thank you!

I'm using the SD card that came with the Ultimaker 2 which came with several files that work fine when printing. I've down loaded a couple of files from YouMachine. Ran the file through slice set for Ultimaker 2 then saved to SD. The new files don't shown up on the Ultimaker 2 screen where it allows me to select which program to run.

The files that came on the SD from the factory are dated Feb 2014. That lead me to believe that the firmware might need to be updated since I'm running Cura 15.02.1 and since it appears that have been some recent updates released.

I'm not able to run update for firmware because Cura returns a message telling me to plug the cable into the Ultimaker 2 even though it is plugged in and the printer is on. I've had the cable checked through my IT dept. who are telling me they don't see a problem with the cable. I've tried plugging in to the (3) USB ports, but no luck. Could the antivirus block this type of connection?

Thanks for you help!!!

Share this post


Link to post
Share on other sites
connect pc and Um2 with cable.

Wait until PC stops doing anything.

IF after 3 mins nothing happens, turn UM2 off and on again.

Wait.

IF  not recognized by PC, change usb port.

Tried as you recommended...still did not work.

Took my computer down and had all the USB ports checked, everything is normal.

Bought a new cable, just in case.

Just finished running through the whole thing again and still have the same issue.

Frustrated....

Share this post


Link to post
Share on other sites

I could get you connected to USB but this won't help anything. You have a brand new printer and even printers 2 years old recognize files on the SD card. I suggest you forget about USB unless you have a different reason. If you really really want to connect USB start a new thread.

Now to your problem - files not showing up on your SD card. I suggest we concentrate on that. Put the SD card into a PC and look at all the files. They should all end with ".gcode" but most likely the newer files you put on there don't. By default windows hides the extension of files so you might want to fix that in explorer in settings but not necessary as it should show the file "type" as gcode also.

When you choose "PRINT" on the UM2 panel, it should list all files that end with ".gcode". If not then something is probably wrong with the SD card but much more likely the files don't end with ".gcode".

Share this post


Link to post
Share on other sites

Im using new cura and never used the usb on my ultimaker ever. I also only use the memory card that came with the ultimaker, and have only had one case where the file saved incorrectly from cura because the options suddenly appeared defferent on the ultimaker, i just went to cura again, redid it and it was ok. I bought ultimaker last september and am also on cura 15.02.01. if that helps. im using everything defult and also dont play with setting to much. if you want send me the files via wetransfer and ill take a look?

P.S. if your models are extremely thin, they will show in cura but not in the layer mode, and will print nothing. make sure yuor models have enough thickness to print. and use the layer mode in cura to check you model, this is a MUST if you want to get results that you expect.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!