Jump to content
Ultimaker Community of 3D Printing Experts
aleciuf

Ultimaker 2+ custom material settings

Recommended Posts

Hi there,

I set a custom material settings on my Ultimaker 2+ (material -> settings -> customize) and I saved it as custom but, when I try to print a file on SD card exported from Cura (last version) with PLA profile, the printer notifies me: "This file is created for a different material" and It leaves me two choices: "Cancel" -> doesn't print; "Continue" -> printing begins but with standard PLA settings, ignoring the custom settings...

How do you print with custom settings?

Share this post


Link to post
Share on other sites

What? This sounds very new. What version of Cura are you using? How do you set PLA in Cura? I've never seen that before.

One workaround - print it with any material settings, then while the printer is heating up, go to the TUNE menu and change the settings to whatever you want. It won't start printing until you exit the TUNE menu.

Another workaround - change the values for PLA then do SAVE SETTINGS then choose PLA after you save. This will change the settings for PLA. I like the first workaround better.

But... what version of Cura do you have?

Share this post


Link to post
Share on other sites

I've never seen that error. What version of Marlin do you have? That's a new feature I think. I would open the CURA file in a text editor and search for PLA on the first few lines and change it to PLAf and also change your material name to PLAf and see if that helps. This really looks like a new bug/feature.

it could be related to a known bug in marlin talked about here and easy to fix but I doubt it:

https://ultimaker.com/en/community/19700-what-are-the-various-parameters-in-the-materialtxt-file?page=last#reply-136309

Read tinkergnome's posting and note the bold parts and then read the first posting.

Alternatively get rid of that space between "PLA" and "flex"?

Share this post


Link to post
Share on other sites

I'm still using cura 15.04.4.

Hey @nallath!  Do you know about this new feature in Marlin??  Look at the photo just above.

 

I'm using 15.04.4 too...

Looking at the first few lines in the .gcode file, I have the following:

 

;FLAVOR:UltiGCode

;TIME:2694

;MATERIAL:2473

;MATERIAL2:0

;NOZZLE_DIAMETER:0.400000

;NOZZLE_DIAMETER2:0.400000

;MTYPE:PLA

;Layer count: 105

;LAYER:0

M107

.......

.......

.......

So I can change "MTYPE" to match the material's name set on the printer, but what about the line: ";MATERIAL:2473" ? What is it, some kind of material code?

About the Marlin version, how can I check it? I just purchased my UM2+ and I never changed it... Thanks for the support guys :-)

Edited by Guest

Share this post


Link to post
Share on other sites

MATERIAL -> Amount (in cubic mm if we're consistent)

MTYPE -> type of material

You can always ignore the warning. It's just there to help prevent mixups. Cura has the same logic; it will warn you if you use weird settings but will pretty much allow everything.

Share this post


Link to post
Share on other sites

MATERIAL -> Amount  (in cubic mm if we're consistent)

MTYPE -> type of material

You can always ignore the warning. It's just there to help prevent mixups. Cura has the same logic; it will warn you if you use weird settings but will pretty much allow everything.

 

Hi nallath, how can I ignore the warning leaving the printer use the custom material settings? Selecting "Cancel" the print doesn't start, while selecting "Continue", the printer switch to default PLA settings (then the profile exported with Cura)

Share this post


Link to post
Share on other sites

I'm not sure which is "leading" in this case. Is the selected material by machine leading or the one defined in the g-code.

Updating the firmware regularly is a good idea. We are far from perfect and have made mistakes (and fixed them) in the firmware / Cura.

Share this post


Link to post
Share on other sites

So there you go - delete the "MTYPE" from you gcode might be a reasonable fix for now until they get this firmware bug fixed. Or go with a slightly older firmware.

You can tell which version of firmware you have on the printer by going through the menus - start by choosing ADVANCED and look around from there.

Each version of Cura comes with a Marlin. You can update Marlin by connecting a USB cable to your printer and there are options in Cura for updating the firmware. Certain settings are preserved if possible (leveling position, hours printer has been used, material settings, motion settings) but sometimes updating Marlin does a "factory reset" because the settings are now in a new location in memory. "Factory reset" sets most those to defaults forcing you to relevel and recreate your material settings.

Share this post


Link to post
Share on other sites

Just bumping in because of that issue report.

First off, this warning is specific for the Ultimaker 2+.

The exact code where this check is done is here:

https://github.com/Ultimaker/UM2.1-Firmware/blob/UM2.1_JarJar/Marlin/UltiLCD2_menu_print.cpp#L456

The only extra logic that is executed in this case is this:

https://github.com/Ultimaker/UM2.1-Firmware/blob/UM2.1_JarJar/Marlin/UltiLCD2_menu_print.cpp#L689

And this bit that reads the MTYPE tag:

https://github.com/Ultimaker/UM2.1-Firmware/blob/UM2.1_JarJar/Marlin/UltiLCD2_menu_print.cpp#L274

As you can see, there is no logic there that changes the currently selected material in the printer. So as far as I can see, the material selection in the printer is used.

Share this post


Link to post
Share on other sites

Note that the material settings in the UM2 do act a bit odd. Instead of you having selected a certain material (Current material = PLA), you actually have a "copy" of that material selected. So if you change the PLA settings (or PLA Flex settings) by an import, your selected copy is not changed. So you need to re-select that material for the changes to be active.

I think this is more likely to cause this confusion here.

Share this post


Link to post
Share on other sites

Ah. Interesting. Did you get that @alecuif? Daid thinks you did something like this:

1) Created PLA Flex with same settings as PLA.

2) Edited PLA Flex on the SD card again and imported again (at this point you still have old PLA Flex settings)

3) Started a print and chose CONTINUE to the question above

4) Ended up with the *old* PLA Flex settings

In other words Daid doesn't believe that CONTINUE goes back to PLA. Could you test this one more time? Someone else needs to test for this bug. My only UM2+ has a different firmware (tinker marlin).

Share this post


Link to post
Share on other sites

Hi all and thanks for the support. I selected the material afte the settings change... here what I did:

- exported the materials settings from UM2+ to SD card

- removed the SD from UM2+

- inserted the SD into computer's card reader

- edited the file materials.txt

- duplicated PLA material lines:

 

[material]



name=PLA

temperature=210

temperature_0.40=210

temperature_0.25=195

temperature_0.60=230

temperature_0.80=240

temperature_1.00=240

bed_temperature=60

fan_speed=100

flow=100

diameter=2.85

 

 

- edited cloned lines with new settings

 

[material]



name=PLA flex

temperature=240

temperature_0.40=240

temperature_0.25=240

temperature_0.60=240

temperature_0.80=240

temperature_1.00=240

bed_temperature=60

fan_speed=100

flow=100

diameter=2.85

 

 

- saved the txt

- removed SD from computer and inserted back into the printer

- turned on UM2+

- imported edited material file from SD to printer

- selected new material (PLA flex) from material menu

- started a print

- printer showed me the alert "the file

- selected "continue"

at this point the print started but the nozzle temperature reached the 210 °C, while the "new" material I edited and selected was 240...

Anyway, I'll try again over week end :-)

Share this post


Link to post
Share on other sites

When selecting PLA Flex - hover over that for a while and it will cycle through all the settings - make sure it's "240".

Also after you select PLA Flex, try doing MOVE MATERIAL and see what the goal temperature is for that step also. Make sure that is *also* 240. Then start the print, etc.

Thanks for helping debug this issue @alecuif

Share this post


Link to post
Share on other sites

Hi all,

sorry for the delay, I've found that exporting the gCode from the "full settings" of Cura, in the gcode file there isn't the MTYPE line, so the selected material is used and no alert appears. While, exporting from the "quickprint" Cura's settings, the gcode has the MTYPE line.

So now everything is ok, probably I did a bit of confusion between settings and material selection...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • How to 3D print with reinforced engineering materials
      Ultimaker is hosting a webinar where we explain how you can achieve and maintain a high print success rate using these new reinforced engineering materials. Learn from Ultimaker's Product Manager of Materials and top chemical engineer Bart van As how you can take your 3D printing to that next level.
      • 2 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!